Jump to content

3.4.3 and newer - File type of .torrent is displayed as "uTorrent URI"


Recommended Posts

Observed behavior
In the Windows Explorer shell, the file type of .torrent files is displayed as utorrent URI.


Expected Behavior
A URI is a uniform resource locator. An example of a URI is a magnet URI, such as magnet:?xt=urn:btih:<SHA1_hash>. A .torrent file is not a URI and should not be labelled as such. I would suggest uTorrent file, µTorrent file, etc.


  • Correspondingly, the mainline BitTorrent client from version 7.9.3 on shows bittorrent URI as file type.
  • The same applies to .btapp, .btinstall, .btkey, .btsearch, and .btskin files.
  • The responsible registry keys are HKCR\.torrent (the <file_extension> key) and HKCR\utorrent (the <ProgID> key)
  • In older builds, i.e. 3.4.3 stable build 39744 and older, the file type wasn't specified in the registry at all, which means that the file type shown in Windows Explorer defaulted to TORRENT file, see http://i.imgur.com/pweMXEZ.png.
  • In contrast to the official name, utorrent is written without an upper case T and without the Greek letter µ.

Affected uTorrent builds
This was introduced with the new installer in 3.4.3 stable build 39944, and also affects all newer stable builds. Earlier beta builds from the new installer branch are probably also affected, i.e. build 31831, 32118, etc.

Link to comment
Share on other sites

  • 1 month later...
On 4.3.2016 at 9:31 AM, scholar25 said:

go to preferences, advanced, uncheck "true" on "store_tor_infohash".  Will revert the files back to the textual name and other options to download.

Well, "store_torr_infohash" was already set to "false", which is the default value. After changing the value from false to true, the old behavior (file type not specified in the registry at all, Windows default "TORRENT file" is displayed) did return.

However, it also caused collateral damage: All torrents with files set to "do not download" changed their state to "Files missing". The files which were set to "do not download" were suddenly marked to be downloaded again. After setting the files back to "do not download", the torrents rechecked to less than 100%, as if I had deleted the "~uTorrentPartFile_xxxxxxxx.dat" file.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...