Jump to content

Using Comodo Personal Firewall with uTorrent


Recommended Posts

Found this is the Comodo Forums, this made it work for me, enjoy!


A mini tuttorial of how to open ports for bittorent and similar p2p programs

Go at the "Network Monitor" panel and add the following rule

Rule for TCP/UDP protocol

Action = Allow

Protocol = TCP or UDP

Direction = In

Source IP = Any

Remote IP = your IP adress (or "Any" )

Source port = Any

Remote port = the port your bittorent program uses for the TCP/UDP connections

You must move the rules up, over the default rule "Block IP in". ( CPF "reads/applicates" the rules from the top to the bottom)

ps. Remember that for CPF "Source IP" is the adress of the computer which sends the data and "Remote IP" is the computer that receives them. When your computer sends data is consindered Source, when receives them is consindered Remote.

Link to comment
Share on other sites

  • 1 month later...
  • 8 months later...

"No, it won't be any less secure."

But wont some malicious person or software be able to "come in" from the open port ?

I tried grc:s port scan on the specified port that my uTorrent uses, and it said following:

--"Solicited TCP Packets: RECEIVED (FAILED) — As detailed in the port report below, one or more of your system's ports actively responded to our deliberate attempts to establish a connection. It is generally possible to increase your system's security by hiding it from the probes of potentially hostile hackers. Please see the details presented by the specific port links below, as well as the various resources on this site, and in our extremely helpful and active user community.

Unsolicited Packets: PASSED — No Internet packets of any sort were received from your system as a side-effect of our attempts to elicit some response from any of the ports listed above. Some questionable personal security systems expose their users by attempting to "counter-probe the prober", thus revealing themselves. But your system remained wisely silent. (Except for the fact that not all of its ports are completely stealthed as shown below.)

Ping Echo: PASSED — Your system ignored and refused to reply to repeated Pings (ICMP Echo Requests) from our server."--

Beacause if the port is open, wont people be able to connect to it or see that it is open, even when uTorrent is not active ?

Not trying to be smart-ass here, but could someone give more through explanation (or a link to such) of why this wont lower my security level ?

Im not a professional by any means, but what they tought me computer security class long long ago was port open = bad, port stealth mode (closed) = good :)

Link to comment
Share on other sites

An open port is only as vulnerable as the program listening on that port.

µTorrent is about the only thing that responds to whatever oddball port you're using.

And at this point, just by anecdotal evidence alone, I'd say it's pretty secure.

Immensely more people get viruses and trojans just surfing the internet.

Link to comment
Share on other sites

  • 3 months later...

Hi. I cant get my utorrent and comodo firewall pro to work. I have Network monitor rule set up, but it just wont work. Here's picture of settings that i curreltly have. Firewall version µtorrent 1.7.5

(EDIT) Sorry I all ready figured it out my self. I made 2 separate rules for udp and tcp. For some reason tcp or upd setting wont work.

[edit] well it stopped woking after reboot, I unistalled comodo since i had to put network rules off for while that utorrent set upnp and then put back on.

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...

I'm gonna bump this thread instead of making a new one (which I or someone else can do if necessary)

Comodo PF version 3 has been released (works with Vista, woo!)


So has anyone managed to set it up with good ol' µT?

I tried doing the way for the previous version but it didn't result in my port being allowed...

What I did was click on the Firewall button on the top, then the Advanced button, go to Network Security Policy, then Global Rules tab and Add a new rule changing only the setting on the last tab putting in my port in the Single Port option, then I moved the new rule to the top of the list and Tested in µT but no green light!

I had a look in the Application Rules tab too but there was no place to put in the port number.

Link to comment
Share on other sites

  • 3 months later...


This topic is now archived and is closed to further replies.

  • Create New...