Jump to content

I wish I didn't have to go back to Bitcomet!


Recommended Posts

After some hours spent trying to configure my router (which I managed to do, but without consequences towards the [poor] speed of uTorrent), I decided to give up. I'm going back to Bitcomet.

Ok, someone might say that configuring the router is the easiest thing in the world, there's even a guide that lead us step by step. Well, I followed the guide and still have the red light icon on my status bar.

I consider myself to be a relatively bright person, but I just don't have the time to improve my informatic skills towards static ip's, port forwarding, port mapping, how to resolve things when we go by the guide and still have no results and so on...

Maybe to the majority of the people who post on this site these are simple concepts, but to the average computer user this might cause quite an headache.

uTorrent is a great bitorrent client, if it wasn't for these issues it would be perfect. When I did a search in the forum I've noticed that there are a lot of guys having the same problem I do and that there are some brave ones that dedicate infinite time trying to solve this. But I think (maybe I'm wrong, that's just my personal opinion) applications should be easy to use, straight forward, with no need for extra configuration that sometimes require some skills.

Hope to see a more user friendly uTorrent in the future, because its a great program.

Link to comment
Share on other sites

Chances are, you've got some software interfering with µTorrent instead of your router. Your router alone may make µTorrent firewalled -- but µTorrent should still work even firewalled, just a little slower on upload and perhaps a lot slower on download. Potentially any internet-using application could be "fighting" µTorrent for internet access, with bad results. So please list out what you have and maybe we can spot a troublemaker.

Telling your ISP, modem model, and router model wouldn't hurt too. :)

Things should be made as easy to use as possible, but no simpler.

The problems you're having, such as with a router, is often because you chose a complex network setup -- instead of 1 computer straight to a modem or using an internal modem.

You probably have 1 real internet ip shared between multiple computers, compounding the complexity.

Worse, lots of routers are "just plain junk"[tm] (D-Link and the non-Linux-based Linksys routers just to name 2 brands)...at best with them, you have to run µTorrent with really conservative settings...so it even works at all!

Microsoft likes to repatch the half-open connection limit back to 10 almost every monthly update, so that causes all sorts of disasters on the unwary too.

But I think I should close with this:

You've been scammed into thinking computers are easy or simple.

They've been getting magnitudes more complex since they were first invented.

Simplicity on them at best is an illusion, often by giving up almost any real control at all.

Link to comment
Share on other sites

My router model is Aolynk DR814.

As far as multiple computers, I just have one. One computer, one router...

My half open connections are ok, I've got my windows firewall turned off and as far as I know I don't have any application fighting uTorrent for access. Even when I'm not using any app I've got the same results.

My settings are well configured, and I´ve set my router to accept connections from the port uTorrent uses.

I'm able to connect to some peers in uT, but it detects for example 4 000 peers and I can only connect to 3 or 4, getting speeds like 3kbs/s or less.

I know computer stuff are getting more complicated everyday, and I'm not complaining, one should adapt; the problem is that I just want to arrive home and spend my time in others things rather than trying to apply configurations that just wont work!I'm downloading as I write using BC, its not as good as uT, but at least it gets the job done thx to NAT traversal.

Nevertheless, if there's anything I could do to get my uT working, I'd appreciate that!

Link to comment
Share on other sites

If there's only 1 computer, then you don't really need a router unless you're using it for its firewall.

If there's a torrent with 4000 peers and you're connecting to fewer than 10 of them, it might be a poisoned/fake torrent. Have you tried the open office torrent/s others mentioned that are known to have extremely fast download speeds?

NAT traversal won't help all kinds of firewalled conditions, and uses UDP packets. I helped beta-test that on BearShare long before BitComet heard of it.

What was your upload speed like with µTorrent? and also with BitComet? (so I can get an idea for what your connection can do)

Did you try µTorrent's Speed Guide (CTRL+G) to see if your connection was transparently proxied or "regularly" firewalled, and also to see what it says about your max speeds? This too might give us a clue what you have and what might be wrong.

Also knowing what ISP you have is helpful, some are very hostile towards BitTorrent traffic.

Link to comment
Share on other sites

My ISP doesn't restrain bitorrent traffic.

As far as the torrent being fake, I tried several, all with the same result. Besides, I was downloading that same torrent with BC and experienced no problem at all. Even downloading openoffice I get extremely slow speeds.

My connection is a 2mb/256kb, and I usually set my upload speed to 20kb/s. In uT I sometimes get that 20Kb upload speed, but not very often. As far as the DL, it rarely goes beyond the 5kb.

In BC, my UL is always at 20kb, and my DL sometimes reaches 230kbs, but the average is around 40kbs, depending on the seeds.

I checked the guide, but it goes more towards fine tuning, while in my case the engine doesn't even start.

I know I'm not providing a lot of clues, but I ain't got one myself.

Just one question: is the internal ip the same thing as static ip? Because while going through the guide to forward my ports I had to use that ip on the configuration, but the only thing I found was my internal ip. I tried to run "ipconfig" to know the static ip (as explained in the guide) but for some mysterious reason that command is unknown to my computer...weird...

I'm beggining to think this is a basket case...

Link to comment
Share on other sites

Hi Pax3

I have the same shity router and I had some problems to (not all with utorrent) and one thing i did, after beeing at portfoward.com is to make triggers in the router. it could be just a coincidence (i've read that triggers are for upnp and thats off in utorrent because my ipcop firewall doesn't support it) but since then i've stressed out my 2mb/128k line, up and down!

This is my network setup:

internet --> router --> Ipcop Firewall --> PCs (with utorrent and all other stuff)



Try it! Just go to your router gui -> security -> trigger and click New Trigger

Then fill the fileds with these values:

tcp 1024 65535 1024 65535 allow 300 allow allow allow tcp

udp 1024 65535 1024 65535 allow 300 allow allow allow udp

Hope it helps!


Link to comment
Share on other sites

It's typical with "average" torrents for download to exceed upload speed but not normally by more than 4 times.

The fact µTorrent was not reaching the set upload speed and BC had no problem doing so is troubling indeed.

Usually, that's caused by the half-open connection limit being exceeded immensely by µTorrent and not at all by BC. Either that or firewalled and trying to upload torrents with few peers.

If you could not get µTorrent unfirewalled, then we cannot rule that out as a possible cause of your problems. Do note that µTorrent being firewalled means something ELSE is firewalling µTorrent -- it's not something µTorrent is doing or not doing.

Yes, your computer's internal (LAN) ip should be static. This is normally a 192.168.x.x number, though a few exist set to 10.x.x.x (x=any number from 0-255)

Your modem and router gets an external (internet!) ip from your ISP. That ip is dynamic in theory, but many ISPs leave their customers on the same ip for days/weeks/months.

It is the internal (LAN) ip that the router needs to port-forward to. When the router receives a datapacket from the internet on µTorrent's port (you choose that port), it needs to know WHERE to route it to. Without knowing which internet (LAN) ip to route it to, it will just drop EVERY packet arriving on that port. (Only way any packets ever make it through like that is if your computer makes the connection first -- then so long as the connection is going, incoming and outgoing packets are accepted for that connection only.)

So...you have to find out how to port-forward your router, since it sounds like the only reason BitComet works very well is because NAT transversal partially gets around your computer being firewalled by your router. Accepting connections on a port is probably only the first step.

Ironically, there's no need to port-forward outgoing connections -- your computer can already "find the internet" due to how routers work, it's just the internet (at least BitTorrent clients) can't find your computer!

Another thing, many viruses/trojans/spyware act as proxy servers -- routing internet traffic through themselves to modify it in some way. They can cause unresolveable firewalled conditions as well.

Link to comment
Share on other sites

Switeck, thanks a lot for your help man, for all the time you spent trying to figure this out for me!

But Yajdam already solved it for me in his previous post! I´ve triggered the ports according to his suggestion and now I finally see the much desired green light!:)

Thank you both!;)

Link to comment
Share on other sites

Good luck then, I tried port triggers on my Linksys router a LONG time ago and found them only semi-reliable.

The first couple seconds my connection acted like it was firewalled -- as though the port had to be triggered by the 1st packet (or 2...) before the next few packets were allowed through.

If port triggers works, you don't need UPnP. :)

Link to comment
Share on other sites

Good Lord I hope I'm in the right forum!! Folks, I'm a newbie and I'm not skerred to admit it; lol. I love the concept of BT but, I'm having serious doubts to my ability to overcome the technicalities of this without having to go to night school.

Here's the crux of my problem: My down spd is 16-40 kbs and my up spd is .5 to 4 kbs and I have a yellow network status light (all of the time). My internet tested at 1024/452. The reason for the router is three teenagers and before I forget the router is wireless, but I'm hard wired to it then through the modem.

I have Zone Alarm Pro for a firewall, a network everywhere NWR11B routers, a Westell B90 modem from Bellsouth and I have their mid-range DSL. I've read every FAQ and completed every port forwarding link I could find and still it's taking close to two - two-half days to download 4-11 mb torrents.

My ZA shuts down after about 2 hours when I'm using uT. Although I've entered port 14188 into every imaginable place when I test it from the speed guide, the guide responds by saying that it doesn't appear to be open; if that don't beat all – ZA says uT is communicating thru port 14188.

I've tried office, movies, and music torrents with the same results on all.

Here are some other items that I've noticed: seeds 18(279), Peers 51(837) Ratio .046. I'm not sure what I'm looking at, but I suppose the number outside the parenthesis is who I'm connected to and the number inside is the availability? Not sure about the ratio at all since I cannot compute that average with the numbers available.

Is the tracker the link for my download and the seeds the folks I'm uploading to? Is there one document somewhere that teaches/instructs folks like me what is what? I can program my VCR (or when we had them lol), but for the life of me I cannot figure this one out.

Right now I'm trying to download a torrent for 11.3 mb and it's reporting a 7h 39m ETA.

Thanks for listening.

Link to comment
Share on other sites

Disable UPnP in your router and in µTorrent.

Disable DHT in µTorrent.

Reduce half-open connections to only 4-6.

Run Speed Guide again and choose a lower upload speed setting than you're currently using.

If that doesn't work, uninstall Zone Alarm Pro and instead use your router's firewall and possibly Win XP's firewall to keep baddies out. Because chances are, Zone Alarm is blocking a lot of stuff it shouldn't -- like µTorrent traffic.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...