TylerW

3.5.x Beta

Recommended Posts

yeah, copy&paste worked great ... I'll re-edit and improve on you, so you would't complain (I allow you to copy it into your sig...) ... 

Edited by rafi

Share this post


Link to post
Share on other sites

3.6.6.44841available:

magnet:?xt=urn:btih:5604B82412B5533375680485891A0D5FD204D151

Binary size: 2.23 MB (2,341,816 bytes) / MD5: 80B8301A31934E13148AAB97EAD79597

No changelog.

Latest Beta in Signature below...

Edited by mike20021969

Share this post


Link to post
Share on other sites

Just had 44632 just completely force close on me after I started downloading a torrent, never had that happen before, no dump file either, nothing in the Windows logs. =/

What the heck happened to 3.5.5?

Looks like I've frozen it this time, disk cache overload, whole UI is frozen. Guess I need to tame my download speed.

Ain't the first person to experience this and sure won't be the last. The client sure as heck shouldn't be hanging.. Just stop the torrent for a bit or something? 
uTorrent should be smart enough to choke a torrent if the disk can't keep up.

Edited by Ryrynz

Share this post


Link to post
Share on other sites
On 01/11/2018 at 7:41 AM, mike20021969 said:

3.6.6.44841available:

magnet:?xt=urn:btih:5604B82412B5533375680485891A0D5FD204D151

Binary size: 2.23 MB (2,341,816 bytes) / MD5: 80B8301A31934E13148AAB97EAD79597

No changelog.

Where is  the BT inc server for those betas nowadays?

 

 

Share this post


Link to post
Share on other sites
28 minutes ago, rafi said:

Where is  the BT inc server for those betas nowadays?

In English please...

Deciphering it now...

xiYxKYXe_o.jpg

Edited by mike20021969

Share this post


Link to post
Share on other sites

oh, so, the auto-directed from the generate beta link? I thought there is that special  "install" releases/server a for more deterministic download .

hmm.. AFAIK, all were words in English.. 

Share this post


Link to post
Share on other sites
10 minutes ago, rafi said:

hmm.. AFAIK, all were words in English.. 

They may be English words, but they need to make sense.

"BT inc server" - I've never heard of a BT inc server.

What does "inc" mean... nothing to me.

Edited by mike20021969

Share this post


Link to post
Share on other sites
24 minutes ago, rafi said:

BT inc - BT  incorporated ...  => so, a server managed by BT ... 

That would be BT Inc. then.

Anyway, the Beta & stable Links I use are in my signature... well, most of them ;)

Edited by mike20021969

Share this post


Link to post
Share on other sites

The question was were did you download it FROM - the official beta DL link, or some other server?

Edited by rafi

Share this post


Link to post
Share on other sites

The UI responsiveness needs some work, I've got uTorrent completely freezing the UI while it downloads fine in the background, the mouse over in the taskbar shows uTorrent is downloading/uploading & completing torrents fine but the UI isn't updating if I bring up the full window and at times it just stays blank with no torrents showing in the window at all. My CPU is only at 25% (It's a quad i7) and I have oodles of RAM to spare. Once the torrent has finished downloading, the UI is back to working properly again. Doubt it'll make much difference but I changed the GUI to update every 2 seconds instead of 1. ANyone got any other options they know of that might help?

Edited by Ryrynz

Share this post


Link to post
Share on other sites

Haven't changed much of anything, certainly haven't touched any of the more advanced stuff, just cache and ads, connections, loathe to do defaults TBH, wouldn't that mess with my labels? Bout 350 active. 500 max connections is pretty sane yeah? Maybe I should lower it a bit more? Anyway does the UI not have it's own thread or something? Changed a few GUI options as well, will report back if it improves things.

Edited by Ryrynz

Share this post


Link to post
Share on other sites
56 minutes ago, Ryrynz said:

Haven't changed much of anything, certainly haven't touched any of the more advanced stuff, just cache and ads, connections, loathe to do defaults TBH, wouldn't that mess with my labels? Bout 350 active. 500 max connections is pretty sane yeah? Maybe I should lower it a bit more? Anyway does the UI not have it's own thread or something? Changed a few GUI options as well, will report back if it improves things.

Make a backup of the folder that contains all the *.dat files etc., so restoring back shouldn't be an issue.

The only file that would be changed for default values would be the settings.dat file (and re-blocking the ad value entries shouldn't be too much hassle).

Edited by mike20021969

Share this post


Link to post
Share on other sites

Changing the GUI refresh rate gui.update_rate from 1000 msec to 2000 or 3000 can help , but just a bit...

And 300 active, and 500 connections (active downloads) is too mach IMHO .... You are welcome to try with my settings (@sig)

 

Edited by rafi

Share this post


Link to post
Share on other sites

As there is no Stable thread...

3.5.4.44846 available:

magnet:?xt=urn:btih:95C8617F85BBBB316C4E1F445439391787C17B6B

Binary size: 1.65 MB (1,738,936 bytes) / MD5: CABC2DB0BB2DB3A6C6B1855D15722E28

========================================================================

Changelog:
uTorrent 3.5.4 For Windows (build 44846)
November 14, 2018
– Removed old trial streaming functionality
– Remove old embedded html video player

Edited by mike20021969
Smaller Binary | Added Changelog

Share this post


Link to post
Share on other sites
15 minutes ago, mike20021969 said:

magnet:?xt=urn:btih:0F9D044A685365EF4F6B90922581874B4C2800AE

500K smaller. I'm wondering what's missing...

Edited by rafi

Share this post


Link to post
Share on other sites

It seems to recognize the previous beta as NEWER... :( I think I'll avoid this one.

Edited by rafi

Share this post


Link to post
Share on other sites
1 hour ago, rafi said:

It seems to recognize the previous beta as NEWER... :( I think I'll avoid this one.

I've had that a few times. Uninstall (but leave config settings) and installing the later version works.

Share this post


Link to post
Share on other sites
On 11/5/2018 at 1:32 AM, rafi said:

Changing the GUI refresh rate gui.update_rate from 1000 msec to 2000 or 3000 can help , but just a bit.

 

Tried some tweaks but UI still freezes. net.low_cpu isn't set and the only thing I thought might be related here.
WebUI is perfectly fine, updates in time but the main UI is completely frozen until downloads slow down.

Seems to happen when it reaches about 20MB/s or so, UI comes right after it drops below this. PC is still responsive, CPU only at 25%

so it's related to the amount of connections and the UI, I might drop the connections by half and see if that changes anything, 

I'd rather the performance anyway screw the UI, but the dev/s should look at making the UI better threaded perhaps.

Edited by Ryrynz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now