Jump to content

3.5.x Beta


TylerW

Recommended Posts

3.5.5_45283.exe beta:

http://download-new.utorrent.com/endpoint/utorrent/os/windows/track/stable/

magnet:?xt=urn:btih:3E79F8B926006580DF4832EFA6C4DF00F49D1339&dn=3.5.5_45283.exe&tr=udp%3a%2f%2ftracker.openbittorrent.com%3a80%2fannounce&tr=udp%3a%2f%2ftracker.opentrackr.org%3a1337%2fannounce

My change-log:

+Fix: Language icon (globe) now opens preference->general tab, and not the last opened tab

 

Edited by rafi
  • Thanks 1
Link to comment
Share on other sites

3.5.5.45283 magnet:
magnet:?xt=urn:btih:655AC872530E33879A6B9D13A75E4C84B6C68D48
Binary size: 1.75 MB (1,837,296 bytes) / MD5: AD1808DBC99BD83B487CB6A9E262C527
Changelog:
June 24, 2019

  • Fix unparseable callback data crash
  • Allow user to enable protocol enhancements in preference settings
  • Ensure language button opens correct page
Edited by mike20021969
Update Changelog
  • Like 1
Link to comment
Share on other sites

http://www.imagebam.com/image/c2d9561263502514

c2d9561263502514.jpg

Linking to the latest beta, modified to use >2G cache-memory (only on x64 OS). Check it up, see if you can indeed set a larger cache ( >2G ) .

Download link: http://tinyurl.com/utorrent-LAA

Background: https://devblogs.microsoft.com/oldnewthing/20050601-24/?p=35483

Have fun, and post your feedback  :)

Edited by rafi
Link to comment
Share on other sites

4 hours ago, YuriPet said:

10.0.18362.207 (Win10 RS6 [1903] May 2019 Update) x64 Pro
16GB memory

 

This is GUI-related, hard coded, so just setting that flag cannot change it, we need the devs for that... I hope in auto/dynamic allocation mode, it will behave better, in use-cases with many active torrents for now.

Here is how to change it manually in settings.dat, using BEncode:

9756031263639494.jpg

 

Edited by rafi
Link to comment
Share on other sites

26 minutes ago, rafi said:

You need to check out the speed->disc statistics tab.

OK. Let's try again.

001.thumb.png.73f833e87d12d4c58e9fb3e91155ea75.png

I deleted the downloaded file and started it again.

002.thumb.png.cc4431a2c491c14572bbee3775fdf0d4.png

As you can see, cache is overloaded again, although the cache size is zero.

Edited by YuriPet
Link to comment
Share on other sites

Testing with 1800M cache, process explorer:
"uTorrent.exe uTorrent.exe 4.73 1,958,064 K 1,962,888 K 1,959,976 K 2,175,816 K 3528 µTorrent BitTorrent Inc. Disabled 8 40 49.8 MB 881.9 MB 332.5 KB 38.8 KB
07:43 "

So at 1800 MB cache size, uTorrent used a peak of ~1,960,000 KB ram but had a virtual memory size of 2,175,816 KB.

Had this not been with the LAA flag set (patched uTorrent), it would certainly have caused a show-stopping crash...possibly even requiring or even triggering a reboot.

 

Bottom line: seems like this flag can help to avoid cache related issues. No need to force it over 1800M!

 

Edited by rafi
Link to comment
Share on other sites

So everything's working fine but every few days it stops accepting new connections. Uploads and downloads just stop working and this has been an issue for me for a while now.

If I add a torrent it sees the peers and the seeds but transfers nothing. Simply restarting the client fixes it. Any tips on what it could be?
I downloaded Rafi's settings and changed all the advanced settings that I changed to match his and it did help performance but I still have this one issue. I have qBt running concurrently and it has no such issues. Anyone else seen this? Was running 45225, and just now updated to 45271 but I expect this won't change anything.

Edited by Ryrynz
Link to comment
Share on other sites

On 7/3/2019 at 3:57 AM, Ryrynz said:

So everything's working fine but every few days it stops accepting new connections. Uploads and downloads just stop working and this has been an issue for me for a while now.

If I add a torrent it sees the peers and the seeds but transfers nothing. Simply restarting the client fixes it. Any tips on what it could be?
I downloaded Rafi's settings and changed all the advanced settings that I changed to match his and it did help performance but I still have this one issue. I have qBt running concurrently and it has no such issues. Anyone else seen this? Was running 45225, and just now updated to 45271 but I expect this won't change anything.

Can you observe any memory leaking ? large amount allocated, close to 2G, being used? If so, you can try my specially version (above) set with LAA flag.

 

Edited by rafi
Link to comment
Share on other sites

On 7/3/2019 at 6:22 PM, rafi said:

Can you observe any memory leaking ? large amount allocated, close to 2G, being used? Is so, you can try my specially version (above) set with LAA flag.

 

No leak. Still at 116MB. It's just done it again too. Might have to start going backwards in version numbers until I find one that keeps working.

But before that I'll set my max active torrents lower, it's probably higher than uTorrent is happy with, will keep halving it and see what happens.

 

Anyone stabley have their set max active torrents limits at say 200+ or nah?

Is currently appears stable on 400 active torrents.

Edited by Ryrynz
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...