TylerW

3.5.x Beta

Recommended Posts

also, let's stay on topic. This thread is about beta versions. Announcing new betas, their features and download issues is spot on. Discussing issues that happen in those versions is also okay, even though we might should have moved it into separate threads with that. But saying that nobody needs betas and an old version is all you need is definitely not on topic here.

I'm not saying that point is invalid. In fact, I am strongly considering finding an old x64 version and trying it myself. (Because there were 64-bit builds of uTorrent—and I think they would handle large number of torrents much better.) But so far, I am reluctant to take this road because I do not want to run unsupported three-years-old code which has God knows how many issues in it. (Including, potentially, security bugs.) And also, I don't trust 3rd party download websites.

But, again, this is not on topic here, so let's not discuss that in this thread. I would be very happy to hear everyone's perspective on this topic in my 64-bit feature request thread because that would help bump it.

Share this post


Link to post
Share on other sites

Isn't a new Beta due?

I'm having one big problem with 45852 - it randomly loses the links between the *.torrent files and the downloaded files associated with them, and it is a major pain in my ass to rebuild those links.

Share this post


Link to post
Share on other sites
7 hours ago, Nancy023 said:

Isn't a new Beta due?

There have been a new beta + stable after that...  RTF[Thread]...

  • Like 1

Share this post


Link to post
Share on other sites

so with latest stable, GDI crash still happens.  How hard is it to figure out where the GDI aren't being returned when unneeded?

Share this post


Link to post
Share on other sites

Maybe so, but still, this has been going on for many months now, and at least four so called stable releases.  It's utterly ridiculous at this point.  I'd like to know if they ever plan to fix this. 

Share this post


Link to post
Share on other sites

The GUI/UI has been unchanged for ages now, from V1.x . So I guess Ludde - the original Swedish dev who sold uTorrent to BT inc (aka now - Tron) has developed it. Pretty old stuff and no Ludde now, from Windows 7 days.... Who knows, maybe using Win7 compatibility mode can improve this for you...

Edited by rafi
  • Confused 1

Share this post


Link to post
Share on other sites

I do better than compatibility, this is a win 7 machine.  So that isn't the answer.  Something was done to the code in 2020 that caused this.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, ex58 said:

uTorrent 3.5.5 Build 45966

http://ll.download3.utorrent.com/latest/uTorrent.exe

or

http://llsw.download3.utorrent.com/3.5.5/utorrent.45966.installer.exe

File size: 2,03 MiB (2.133.032 bytes) / MD5: 816BDFC773A826F3F72568E35F0A5C52
Digitally Signed: BitTorrent Inc. 16 March 2021

Stable or Beta?.

Share this post


Link to post
Share on other sites

Thanks for the update. In case anyone had high hopes for the new build, it's still crashing every ~10 minutes at me.

Update

Oh great. Now apparently it crashes even before it manages to save the settings file at least once. Because every time I relaunch it again, it opens the browser with the stupid “hey we've updated you” page. Which probably means that the fact it already did that was not recorded in the settings file. So, it becomes even worse than before.

Edited by Bacc
  • Thanks 1

Share this post


Link to post
Share on other sites
On 3/16/2021 at 11:53 PM, icebox said:

so with latest stable, GDI crash still happens.  How hard is it to figure out where the GDI aren't being returned when unneeded?

I have tried to see how to manually increase the GDI count, and it seems to be easily reproduced like this (visble in task-manager->details->GDI column):

1. Enable sidebar (F7)

2. Using the mouse - "grab" the right side of  the main uT windows and increase/decrease it's size .

3. Each movement the GDI count increases, and never drops back.

4. Disable sidebar (F7 again) and repeat - this no long happens

So, I suspect that some  new item in the sidebar is causing this ("Speed", TronTV...  etc).

Test clip:

https://drive.google.com/file/d/15Di6Rjlf70GLn2vjHXnbie4Uz96l0WBy/view?usp=sharing

 

For now, a W/A can be - to just run uTorrent with a closed sidebar, and use F7 to re-open when needed...

Edited by rafi
Added a test clip...

Share this post


Link to post
Share on other sites

I disabled the sidebar, but haven't resized.  I rarely resize that window, in fact.  GDI was at 3406 when I disabled the sidebar, and by the time I got to replying, a few minutes later it's at 3438.  I haven't yet updated to the new "stable" yet, but based on the earlier comment by Bacc, still not fixed.  Seems like 45952 crashes faster than the previous build did from this, but im not sure.  And now its at 3502.  This is clearly faster.  I haven't been able to watch it go this fast before.  where it jumps a 100 in 10 or 15 minutes (except at startup, and this was started about 4 hours ago . 

Share this post


Link to post
Share on other sites

"Resizing" is just a way to get the GUI refreshed... Even if you do not resize, the sidebar is being self-refreshed to update the counters in there, so it will still increase, just slower...

Anyway, you can post a screenshot of your sidebar&options, see if we have it set in a similar way...

 

Edit:

I think I might have pin pointed to the "Speed... " side-bar menu item as root cause. Tried to expand "Labels" or "Feeds" , scroll down to hide "Speed..."  above - and GDI counter seemed to have stopped increasing...

94b3f41372647862.jpg

Edited by rafi
Pin point to "Speed" menu item as root cause

Share this post


Link to post
Share on other sites

 

If you see Speed there than you have "BitTorrent | Enable Protocol Enhancments" checked in options.  This allowed uT to install the "BitTorrent Speed" add-on at some point.  This add-on is a fairly large thing, and if you do not use it then turn it off by:  1) Quit 2) save settings.dat [just in case!] 3) launch and uncheck "enable protocol enhancments", save. 4) Quit and relaunch.  It shd be off/gone now.

FWIW the btspeed add-on is in the ut/helper folder.

Note:  once turned off it will not come back simply by turning it on again - you need to wait for it to be offered up again, perhaps a few weeks.  you may also lose your earned tokens.  [restoring the prev settings.dat file might bring it back immeadiately, I'm not sure tho].   But if you're not using the feature you don't care anyway...  If in doubt read up on BitTorrent Speed.

---

you can also disable other "baggage" in uT:  TronTV,  BTFS and DLive,  with these Preferences | Advanced option changes:

  offers.dlive_enabled   to false

  offers.TronTV_enabled to false

 offers.btfs_enabled  to false.  [I think btfs has been totally depreciated]

Note: you need to hold down shift-f2 when clicking on Options | Preferences menu choice to see these "hidden" options.  [This an an old trick, shift-F2 reveals a different second-set of advanced parameter-names, always best to try both regular and then shift-F2 when "snooping" thru the parameters.  BEncode Editor is also great for snooping thru .dat files].

Once done these guys [F8 and F9] should be dimmed in the Options drop-down menu, and gone in the sidebar.

Lightening the misc features may make it work better for you...

good luck.

[Remember to always make a backup of settings.dat just in case!]

 

Edited by javacatpaul
try to make it clearer...
  • Like 1

Share this post


Link to post
Share on other sites

never mind.  Gotta read the whole damn post above.  leaving this here for when I'm done, but removing evidence of my own idiocy.  :)

 

EDIT 2: OK, BTFS was disabled already, but the other two were not, and protocol enhancements were enabled.  Disabled that, and with the new advice, (thanks javacatpaul!), now I move from rafi's Fail (though I had scrolled those offscreen before where they never were seen and so wasn't annoyiing) to OK. 

 

We'll see if that reduces GDI use, and I'll turn off F7 when not needed.  Thanks to both of you!

Edited by icebox
mistaken post

Share this post


Link to post
Share on other sites

Actually on relaunch Dlive and Tron came back, and they both had "*true"  * I thought was for manually adjusted settings.  I went back into advanced settings and falsed them again and they're gone.  Still have upgrade to pro at the top, but I don't really care. 

 

But holy moly, after these changes (also made offers.superad.adson=false, don't know why that was true before) GDI use after restarting is only 243, lower than utorrent 2.2.1s 273.  Still using 45952.  It went up to 251 then back down to 243!  And up to 244 and back down.  I think we discovered where the damn GDI error was for real.  I'm actually going to leave this as is without hiding the sidebar and see if this is truly stable!

EDIT: one hour later.....GDI objects are 239!  I think we have stability!

Edited by icebox
update

Share this post


Link to post
Share on other sites
7 hours ago, icebox said:

EDIT: one hour later.....GDI objects are 239!  I think we have stability!

Good, we can manage as long as we can w/a this ...  The Devs will probably fix this soon enough...

 

Share this post


Link to post
Share on other sites
18 hours ago, icebox said:

 

   >>>   *  I thought was for manually adjusted settings.

    the star [asterisk] on a value means it is the default.

 

[edit] what I meant to say is star means MODIFIED from the default. 

Edited by javacatpaul
fix answer to be CORRECT!

Share this post


Link to post
Share on other sites
2 minutes ago, javacatpaul said:

the star [asterisk] on a value means it is the default.

No, "*" means the value was MODIFIED from the default value!

Share this post


Link to post
Share on other sites
1 minute ago, rafi said:

No, "*" means the value was MODIFIED from the default value!

Hell, I was in the middle of editing myself and you caught it before I could click SUBMIT!  Yes, the star means MODIFIED, that's what I meant to say...   ;)

Share this post


Link to post
Share on other sites

Update on GDI: the two times I've added and then deleted (which involves stopping the torrent, moving the files through the program to a different location, then removing and deleting torrent file) the same number of torrents (3 the first time, 4 the second time), the GDI count rises and doesn't decline, though the amounts are small.  By small, rising from 243 to 352, and now the second time, to 406, but dropping as a wrote this to 398. 

Share this post


Link to post
Share on other sites
9 hours ago, icebox said:

Update on GDI: the two times I've added and then deleted (which involves stopping the torrent, moving the files through the program to a different location, then removing and deleting torrent file) the same number of torrents (3 the first time, 4 the second time), the GDI count rises and doesn't decline, though the amounts are small.  By small, rising from 243 to 352, and now the second time, to 406, but dropping as a wrote this to 398. 

Seems so, just that since this is a one time thing, and do not causes GDI leak/increase over time - it does not really matter too much...

Edited by rafi

Share this post


Link to post
Share on other sites

Downloaded and installed 45966.

Magnets no longer load, advising uTorrent is already running.
I can download torrent files. These do not work if double-clicked (file associations are set up) but *do* work if dragged to the uTorrent client.

Tried the suggested route of opening the .exe and simply cop[y/pasting the uTorrent file - it's not there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.