Jump to content

USB ports stops responding because of ? uTorrent ??


Recommended Posts

TL;DR : When I'm usb tethering and utorrent is running and after a while if i unplug my phone, network icon will get yellow exclamation mark and USB ports will stop responding. Restarting is the only solution but computer won't shut down now and I have to cut the power.

FULL : Hey guys!! so I have been having this weird issue in my pc (Win 7) when I use USB tethering from my android phone(Lenovo a6000 if that helps).I use my phone to run internet in my PC via USB tethering. Its a spare phone that no one uses and is just used for internet purpose.

Coming to the issue, when i turn on USB tethering and use it for a while (say an hour) and now if I unplug the USB cable I'll get this yellow exclamation mark on the network icon and NOW all the USB ports will stop responding and I can't reconnect.The ports won't even respond USB drives and external HDD.

Now I have to restart to get it working again but MY PC WON'T SHUT DOWN.It will get stuck on windows is shutting down screen.I left it twice there for 20mins to see if something happens, one time it gave "failed to shut down" (or some error like that i dont remember exactly) and restarted automatically, while second time it ended up in blue screen :(

A very major observation I have made is this only happens when there is utorrent running.And I'm almost sure its causing that.And like 99% times it didn't happen unless I unplugged the cable from phone.

Things I have already done

1. Formatted my phone

2. Formatted my pc

3. Try different USB ports and USB cabels

4. Try other phones (PROBLEM SEEMS TO BE ONLY WITH THIS PHONE and only when utorrent is running)

So anybody has any idea what is happening here? I can deal with restarting pc to get the ports working but can't absolutely deal with windows not shutting down and having to cut the power :( This thing has been killing me. I'll appreciate any help from you tech lords.

If you want to know anything else about the issue just let me know in the comments !!

Thanks in advance for reading!

Link to comment
Share on other sites

13 hours ago, prylandermau5 said:

It's only happening only when utorrent is running !! Everything is clean on the driver side. Can you tell me who would be able to assist on this issue ?

Sounds more like a hardware/software problem. As it doesn't sound like no one else is experiencing this problem per say be related to your setup. And since no one is there to see any setups or see how it is installed blaming utorrent tell much of anything. I ran utorrent with my mobile phone driver app and it has no problem with utorrent so just by the face of it this issue isn't related to utorrent but probably shows up because utorrent is running doesn't equate to a utorrent problem. Have you tried this on another computer to see if the same problem happens? Unless you can reproduce or show this problem on another hardware then it because a hardware/software issue with your current system not utorrent.

Link to comment
Share on other sites

11 hours ago, PiusX said:

Unless you can reproduce or show this problem on another hardware then it because a hardware/software issue with your current system not utorrent.

But as I said I formatted both my pc and phone. Also I have been a long time user of utorrent and never faced such problem. Its only been happening for a while now (a month I guess).

One of my web friend told me that  torrents can open an unreasonable number of ports and there might be a maximum to the number of simultaneous connections possible over a USB bus. When it overflows your USB controller driver would fail ungracefully. Is that a possibility ? 

Also the problem only occurs if I detach the cable (But utorrent has to be running). Otherwise its fine. Its so weird I can't wrap my head around it. Should I be seeking help from hardware guys ?

Also I have seen some posts on this forum about utorrent causing USB disconnections for routers? But they were not very much related to my problem. But it does show that utorrent can cause such problems ?? 

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...