Mf93

The pirate websites force you to downoald with bitlord not utorrent

9 posts in this topic

i had a problem from yesterday the piratebay website don't allowed me to downoald torrents with utorrent they force you to downoald with bitlord, plllllz if there is anyone who could help me out

Share this post


Link to post
Share on other sites

I Still have the same issue even though I uninstalled Bitlord and rechecked Utorrent file associations, but I will elaborate. When using Pirate Bay to search for a title you find the movie and select that for download. There is now in green letters "download" "play/stream" and you can not select the download section. You have to hit play/stream and once you do the next page opens asking you to download Bitlord.  All this is frustrating, but Bitlord is FREE.  So I tried the search on Bitlord and downloaded the movies (3 actually) and wonder what is the point to using Utorrent anymore? (Adfree at a cost)

Edited by obsurv44

Share this post


Link to post
Share on other sites

It would appear that they are applying script based blocking of the actual magnet link. You can right-click the magnet icon in the search results to bypass their crap.

1 person likes this

Share this post


Link to post
Share on other sites
16 hours ago, obsurv44 said:

Pirate Bay

Are you using the .org site, or some proxy version?

On .org, their magnet links work fine with uTorrent when clicked.

Share this post


Link to post
Share on other sites

As I mentioned, I have been doing this for many years even back to the days of Bearshare and Napster.  I have been solely using uTorrent for at least 4 years on 3 different PCs using win7 and most recently win10. I have downloaded successfully up until this past week actually so it can not be browser issues, using .org versus some proxy because I have always used .org.

https://thepiratebay.org/torrent/18492242/Game.of.Thrones.S07E07.The.Dragon.and.the.Wolf.AMZN.WEBRip.DDP2.  shows up in the top bar of Pirate Bay like always and when I click on the link I get the same choice to download with a green link or stream/play with a green link. Only the stream/play link works and that is where the Bitlord download page opens.  Even after downloading and installing bitlord it will still take you to the download page. 

I have uninstalled and reinstalled uTorrent and still no luck.

What am I missing?

Share this post


Link to post
Share on other sites

I just re-read the string in this post.  

10 hours ago, DreadWingKnight said:

It would appear that they are applying script based blocking of the actual magnet link. You can right-click the magnet icon in the search results to bypass their crap.

I then just "left click" on the magnet link and all works fine!!!  Thank you very much sir. :)

Share this post


Link to post
Share on other sites

Hmmm. It appears many videos are now linked to this bitlord nonsense.

An alternative way round this is to click the magnet icon on the results page itself, rather than any link on the torrent's details page.

Edited by mike20021969

Share this post


Link to post
Share on other sites

I experienced the same thing as well, but after doing some research, I found that the default Piratebay site (https://thepiratebay.org/) is in fact pushing out a change mandating Bitlord for some odd reason and magnet links are not working. When you hover magnet links, they are dead. Right click and left click do nothing. Going to a proxy such as piratebay.tv, the magnet links work just fine. So, not sure what's going on, but I'm over it. Use it a proxy available here: https://thepiratebay-proxylist.org/ and magnet links are working. This has nothing to do with configuration of the client, browser, etc.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now