antik

7MB/s max on 100Mbps Fibre

Recommended Posts

Hi all,

I am on a 100/40 FTTH connection - speedtest.net I sync at 95Mbps and I can download from Apple at 11.5MB/s. When I torrent from my private tracker I can't get more than 7-8MB/s stable even though the torrents have >1000 seeds and <10 peers. If I have 1 torrent downloading it will be @ 7MB/s, if I add another torrent they will both download at 3.5MB/s, 3 torrents will download @ around 2.6MB/s each etc. I've also noticed that torrents will only connect to a max of 75 seeds per torrent - is this normal even though I have much higher connection limits set?

I am using version 3.5.5

https://www.speedtest.net/result/9445861740

Any help would be great!

Edited by antik

Share this post


Link to post
Share on other sites

Here, try again with my settings (@ my sig) .

Also, a good test as reference will be slackware torrent, not your private tracker...

Share this post


Link to post
Share on other sites
On 5/16/2020 at 4:06 AM, rafi said:

Here, try again with my settings (@ my sig) .

Also, a good test as reference will be slackware torrent, not your private tracker...

Thanks for the reply. I used your settings and I am now getting full speeds again. Although, what I have noticed is it takes torrents a long time to start connecting to peers even though the peers are shown. The torrents will sit "Finding Peers" for 60 seconds before connecting. Any idea why this might be? Also, for some reason I can't download slackware torrents, tracker shows "No Connection". My private torrent tracker works fine...

Edited by antik

Share this post


Link to post
Share on other sites

>Also, for some reason I can't download slackware torrents

^ You've got serious blocking issue, it is both public and legal torrent/file.  Check your firewall or ask your ISP. After that, you can investigate the 60 min thing...

 

Share this post


Link to post
Share on other sites

Excluding of utorrent.exe . Not being able to get/download slackware is not possible under normal conditions. More likely your ISP is involved.

Share this post


Link to post
Share on other sites

I got slackware torrents working - I had to enable DHT and PEX. These settings I always have disabled for my private torrent tracker

Edited by antik

Share this post


Link to post
Share on other sites

So, you've screwed with my settings, and  complain? ... ;) This shows, that your system (settings) are still not well adjusted. Check if your port # in preferences  is the one being is forwarded in your router, and if open-port test from any internet test-site to it - passes.

Partly blocking the outside world from yourself, and still hoping to get fast peers, is a contradiction...

Edited by rafi

Share this post


Link to post
Share on other sites

DHT & PEX need to be disabled for my private tracker. If I use a public tracker I will enable DHT and PEX. I'm getting full speeds, so no issues there.

 

The only issue now is that it takes around 60 seconds to connect.

When I add a torrent it will sit like this for 60 seconds: OJ8YDT3.jpg

Then after 60 seconds it will download as per normal: d3rhP1X.jpg

Share this post


Link to post
Share on other sites

>I am using version 3.5.5

latest build -   45660 ?

 

You can try changing these two:

pref.->general -> pre allocate all files - unchecked

pref.-> advanced -> bt.connect_speed = 10

Also confirm - pref.-> advanced ->diskio.no_zero = default (true).

Edited by rafi

Share this post


Link to post
Share on other sites
3 hours ago, rafi said:

pref.->general -> pre allocate all files - unchecked

pref.-> advanced -> bt.connect_speed = 10

Also confirm - pref.-> advanced ->diskio.no_zero = default (true).

I tried these, same issue.

I had pre allocation checked as when I used your settings I was getting a disk overload error. So I followed an online guide and changed a few settings which solved my disk overload issue, one of which was pre allocation of files. The other settings were changing diskio.use_partfile to False and enlarging the Base Cache to 1024MB. Would any of these settings fix the 60 seconds connection delay? - https://appuals.com/utorrent-disk-overloaded/

Edited by antik

Share this post


Link to post
Share on other sites
4 hours ago, rafi said:

>I am using version 3.5.5
latest build -   45660 ?

Been there, done that, not going to check those...  Both your changes are not needed, plus pre-allocation - can cause delays, and I am against these. Per #2 in your list (which I agree to...) - use the latest release from my link ...

Share this post


Link to post
Share on other sites

Can you check if this delay happens for you with the  slackware torrent (+DHT/PEX ) too ? 

I've noticed a new setting: advanced setting :  magnet.download_wait - 60  ... which "doesn't work" for me... Maybe it works for you for some reason... ;)

Share this post


Link to post
Share on other sites

I am already using build 45660. I tried changing magnet.download_wait to 0 but it didn't fix the issue. Also my torrent site doesn't use magnet links

Edited by antik

Share this post


Link to post
Share on other sites
17 hours ago, rafi said:

Can you check if this delay happens for you with the  slackware torrent (+DHT/PEX ) too ?

(and with DHT/PEX enabled/disabled)

 

PS/edit: I still recommend trying with the exe I've linked to.  Also, uploading  a clip of the first 60 seconds with slackware (showing the different tabs) can be of help

Edited by rafi

Share this post


Link to post
Share on other sites

Slackware torrents connect normally so it must be an issue with the private tracker as I noticed the tracker status is "Updating" when torrents are added. When it finishes updating is when I start connecting. I spoke to the support team of my private tracker and they said the tracker had been updated a few weeks ago which is when the issue started

Share this post


Link to post
Share on other sites

Well, too bad you haven't provided that extra/important info... Seems like you have your answer... Don't use this tracker...

Case closed... ;)

Edited by rafi

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.