Jump to content

Speed dies few seconds after starting uTorrent Web


Recommended Posts



I am using MacOS, version 11.5.2 (20G95). I have installed uTorrent Web, version and having issues with it.

For sometime (few months) after installing it for the first time, everything worked fine. I added magnetic links, they downloaded fine with best possible speed. Then one day I suddenly ran out of disk space, and everything went bad after that. I cleared the disk space, but torrents wouldn't resume. I restarted the uTorrent Web, but the torrents went into Queued state, and no matter how many times I clicked resume, or force download, they wouldn't resume. I checked logs, and found the below error message:


[2021-09-17 21:43:07.142] [lt-error] [error] error [] (libtorrent:43) too many piece requests while choked

This error wouldn't come continuously in the logs, but would come from time to time. So I uninstalled uTorrent Web, deleted all the files, partially downloaded torrents too, and re-installed the application. Same version number as mentioned at the starting of this post. After re-installing, things became fine, torrents started to download with top possible speed.

Then suddenly, after few days, the speed died for no reason I checked bandwidth usage as the speed was dying, there were no transfer happening. And the speed reduced to few bytes per second. Note that there is no limit of bandwidth in the settings. Also I was able to download large files (greater than 5 Gb) with top speed, so bandwidth is not an issue. Waited for a couple of days for the speed to pick up again, it didn't. Tried to quit the app, it would hang, so I had to kill Force Kill it. Started the application again. For few seconds after starting I would get top speed, then again the speed would die. Logs didn't have any other error than the one mentioned above. Again tried to quit the application, it would hang, so again Force Killed it. On starting again, again I would get top speed for few seconds and then it would again die.

What do I check here? How do I solve this problem? Note that I don't have bandwidth or speed issues. I downloaded a CentOS iso file and got speed greater than 27MBPS (megabyte per second) continuously till the file was downloaded.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...