Jump to content

Issues Creating/Adding New Torrent


Splitzzzzz
 Share

Recommended Posts

I have a large  (18.53 GB) directory of media I wish to share via creating a new torrent. When I create with uTorrent, it gets part way through creating then crashes and windows says run out of memory. Some Googling sees this has been a problem for some years with respect to larger .torrents and seems unresolved in uTorrent.

One thread suggested using a 3rd party torrent creator/editor and recommended "Torrent File Editor" ( https://sourceforge.net/projects/torrent-file-editor/ )

I tried using that but when created, the main panel says "0"  for "Piece Size", "Pieces" and "Total Size". When 1st created and directory added, the "Files" panel does list the correct total torrent size. No matter what I do I can't get the main panel to display this info (when I created a torrent with a single file it did show this info?).

When I add the created .torrent file to uTorrent, it comes up with an error saying cannot add as piece size is zero (or similar).

When I re-open the .torrent file with "Torrent File Editor" the file panels shows only 1 file with zero pieces instead of the previously shown 60 files?

Also unsure about which trackers I should include from this list. https://techspree.net/torrent-tracker-list-updated/

When I add about 8 trackers from this list which uTorrent seems to use for my other torrents, utorrents says one or more are invalid and asks me to continue without a tracker?

Thanks in advance...Cheers

Link to comment
Share on other sites

So is this one file or individual files? Maybe you might have to create individual for each folder or files to upload to torrent sites? As to creating torrents I looked and there isn't much utorrent can do because you need to find trackers to get it started so you might have to go online to find these resources to help create your torrents.

Link to comment
Share on other sites

1 hour ago, PiusX said:

So is this one file or individual files?

60 x Individual files, 1 root directory with 2 x sub-directories each containing 30 files. I've tried creating a torrent for each sub-directory but it still crashes.

Link to comment
Share on other sites

Posted (edited)
11 hours ago, DreadWingKnight said:

And if you try making the torrent with http://wiki.depthstrike.com/wiki/EAD:Utilities:TorrentBuild instead?

Also, the monolithic tracker lists are completely unnecessary. If you are not enabling the private flag in the torrent there is no need to even add trackers to the torrent at all.

Thanks for the reply!

I tried using TorrentBuild. The app starts OK but as soon as I click "Build Torrent" it gets an "unhandled exception" error. I click "continue" but app just sits there doing nothing? Cheers + thanks again

Error text;

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.FileNotFoundException: File 'F:\XXXXXXXX[Complete]720p.h265.AAC.2.0. Burned.E-Subs.for.Spanish.dialogue\XXXXXXXp h265 AAC 2.0. Hard coded Subs for Spanish dialogue (no Subs for English dialogue)\XXXXXXXXXXXX.S01E01.720p.WEBRip.x265-HETeam+HCSubs.mkv' not found.
   at Microsoft.VisualBasic.FileSystem.FileLen(String PathName)
   at TorrentBuild.TorrentBuild.MakeOneTorrentFromFolder()
   at TorrentBuild.TorrentBuild.BuildTorrentNow_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.9164 (WinRelRS6.050727-9100)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
TorrentBuild
    Assembly Version: 1.3.1.0
    Win32 Version: 1.3.1.0
    CodeBase: file:///E:/Our%20Documents/Peter/My%20Downloads/torrentbuild/TorrentBuild.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.9149 (WinRelRS6.050727-9100)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.9149 (WinRelRS6.050727-9100)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.9149 (WinRelRS6.050727-9100)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
EADCSharpClasses
    Assembly Version: 1.0.2.1
    Win32 Version: 1.0.2.1
    CodeBase: file:///E:/Our%20Documents/Peter/My%20Downloads/torrentbuild/EADCSharpClasses.DLL
----------------------------------------
EADVBClasses
    Assembly Version: 1.0.2.1
    Win32 Version: 1.0.2.1
    CodeBase: file:///E:/Our%20Documents/Peter/My%20Downloads/torrentbuild/EADVBClasses.DLL
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.50727.9149 (WinRelRS6.050727-9100)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Edited by Splitzzzzz
Link to comment
Share on other sites

5 hours ago, DreadWingKnight said:

That error is consistent with a file or folder not named properly, causing windows to throw errors that the file can't be found.

OK so shortened the root and sub-directory names. uTorrent still failed but TorrentBuilt worked and created the torrent.

I've added the .otrrent to uTorrent but the "pieces" status bar is showing all red, whereas other seeding otrrent sho green?

Link to comment
Share on other sites

Posted (edited)
57 minutes ago, DreadWingKnight said:

Did you point uTorrent at your existing files?

OK so I posted an update to the above, dunno what happened to it!

Anyways, I first just used the "Add Torrent..." method, didn't work, then used "Add Torrent (choose save dir)...", directed to where the folders/files are. It did a re-check and then pieces turned green (100%) and it's now seeding. Added 16 hours ago, not one single download yet so I'm hoping I did it right?

Cheers + thanks 

EDIT: typos

Edited by Splitzzzzz
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...