Jump to content

SKY Broadband


nickt
 Share

Recommended Posts

Since switching to sky broadband my utorrent fails to seed back. i sometimes get the green tick in the bottom right hand corner but even then if i run the connection check it states port is not open.

Running utorrent 2.2.1

port forward is set OK

tried via VPN and without VPN

Disabled Windows Firewall and all AV software 

stuck for now any ideas to check would be appreciated 

Thanks

Nick

Link to comment
Share on other sites

  • 3 weeks later...

I had no issue using Proxy to run utorrent with 2.2.1 utorrent. I've used this setup for long as I can remember and it has worked fine. Just use Proxy address outside of NA ISP blocks and you'll be fine.

Edited by PiusX
revise
Link to comment
Share on other sites

  • 2 weeks later...

Its most probably because Sky Broadband is using a CG-NAT. You might think your ports are open but they only open out to your ISP NAT where they are not. You will need a public IP address, perhaps Sky Broadband will let you opt out of CG-NAT if you call and ask (some providers do, just mention you need port forwarding). If not free, then most providers will also let you purchase a public Static IP address for a fee. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...