Archived

This topic is now archived and is closed to further replies.

stinkymojo

Error:The device is not ready.

Recommended Posts

Apologies if this is a stupid question but I've downloaded over 50 torrents now, completely trouble free but since connecting after a week away from using utorrent, anything I try to download gives this response:

Error:The device is not ready

I'm at a total loss as to what's gone wrong, I'm uploading my seeded torrents fine but the downloads just won't work. I've removed all the partially completed downloads from the tracker and the added new torrents, the same torrents and all combinations thereof, but still the same message. I'd be grateful for any advice you can give.

Share this post


Link to post
Share on other sites

Yes I have a External hard disc and the drive letter has changed to G from F, there's the problem no doubt but why has it changed, who did the deed? And what do I do about it now?

Manyy thanks for putting me on the right track though!!!

Share this post


Link to post
Share on other sites

You probably added some other drive -- maybe Daemon Tools? Anyway, you're going to have to point to the new location for each torrent, or find a way to change the drive letter back.

Share this post


Link to post
Share on other sites

Also getting "device is not ready" on a couple of torrents today. Problem is that the paths are correct and they work fine in shorter periods as long as I manually "force start" them in-between? (upgraded to 1.7.6 a couple of days ago)

Share this post


Link to post
Share on other sites

Where is the drive? external? networked? uT doesn't have any fault tolerance for losing pathing. Make sure your cables are securely connected and the bandwidth isn't being overloaded.

Share this post


Link to post
Share on other sites

The drive is external on my home computer, but 98% of the torrent working fine so I don't think that's the problem. And the download or upload speed doesn't seem to affect the problem at all.

Edit 1:

Just noticed that all the problem torrents are from the same tracker. So I guess it's likely that has something to do with the problem? However, to me it seems strange that a tracker problem would generate "device is not ready" in utorrent.

Edit 2:

Found some more torrents from the same tracker that working just fine, also tried to download a coupe of new ones, and this also works. So about half of them works ant the other half gets "device is not ready"

Share this post


Link to post
Share on other sites

Im having the same error, originally the files were on an external drive but i moved them to my desktop after reading this but it did not do anything

Share this post


Link to post
Share on other sites

no but I figured if I were to place utorrent in my program files and redownload the .torrent file than it should negate the problem however it did not

Share this post


Link to post
Share on other sites
Check in Preferences > Directories you have removed the path about your external HD.

Then do what was asked of you, because what you THINK should be done isn't always what SHOULD be done.

Share this post


Link to post
Share on other sites

I did as told and it did not work and thus I tried my own solution, do you have a problem with me trying to solve my problem myself as well as trying your solution

Share this post


Link to post
Share on other sites

I have a problem with you NOT informing us of the steps you're taking.

We aren't mindreaders.

We don't have access to your computer (as much as the tinfoil hat wearing retards would like you to believe).

Did you change ALL references to the external in your preferences to no longer reference the external?

Have you tried with reset settings.

Share this post


Link to post
Share on other sites

After changing all the directories to point to my external, and seeing it not work, I unplugged my external drive. Downloaded utorrent straight to my actual computer and re downloaded the torrent file to my downloads folder and tried it again. I still go the same error though. Should I try plugging the external drive back in and giving it one more try like that?

Share this post


Link to post
Share on other sites

I got the same problem (Device is not ready).

I tried all the above solutions and it still dont work.

I never use an external with utorrent, however i did have one plugged in.

I think the error happend after installing PowerISO.

Share this post


Link to post
Share on other sites

same prob. i use an external for downloading. the drive letter is the ok, path settings in utorrent are correct. there is more than enough free space in the drive, quota is disabled. what happens is that the external drive gets unplugged ( ???) and re-recognized again and again randomly. nothing wrong with the cables. its more like fluctuations in power causes this device to be momentarily unrecognized and then re-recognized again.

why though??? no idea. i never needed to use a USB-power cable for my external till now-just the usb data cable was sufficient, but since last week, i have to plug both the data cable as well as the power cable to my hdd else, it wont work. and so, fluctucation in power may be the cause. but y is my external power-hungry all of a sudden???

i checked usb settings in bios as well as device manager. i tried different usb ports on my PC but to no effect.

though i should also say that before this new hunger for power started, i used utorrent to download to this very same drive and never had this device not ready error. even back then the unplug-replug thing (mentioned above) kept happening sometimes and the autoplay woul pop up randomly for this drive. but back then, utorrent never gave me this error. it would only give this error if i unplugged the cable manually or if the drive stops for some time. so why utorrent has no fault tolerance now??? this uplug-replug thing takes just seconds or less and so there mustn't be any problems for utorrent. or should there?

can i do something with utorrent cache settings which can help avoid or atleast minimize this error??? like, say make utorrent access the disk less frequently so that there r less chances that the device is unplugged just at the moment utorrent tries to read or write from it???

current settings are:

ovrride auto cache size and specify in mb: 100mb

reduce memory usage when cache not needed: CHECKED

enable caching disk write: CHECKED

write untouched block every 2mins: UNCHECKED

write finished pieces immediately: UNCHECKED

enable caching disk read: CHECKED

turn off read cache if upload slow: UNCHECKED

remove old block frm cache: CHECKED

auto increase cache if cache thrashing: UNCHECKED

disable windows caching of disk write: UNCHECKED

disable window caching of disk read: UNCHECKED

Share this post


Link to post
Share on other sites

Same problem here: one torrent, all directories in Preferences -> Directories set to an internal HDD, no USB devices connected, wired (ethernet) connection.. same error.

Ports are randomised, encryption is on, download works for about 10 seconds then falls off with the 'device is not ready' error.

I figured it was active port-blocking at the ISP perhaps - and if that was the case, it wouldn't be the first time in IT history that an error message wasn't informative.

UPDATE: It turns out that I am an idiot. clicking on a torrent wasn't initiating the version of uTorrent I had parameterised; it was initiating one that was in a PortableApps directory, which - sure as eggs - was pointing to a non-existent drive. apologies for the idiocy - I have been watching too much American TV.

Share this post


Link to post
Share on other sites

I stumbled across this article after receiving the same error this morning on 2 brand new torrents that I was downloading. It helped me figure out my problem so being that it wasn't mentioned directly I thought to add my experience here in case it helps someone else out.

The laptop I'm using does not download anything to any kind of external drive etc... nor has it ever so no chance there was a mistake in the preferences though I checked anyways. After trying a few things to get it working again I started a previous torrent that I had stopped downloading to see if it worked OK and it did which got me thinking. Last night before going to bed I backed up the RSS.dat file from my other computer and loaded it on my laptop. The 2 new torrents I was having trouble with were started via the RSS downloader. That's when it hit me, the information for downloading torrents in the RSS Downloader was from the other computer so of course the path listed for all the torrents to be downloaded via RSS didn't exist on the laptop. Once I changed the path there it all worked fine.

Share this post


Link to post
Share on other sites

LOKI LOKI Many thanks my friend. This has been driving me nuts for weeks and as usual the solution is simple. Have changed my path in the RSS downloader for all my torrents hopefully my first successful night of automated downloads in a while is looming.

Share this post


Link to post
Share on other sites

Well, I didn't start mine from the RSS downloader, never used that.

I didn't have problems with my external drive before when I was using XP, now I do once rebuilding & upgrading to Win7.

I downloaded & updated the firmware & software for the drive, it's a WD MyBook 2TB. The USB drivers for my EVGA P55 SLi are up to date as well.

Torrents on the drive all get shut off every so often and you can hear a "disconnect noise" but the drive is still available. Almost like it flickers the connection.

I've also tried changing USB ports, changing from having the drive's AC adapter plugged into my normal surge protector to the wall socket.

I've thrown words into google for a few days now and have yet to come up with a concrete solution.

Actually, may have just found something in the Advanced Settings under Power Options. Going to fiddle around in there and post my results. I turned off all power saving features for drives and USB.

Didn't work.

Aha, I think I found the issue. Here's what worked, or has been working for around an hour at least:

Device Manager > Disk Drives > Right Click on Suspect Drive > Properties > Policies > Enable Write Caching.

drivefix.th.jpg

Share this post


Link to post
Share on other sites