Jump to content

Still get warning triangle & circle although ~5GB down & uploaded


Daytona

Recommended Posts

I've been using BT for a couple of weeks now and I'm intrigued as to why I'm getting the warning triangle & circle in uTorrent indicating that my ports are not forwarded even though I'm uploading and downloading at near max. line speed (30KB out of 36KB which is better than various local and foreign speed testers that suggest ~22KB). I've uploaded about 5GB and downloaded about 2GB.

They have been forwarded since day 1 using http://www.portforward.com. The setup is -

---

Network Address Translation (NAT) Configuration

Enabled

---

Network Address Translation (NAT) Rule Configuration

NAT Virtual Server/DMZ

Rule ID: 1

Rule Flavor: Virtual Server

IF Name: ALL

Protocol: ANY

Local Address From: 192.168.1.3

Local Address To: 192.168.1.3

Global Address From: 0.0.0.0

Global Address To: 0.0.0.0

Destination Port From: 20000

Destination Port To: 20000

Local Port: 20000

---

NAT Translations

No NAT Translations!

---

IP Address Configuration

System Mode: Routing

Get LAN Address: Manual

Actual LAN IP Address: 192.168.1.1

Actual LAN Network Mask: 255.255.255.0

Conf. LAN IP Address:

Conf. LAN Network Mask:

---

DHCP Mode: None

---

DHCP Server Configuration

192.168.1.3 192.168.1.34 192.168.1.1 Enabled

*I assume that this configuration is actually inactive due to DHCP mode being switched off*

---

The tests at http://www.portforward.com and http://www.btfaq.com/natcheck.pl fail and ShieldsUp! http://www.grc.com gives -

GRC Port Authority Report created on UTC: 2006-08-19 at 13:30:38

Results from scan of ports: 20000-20063

0 Ports Open

0 Ports Closed

64 Ports Stealth

---------------------

64 Ports Tested

ALL PORTS tested were found to be: STEALTH.

TruStealth: PASSED - ALL tested ports were STEALTH,

- NO unsolicited packets were received,

- NO Ping reply (ICMP Echo) was received.

My router is a BT Voyager 205 using the common Viking chipset. It uses stateful rules if that means anything ?

Also, I'm allowing any protocol through - can I tighten that up to just TCP? or are other protocols used (UDP?) ?

Thanks

Daytona

Link to comment
Share on other sites

So is the rule I set up incorrect, or is it being ignored ? If it's being ignored, how can I make the router obey it ?

If peers cannot make incoming connections to me how can I have uploaded to them when seeding ?

I couldn't see a FAQ that answered my specific question, if there is one please post the link.

Thanks

Link to comment
Share on other sites

No SW firewall - Windows 98SE

BT Voyager 205 router with built in firewall using the common Globespan Virata (now Conexant) Viking chipset (CastleNet AR502, Dynalink RTA100, RTA500-D51, GlobespanVirata, Netgear DM602, Solwise SAR100 & SAR130 etc)

No modem - ADSL not cable.

Does the fact that I'm seeding successfully mean that it's more likely to be a uTorrent bug ?

Oh I forgot to publish the (single) computers setup, but it's standard stuff and I no doubt would not have been able to do anything if it was incorrect ;)

Manually specify an IP address - 192.168.1.3

Subnet mask 255.255.255.0

Gateway - 192.168.1.1

DNS enabled - 192.168.1.1

NIC 3Com Etherlink 10/100 PCI TX (3C905B-TX)

Thanks

Link to comment
Share on other sites

Yellow or red circle does not mean you are entirely unable to download or upload, it just means you're not getting (or are unable to receive) incoming connections, which doesn't prevent you from making outgoing connections. So no, it's not a µTorrent bug.

You set up a static IP when you forwarded your ports, right? If so, then the firewall in the router's probably not letting the packets through, and SPI (stateful packet inspection) *could* possibly cause it.

Link to comment
Share on other sites

Ah! OK I obviously wasn't understanding the subtleties of incoming and outgoing connections. So even though I get plenty of ul & dl connections, they're of my own choosing - thanks !

I have had static IPs since before using bit torrent. Does the configuration in my previous posts look OK ?

I'l need to get my head around the firewall and SPI then. Thanks for pointing me in the right direction !

Any other comments or sources of information for this appreciated !

Thanks !

Link to comment
Share on other sites

You have to stop the firewall in your router from stealthing your ports. This on firewalling.com may help, except instead of Enabling you want to Disable. Your firewall does not know why peers are attempting to make what it considers to be unsolicited connection attempts, so it is "protecting" you from what might be a port scan by not replying in any way, known as stealthing. I do not use a router but had this same exact problem with Norton Internet Security's personal firewall.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...