Jump to content

µTorrent Linux as Daemon


Recommended Posts

  • 1 month later...

Bumping this thread :P

Sorry about that.

BUT, I heard some "rumours" (some time ago, some adminpost mentioned it.) about a Linux CLI (with perhaps a Web Interface) version of µTorrent.

And would like to ask about the status on those?

If nothing, i will cry myself to sleep.

If some, i will be a happy forumcamper. and stuff.


Link to comment
Share on other sites

  • 1 year later...

i tried this this (well kinda... i made a script to start it at start up under wine and then told to start)

it seemed to run (i could log in using the webgui) but complained about no display :)

i was wondering if this would cause any problems or if i could stop it looking for a display i tried /hide but that didn't seem to do it

Link to comment
Share on other sites

I haven't tested this, but indications on the net show that you can use Xvfb (a virtual X11 framebuffer) to trick Wine into thinking that there is actually an X server running on some non-existent display.



Taking a script from the latter link and adapting it, I guess you could try something like this:

echo "Running uTorrent:"
export DISPLAY=:1
Xvfb :1 &
wine [PATH TO uTorrent]
killall Xvfb

(replace [PATH TO uTorrent] with the full path to µTorrent like you normally would when running from Wine anywhere else)

At any rate, if µTorrent is running fine, you can most likely ignore the error messages you might see.

Link to comment
Share on other sites

thanks that worked :)

if i could stop the logging appearing in the console that i start it in that would be great

eg stop this

HTTP: Accept: */*
HTTP: Accept-Language: en-nz
HTTP: Referer: x-gadget:///gadget.htm
HTTP: If-Modified-Since: Sat, 1 Jan 2000 00:00:00 GMT
HTTP: Accept-Encoding: gzip, deflate
HTTP: User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; InfoPath.1; .NET CLR 3.0.590; .NET CLR 1.1.4322)
HTTP: Host:
HTTP: Connection: Keep-Alive

Link to comment
Share on other sites


Why would you be using the Vista gadget while running Linux...?

Either way, those messages should show up only in the µTorrent logger tab -- not the console. I've never seen it show up in the console either. Additionally, there should be no reason why chucking the logger messages into /dev/null should affect connectability O.o

Link to comment
Share on other sites

the gadget is running on another pc on my lan :)

got it :)


case "$1" in
su $USER -c "wine $DIR/uTorrent.exe >& /dev/null&"

echo "Usage: $0 {start}"

edit: as i don't really have any idea what i am doing (i looked at other scripts and tried to figure out how they work) i recommend that someone who does tidy it up and add a stop function

but it works for me as is :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...