Archived

This topic is now archived and is closed to further replies.

Directrix

WebUI v0.315

Recommended Posts

@YoaR I read the whole thread and the read me in webui zip, and I didn't find anywhere to say why its IE6 is not supported, all there is that just isn't. Would like some explaining on why when started creating the web ui didn't try working in IE6 compatibility and why from the sound of things it won't happen.

Share this post


Link to post
Share on other sites

IE6 isn't supported because of MS's lack of adherence to standards in that version of the browser, and because of the way the webui is implemented. It won't happen because MS isn't going to go back and fix IE6 to make it adhere to the standards.

The WebUI works just fine in IE7 (which MS will be releasing to all IE users as a 'security update' once it's out of beta).

That's all you need to know. :D

Share this post


Link to post
Share on other sites

Hi, thanks for this great plugin. I really like a lot, make my life easier.. :)

However, today when I log in, it stuck at loading page. It didnt happen before..

Cant log in the whole day. So, I read about when stuck at loading page.

Change at line 9-12 and try again. Sadly, just a blank page. Thats explained, I didnt use noscript extension.

I did few things to see if it helps. It didnt and still seeing the loading page.

1- turn on/off webui and restart client

2- disable/enable protocol encryption

3- replace webui.zip with a new one (incase the old one corrupted, hmm..)

4- changing the lines 9-12. (obviously not the problem)

The only thing I dont like is, each time I need to see the changes I made, I have to restart firefox as well, or else the page is stuck at loading page, the prompt for password never appear.

I forwarded port that I use and using SuperMario guide to "no-ip"ing my dynamic IP.

THe logger said:

[..] HTTP: IP **.**.**.**: GET /gui/index.html

...

stop at..

[..] HTTP: IP **.**.**.**: GET /gui/?action=getsettings

I didnt check the logger until now, so I dont know what it logs when everything run smoothly.

You guys have any solution in mind?

Thanks in advance.

Share this post


Link to post
Share on other sites

Currently, if I visit it with IE6, it says "The webui does not support your browser." Might I suggest that this be changed to "Your browser does not support the webui", so the user knows that it's the browser's fault instead of the webui's?

Share this post


Link to post
Share on other sites

Both good suggestions Poromenos and Determination :D

mfi08: come into IRC chan for help.

mrxrsd: its just u, unless its a specific preference u cant change?

Share this post


Link to post
Share on other sites

You know, it's weird, I downloaded the .310 b2 zip from the initial post, and it contains a filed called "utorrent-1.6.1-beta-build-482.exe", but when I run it, Help > About shows build 481:

aboutxt2.gif

Oh well...it seems to be working fine, so I'll leave it alone.

Also, I use stunnel for connecting via HTTPS, but at least with the .300 b1 (haven't used the new one long enough to know yet), I would be redirected to http:// instead of https:// which means I was prompted for authentication info again, and everything was going through clear text.

Share this post


Link to post
Share on other sites

I agree with schnurlos, it is build 482 in the zip, I downloaded 482 seperatly, but 482 in the zip has the same md5 hash as the 482 I downloaded plus it says 482 in About.

Share this post


Link to post
Share on other sites

Yeah, after further investigation I found I'd copied it to S:\BitTorrent\uTorrent\utorrent.exe while the shorcut was pointing to S:\BitTorrent\utorrent.exe, so I was still running the build from the Sept 21 download I did. Successfully running 483 now.

Share this post


Link to post
Share on other sites

483 should solve most of the loading freezing issues people are having. If people are still having them after upgrading to 483 then please come into #utorrent-webui so we can get some info from u.

Oh and before people inevitably start asking for a changelog, this is all your gonna get:

Ctrl+F12 crash feature taken out

Category list custom label bug fixed

Cache header bug fixed

Guest redirect improved

Share this post


Link to post
Share on other sites

ICleolion , nothing special....i want to change the torrent upload...i always opened "torrent properties" and changed, but now the dialog doenst open...if i roolback to webui 0300, everything works fine, for me is a webui 0310 issue...

i will try later with firefox...im using ie7

Share this post


Link to post
Share on other sites

@ICleolion

Yes, I will do that. Thanks.

@tjobo

I did read the readme, and I did what you have suggested. Still got the problem. Sorry I didnt mention it earlier. I wrote the post very late at night.

Since 483 is out, will try that out first. I cant right now because I'm not at home at the moment.

Thanks.

[*edit]

@ICleolion

Running 483 now, *with help of my housemate at home* (hope he dont screw up my pc though.. :| ).

The problem solved.

Before he replaces the 482 with 483, I tried for the last time logging in webui and it freeze at loading.

Then after 483 installed, the problem solved.

Thanks a bunch.

Share this post


Link to post
Share on other sites

Alpha-Toxic: Directrix :P

mfi08: im glad to hear that mfi08, one of the changes for 483 was an improved cache header, and im glad to see its working. Hopefully the number of loading freeze problems should be reduced now.

Share this post


Link to post
Share on other sites

Considering this is part of µTorrent - "Micro-Sized Yet Feature Filled", I think thumbs.dbs are a problem.

Anyways good work with the webUI, I absolutely love it!

Very minor bug: It says Pausing instead of Paused in the webUI.

Share this post


Link to post
Share on other sites

Because no one ever said UDP trackers would be supported, and ludde's not interested in implementing a dead (stupid) spec. Either way, this is TOTALLY unrelated to WebUI, so I'm not sure why you're even asking this here in this thread.

Share this post


Link to post
Share on other sites

just a question, I had dynamic IP... how can I connect to my utorrent if I'm not at home and I don't know my IP???

I can't be always calling to get it...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.