Archived

This topic is now archived and is closed to further replies.

Directrix

WebUI v0.315

Recommended Posts

Well, other BitTorrent clients did have a web interface before, too, so I wouldn't say this is exactly... revolutionary... but yeah, WebUI is great :P

oh really? hadn't seen any such client before :P well then great job ^^ although I'm pretty sure noone has managed to stuff all this into 170kb :D

Share this post


Link to post
Share on other sites

Hello everyone...

Xanderz, I just wanna say that I feel your pain :-P

I can't get this to work and I've been toying with it for several hours now. Every time I think about just dropping the whole thing I read another comment with someone saying that it worked for them and that its great. GRRRR! Guys, I'm not a Newbie here, I'm a pretty tech savvy guy, but I just don't know what I'm missing here...

1- I placed the webui.zip file in Apps Data directory for uTorrent. [CHECK]

2- Replaced executable with latest uTorrent client, version 483 [CHECK]

3- Went into preferences and enabled the Web Gui [CHECK]

4- Protocol Encryption is NOT enabled [CHECK]

** DIDN'T WORK / Firefox (v2.0) could not connect to the website or server **

5- Set alternate listening port to 6881 [CHECK]

** STILL DOESN'T WORK / Same message / Tried IE6.0, Same thing **

The computer where uTorrent is installed connects directly to the web, no router, no special port configuration needed. I even disabled the Windows Firewall for testing purposes. So... WHAT I'm I missing???

Any help would be greatly appreciated.

Later.

Share this post


Link to post
Share on other sites

First thing to check would be your firewall settings.

EDIT: Don't turn off the windows firewall. Sometimes, it stills blocks stuff even though the service is off. Just add the exception for the port.

Share this post


Link to post
Share on other sites

xanderz, i hope your replacing those x's with the computers IP address when you put it in the address bar

eg http://192.168.1.10:6881/gui

Also on the computer which you are running the WebUI off, type in

http://localhost:6881/gui

to make sure that the port is correct

KabutoCub

try

http://localhost:6881/gui

on the computer which utorrent and the WebUI is installed on

note: you do not need to activate the alternate listening port, the normal listening port which is used for torrent downloads will work

Share this post


Link to post
Share on other sites

xanderz, your problem most likely is very simple. You are missing /index.html. Unless you are running a web server on your computer it does not know to automatically look for index.html. You have to type that in fully on most computers. I personally have run the IIS Webserver so I don't have to type it in at all but most computers that have not need to type in the full url.

Share this post


Link to post
Share on other sites

... Disable Protocol Encryption and try http://localhost:port/gui/ again.

@molitar: Wrong, it's not the computer that needs to know what file to look for by default, it's the application doing the serving that does. µTorrent handles /gui/ (or even /gui) properly and automatically loads /gui/index.html.

Share this post


Link to post
Share on other sites

great work so far, but perhaps a logout feature would make this release a little more secure, seems that if i close the browser and reopen, i can get right back in without re logging in, people who use public computers could use a logout feature to enhance privacy

Share this post


Link to post
Share on other sites

I just get the "Loading..." screen in opera 9.00.8414 and in firefox... how can I fix it? It would be really useful to be able to edit torrents from work!

Also, why is it that when I use scheduler to limit the upload in the day (so that the connection is usable for browsing), the download also comes right down?

Share this post


Link to post
Share on other sites

Because you need to use µTorrent 1.6.1 beta build 483.

@tksm: There is no such thing as logging out in basic HTTP auth. Exiting your browser completely is sufficient.

Share this post


Link to post
Share on other sites

@motoroller: Yes it is. Pls read the included README.txt for it.

@xanderz:

1) use the newest beta build 483

2) this beta must be running

3) if u use ipfilter.dat, check if 127.0.0.1 is there; if, delete this entry

4) recheck your used port

Share this post


Link to post
Share on other sites

KabutoCub

xanderz

don't use "alternate listening port"!!!

"5- Set alternate listening port to 6881" - don't use this, too...

connectbd8.jpg

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.