Jump to content

WebUI v0.315


Directrix

Recommended Posts

  • Replies 1.3k
  • Created
  • Last Reply

Top Posters In This Topic

Hi...

Have I got this right -

1. I start uT on my PC at home.

2. I leave town for a weekend holiday (of course, I've left my PC on, running uT)

3. From where I am, I start Firefox(say) and I can watch the uT window on my PC(and maybe add/remove torrents etc) as if I never left home ???

4. Is that what the Web UI does?

Thanks!

Link to comment
Share on other sites

All I got is array of values on my screen by choosing:

http://localhost:Port/gui/?action=getsettings

or

-||-/?list=1

Direct link to Dir gives me:

application/octet-stream

Although there are several .php written working gui's using anything from Mainline over ABC to Azureus etc., I dont see why you shouldn't make this finally official.

What are the plans? Which object is going to be used here?

Thanks for your fantastic work...

Link to comment
Share on other sites

hi,

i have a small problem in using this UI.

i am using Hamachi to set up a VPN as i dont have a static IP address and my OS is Vista Ultimate.

the problem is that if i add a torrent using webUI from another PC it does not save the downloaded files in the default download directory. instead it tries to store it on c:\windows. since i am using vista it goes on a virtual directory.

any solution for this??

Link to comment
Share on other sites

MAY have found a bug. If I click the settings button (Purple button with a tick on it) I get the preferences page as you would expect. But if I click ok the page redirects to the webui at my alternative listening port. Since I'm using stunnel this page is not retrieveable as it should go to the webui at the port stunnel is listening on...

Should the webui be pulling the port from the url instead of the alternative listening port on the settings page?

If this has been posted already, my bad, I tried searching but this topic is huge!

Link to comment
Share on other sites

I can't seem to get this working. I'm using 1.7 Beta (1875) I've put the webui.zip into into the appdata/utorrent folder and it's enabled within µTorrent. However whenever I try to access it I just get a string of random characters. What am I doing wrong? Do I need to do anything with the sortabletable folder?

Link to comment
Share on other sites

i have the same problem with 1.7 beta. the webUI doesn't work. when i try to connect, the download window of firefox appears and ask me to download a application/octet-stream. when i download it, there are files with names like 29xzcm8z... i tried to re-enable the webui... without success.

greetz from switzerland.

Link to comment
Share on other sites

I've just upgraded from 1.7.0 beta build 147x to build 1875. The upgrade introduced a problem with the web ui.

I'm using Vista and Firefox.

The settings file in my client is now in apdata\roaming\utorrent. So I've put the webui.zip file there.

When I point my browser at the client, i get an "Opening" dialog box that says "You have chosen to open" followed by a blank space. The file is identified as an application\octet-stream. It's from http://myipaddress:myport (even though I'm opening /gui/). Firefox asks me what it should do, open the file with some rogram or save the file to disc.

This happens whether or not the web ui is enabled in the properties page.

Link to comment
Share on other sites

Sorry, I was typing that message while you were responding.

I am not using an alternative port. I can verify that the port in the configuration is the port I'm using because one of the tracker sites I use tells me my port.

I am trying to access the webui from a bookmark that worked before the upgrade.

Link to comment
Share on other sites

Really odd. Several people have reported this in the newest betas, but I've yet to see this problem without messing with the alternative listening port... In any case, I've already requested for the devs to change it so that µTorrent doesn't send the application/octet-stream stuff. Maybe that'll fix things?

Link to comment
Share on other sites

I have found a way to make the new beta build work.

Originally, I installed the beta with the build I downloaded from the web, then grabbed a new copy of the webui and installed it as I have several times (I've been using it since it was available for 1.6). That led to the situation I described above.

This morning, looking through the forum, I found an installer that handles both uTorrent and the webui in one fell swoop. So I uninstalled everything, then reinstalled using that installer. As per your hint here, I turned off the alternate webui port. Now the webui works.

The only change I could see between what the new installer did and what I did is, when I just installed the latest beta it installed itself automatically into \users\me\program files\uTorrent. The new installer gave me the default option of installing into \program files\uTorrent, which I accepted. The settings files are still in \users\me\app data\roaming\uTorrent, as is the webui.zip file.

I'm not sure what's different in the automatic installation, but anyone who is having a problem might want to uninstall and use the new installer:

Check here for more details: http://forum.utorrent.com/viewtopic.php?id=23819

Link to comment
Share on other sites

I upgraded my exe to latest beta 1.7 today - webUI now gives the octet stream error, if I switch over to latest 1.6 stable the webUI works as usual.

I did a fresh 1.7 install, default ports with no alternate settings - octet stream error

Changing nothing and launching with latest 1.6 exe, everything works.

So for now - no beta 1.7 if I want web access.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...