Jump to content

Port Forwarding Stopped Working


Recommended Posts

I have an issue where port forwarding has been working fine and then, as of about 4:30 this morning the router froze up (could get no connections out of it, even to web pages.) After cycling the power on the router (WRT54G, v6, firmware 1.09) things worked fine for a few minutes and then froze up again. Once I got home this evening and cycled the power again there were no more freeze ups, but now I get the red indicator in uTorrent that the port forwarding is not working. I tried specifying different ports but nothing ever changed. I looked at the incoming log on the router and see incoming connections for the port (i.e., it seems to be getting through my Cisco 678 DSL modem fine). Another odd thing is that when I run the port forwarding test the port listed for the test is ALWAYS the original port no matter what I change the listening port to.

I have a second pc with a clean XP Pro install (I'm in the process of setting up a new computer) so I set up uTorrent there, used a different listening port, and still I get the red indicator (although for the forwarding test the port now changes when I change the listening port).

I should note that the forwarding test has NEVER worked, even when I was getting a green indicator.

I read the "Setting up µTorrent for your internet connection" and tried the things it suggested, even turning off UPnP on both the router and uTorrent (I tried this on the clean machine and the indicator remains yellow.)

Now, this does seem to point to a router not forwarding issue since I get the problem on two machines, so I plan to contact LinkSys to see if I can resolve the issue. But I did want to put this out to you guys to see if any have encountered it before and perhaps solved it.

On a related note, why do I WANT to have a port for incoming connections? My down and upload speeds seem about the same as when I had the green light. What turns the use of the port on and off? Is it related to DHT, UPnP, or what (naive questions I'm sure and if there is a good easy to understand explanation regarding all that please point me to it.)

I also read the "µTorrent Connection Setup Guide" and did what was suggested there (even disabling UPnP on the router and on the "clean" machine. I got the yellow indicator and it never changed until I re-enabled UPnP.)

I read the "DHT Not Working? Things to check" note and tried what was suggested in the first post but nothing has changed (except now I have no dht.dat files and all my active downloads show red and low download speeds. Uploads going great!)

Edit: I tried to restore my old dht.dat files and found out that new ones WERE created. Not all download are blue (that were before, anyway.) Download speeds slowly climbing back to normal. Still have red connection indicator.

Thanks for your help in advance.

Link to comment
Share on other sites

Let's assume there's only 10 people connected on a torrent...1 of them is a seed, the other 9 are peers/leechers.

...And they're all firewalled.

That torrent is DEAD!

NOBODY can download from or upload to ANYONE!

You port forward so you are not firewalled, so you can download from and upload to firewalled peers/seeds.

Link to comment
Share on other sites

Thanks Switeck for your explanation. That makes perfect sense.

Does no one out there have any suggestons? The only change I've made so far is to un-check "Block Anonymous Internet Requests" as suggested by forwardport.com. Still no luck. I've tried connecting directly to my DSL modem, still the red indicator. On my priamary machine when I select option|speed guide the "Current port" is greyed. ON my other machine it is not greyed and can be changed (both are running the same version of uTorrent). I have no firewalls other than Norton Anti-virus, but don't even have that yet on the other machine. On that machine the indicator stays yellow the whole time. I have checked and double checked my forwarding and all looks fine.

This is driving me NUTS! I can't stand the reduced download speeds nor the fact that all seems to be correct and yet it will not work properly. ANYTHING at this point anyone can suggest would be of great help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...