Archived

This topic is now archived and is closed to further replies.

Lord Alderaan

mIRC script

Recommended Posts

utorrent webui is on 192.168.1.13

irc is on 192.168.1.11

when i use this script i get

* /sockopen: insufficient parameters (line 93, webui.mrc)

Share this post


Link to post
Share on other sites

From what i can see its to do with url port. Now I have tried the LAN IP, WAN IP, and LAN PC NAME.

These all work fine through my browser. firefox

Im using port 8813

Is there anything I am doing wrong?

Share this post


Link to post
Share on other sites

i added the script as mentioned

utorrent.mrc file loaded in mirc

using version 6.35 but no luck yet

<B0T> [µT] Torrents: 0 (Seed:0, Leech:0, Inactive:0). 0B/s down, 0B/s up. Ratio: 0 Remaining: 0B Downloaded: Uploaded:

any hint?

Share this post


Link to post
Share on other sites

i double check everything u mentioned and its all fine

i put them like username password localhost port

means after the veriable i put space and provide the info

is it ok?

still no luck

Share this post


Link to post
Share on other sites

I am having the same problem. This script used to work with the exact same details when I had utorrent 1.8.2. But now I switched to 1.8.3 (build 15772) and the script doesn't work anymore. I get the same output as AYEHAN. Maybe some changes in the latest version has caused this?

My utorrent is connectable and the webui and connection ports are open. The password is correct. I can login to webui through my browser.

Share this post


Link to post
Share on other sites

If you don't like seeing this in the IRC window:

* Timer ut_getinfo_end activated

You can silence it by replacing:

timerut_getinfo_end 1 20 ut_getinfo_end

with:

.timerut_getinfo_end 1 20 ut_getinfo_end

and:

timerut_getinfo_end off

with:

.timerut_getinfo_end off

Share this post


Link to post
Share on other sites

Ok I have been having an issue since I have installed this for the first time. I was running the ut version of 1.8.1 when I first put the script in and using the mirc version of 6.35. This is what I get every time I try to use the script in mirc.

* Timer ut_getinfo_end activated

[9:05pm] <04~Whitey> 12[µT] Torrents: 0 (Seed:0, Leech:0, Inactive:0). 0B/s down, 0B/s up. Ratio: 0 Remaining: 0B Downloaded: Uploaded:

* Timer ut_getinfo_end halted

It never shows the correct stats I am not sure what I am doing wrong I have done everything correct I believe. My mirc is running on the PC of 192.168.1.100 and the ut is running on the 192.168.1.101 here is a link to the pastebin so you can see what I have in the code.

http://pastebin.com/m4359e93c

Thx's for any help.

Share this post


Link to post
Share on other sites

To fix script change this part:

  ; the hostname or ip of the machine running µtorrent, if µtorrent + webui is running on the same computer leave it at localhost:
set %ut_url localhost

; µtorrent port (or the alternative webui port if activated):
var %ut_port 32459

into:

  ; the hostname or ip of the machine running µtorrent, if µtorrent + webui is running on the same computer leave it at localhost:
set -n %ut_url localhost

; µtorrent port (or the alternative webui port if activated):
set -n %ut_port 32459

This seemed to do the trick for me.

mIRC's scripting language is very tricky.

Share this post


Link to post
Share on other sites

Ok I've integrated that into the OP. I guess it could mess up somehow in specific situations.

btw the suggestion by memosis was already worked into it back when he posted it I just never bumped the thread with an update notice.

Share this post


Link to post
Share on other sites

Ever since the new changes, I've been getting this:

* /sockopen: insufficient parameters (line 93, utorrent.mrc)

Replacing

var -n %ut_port 32459

with

set -n %ut_port 32459

fixed it.

Share this post


Link to post
Share on other sites

i did what u said but only stats and find work when i try to use utdl and utul i get this error for every torrent : * Invalid format: $ut_convert_status (line 179, perform.ini)

Share this post


Link to post
Share on other sites

i hadn't seen it, but then again i could just be blind or half asleep but why not add a one time setup to ur script to make it a bit easier for people?

on *:connect:*:*: {

if (%setup == complete) { $null }

else {

; the username for the webui:

set %ut_username $?="WEBui username"

; the password for the webui:

set %ut_password $?="WEBui password"

; the hostname or ip of the machine running µtorrent, if µtorrent + webui is running on the same computer leave it at localhost:

set -n %ut_url $?="Enter IP or Hostname of machine running µtorrent"

; µtorrent port (or the alternative webui port if activated):

set -n %ut_port $?="Enter WEBui Port"

; OPTIONAL! maximum number of displayed torrentlines (not counting header and footer):

set %ut_flood_max 5

set %setup complete

}

}

should work then to reset setup u would just need to type /unset %setup and it should check each time you connect to make sure setup is still complete (could be a bit off im outta practice on mirc scripting)

Share this post


Link to post
Share on other sites

That is certainly a good idea. Although maybe an onload thingy would be better.

tbh this was merely a working example. And I was never really happy with how I interpreted JSON, I improved it yesterday by using regex but it still doesn't actually properly interpret JSON.

If I ever write a proper script I will certainly include features like onload setup, customizable layout and configurable display options.

In the mean time feel free to write your own script and post it in a topic on this forum. As you can read in the license above you are free to use any or all parts of my script :)

Share this post


Link to post
Share on other sites

on load would work but it wouldnt check the scripts setup each time u started mirc :) not all that great at writing scripts its been a long while

Share this post


Link to post
Share on other sites

Thanks a lot for a nice script /utstats work for me however

/utul keeps failing with this message in status:

* Invalid format: $ut_convert_status (line 177, µT stats.ini)

/utdl don't even do anything.

Share this post


Link to post
Share on other sites
Thanks a lot for a nice script /utstats work for me however

/utul keeps failing with this message in status:

* Invalid format: $ut_convert_status (line 177, µT stats.ini)

/utdl don't even do anything.

edit line 177 as follows :D

  var %temp = [µT]   $left(%torrentname,40)  $+ $ut_convert_status( %status , %progress ) UP: $+ $bytes( $regml(tor,7) ).suf SIZE: $+ $bytes( $regml(tor,4) ).suf R: $+ $calc( $regml(tor,8) / 1000) UL: $+ $bytes( $regml(tor,9) ).suf $+ /s P: $+ $regml(tor,13) $+ ( $+ $regml(tor,14) $+ ) S: $+ $regml(tor,15) $+ ( $+ $regml(tor,16) $+ )

or just put equal (=) after .... var %temp =

Share this post


Link to post
Share on other sites