Jump to content

mIRC script

Lord Alderaan

Recommended Posts

  • 2 weeks later...
  • Replies 87
  • Created
  • Last Reply

that is what i thought, hehe, maybe he is a god or something, lol, thanks for the info Lord alderaan

Edit: btw, my friend edit the mirc script so you can get the info from more then one webui at the same script, like this: !utbw box1 = show one info , !utbw box2 = show the another one, i can post it here or somethink, but i would like one funcion, like, !utbw ALL, and the script gets the info for the both machines or more, like all, and put all together, like 500kb/s from one and 500kb/s, will the show as the total

1000kb/s, is it hard to make? do u have the time...thanks for make the great script

Link to comment
Share on other sites

I updated the script 2 days ago with my most recent version. It now shows total downloaded and total uploaded over the current listed torrents when you use /utstat.

Don't expect any expansion of this script until the 1.8 based webui is released.

When this happens I'm thinking about a few changes I might implement although I'm gonna focus on a php shell.

Link to comment
Share on other sites

  • 5 months later...

Update: Jan-19-2009

Here's a right-click menu I wrote for Lord Alderaans script.

To install this little addon. Just copy and paste this code to the bottom of Lord Alderaans. Then click File -> Save. Now just right-click in a channel window and you will see a uTorrent option :D

; -================================ RIGHT-CLICK MENU ===============================- ;

Menu Channel {
.$iif($menu != Menu Channel,Stats): /utstats
.$iif($menu != Menu Channel,Download): /utdl
.$iif($menu != Menu Channel,Upload): /utul
.$iif($menu != Menu Channel,Find): { /utfind $$?="Enter Search String" }
..$iif($menu != Menu Channel,Enable Channel): { /utchan enable }
..$iif($menu != Menu Channel,Disable Channel): { /utchan disable }
.$iif($menu != Menu Channel,Help): /uthelp

Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...
  • 3 weeks later...

Hi there.

Been using GTSdll for a long while, but it's just suddenly stopped now so I came to look for another script and found this.

Quite liked it at first, didn't work on my pc directly so I had to use another pc to query the PC over the network / internet and that worked fine for about a day.

It's stopped working now and I've not changed anything, any ideas as to why?

Also, in the process of getting it to work I updated the WebUI, does the script still work with that?

Oh thought I would add it looks similar to post #25 in this thread. I don't get any stats though and I don't see any connections made to uTorrent in the logger.

Many thanks in advance.

Link to comment
Share on other sites


Look for this line:

    ;    msg %ut_activechan 12[µT] Error: webui is not responding (socket error).

And remove the ; at the start. Then try again. Do you get an error now?

If Yes: Then the login info is probably wrong. Maybe the utorrent port changed, you could try setting a Alternative port for the webui and use that cos it would never change.

If No: Mail me (through my profile here) the JSON text array you get when you goto http://uturl:port/gui/?list=1 and I can take a look where the script goes wrong.

Link to comment
Share on other sites

Hrm, I removed the ; and no dice. Not sure what you mean by the JSON array but i'm lookin it up :P - I think I know what it is, but just need to make sure :P.

Also if you have msn / g-talk maybe we can work it out there?

Oh and, tested everything. Simple user + pass with localhost doesn't work on the PC where uT is, nor does a networked ip ( = PC where uT is). Tried the external IP too i.e the one people see and still no luck. Checked the ports, set it to 8080, made sure nothing blocking it and still no dice.

Many thanks again.

Link to comment
Share on other sites

  • 3 weeks later...

I'm not too great with scripting but I'm thinking that means it's timing out.

Try to increase the time in the script :

Change line 20 in the script from:

timerut_getinfo_end 1 20 ut_getinfo_end


timerut_getinfo_end 1 40 ut_getinfo_end

And see if that helps. If it doesn't change it to

timerut_getinfo_end 1 60 ut_getinfo_end

Link to comment
Share on other sites

Afaik you always see * Timer ut_getinfo_end activated even if it works.

If you don't get your info there might be a lot of things wrong. As Daed said it might be timing out. It might also be that the info you filled in is wrong. It might be that a firewall is blocking it. It might be that you are using an old version of utorrent. etc. etc.

There isn't really any error description system in place. It either works or it doesn't :P

Link to comment
Share on other sites

  • 2 months later...
  • 5 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...