Archived

This topic is now archived and is closed to further replies.

hiddenriver

I'm writing a WebUI-like firefox extension

Recommended Posts

Nice little addon there avaly.

Have got that installed & running without any problems.

Just a not thought for some reason it says "Radio" as opposed to "Ratio" bit of a spelling mistake lol

Nice Google addon too & I have utalised that make HTML creator with great effect.

Share this post


Link to post
Share on other sites

Alt-u does not work for me running Vista, firefox 2.0 and no other extensions.

I like the 0.1.2 upgrades and suggest this change for the next build:

when you left click the status panel, the sidebar will popup

when you right click the status panel, the options dialog will popup

It would be super-cool if you could drag and drop to status panel(or some button or custom field) without launching the sidebar.

Thanx for this great extension!

Share this post


Link to post
Share on other sites

That's awesome avaly! Thanks for keeping the project going. So I've done a couple of things. First, I've integrated all of avaly's improvements into the official version. Second, I've implemented runemail's request of drag and drop to the status bar. So you can start torrents without opening the sidebar. Good idea runemail.

You can get utorrentext-0.1.4.xpi at the usual place.

- hiddenriver

Share this post


Link to post
Share on other sites

thanks for this, its a really cool thing to use.

Only i cant use the drag and drop to the status bar.

Am i doing somthing wrong or is this a bug in the extension?

Share this post


Link to post
Share on other sites

It could be a bug but I'll need more info to fix it. Which browser, browser version and OS are you using? Does dragging to the sidebar also not work or is it just a status bar problem?

Also, just to make sure, you are using version 0.1.4? I updated my previous post to make that clearer. Just checking.

Also, you need to drag the link over the area of the status bar where it shows the utorrent upload and download rates. I should have made that clearer too lol.

Thanks for the info.

Share this post


Link to post
Share on other sites

I use firefox 1.5.0.8 on win xp sp 2

I can drag the torrent to the sidebar, but when i drag the torrent to the statusbar the cursor changes in to a (im sorry but i dont know the english translation for this word, but i think its called a forbidden sign or something like that).

I have tried it on an other computer (win2000 sp4 firefox 2.0)

And i can drag it to the sidebar but not to the statusbar.

Thanks for the quick respons.

Share this post


Link to post
Share on other sites

I just tried it in Firefox 1.5.0.8 and drag and drop seemed to work for both the status bar and the sidebar. Is there anything unusual about your setup that might make a difference? Just to be clear, you have to drag and drop to the area surrounded with red in this picture.

statusbar.gif

Share this post


Link to post
Share on other sites

Well im sure i use the right place to drag and drop the torrent(its the place you indicated)

I have included a hijackthis log, maby therse something wrong with the setup of my pc.

Logfile of HijackThis v1.99.1

Scan saved at 16:24:36, on 18-12-2006

Platform: Windows XP SP2 (WinNT 5.01.2600)

MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)

Running processes:

C:\WINDOWS\System32\smss.exe

C:\WINDOWS\system32\winlogon.exe

C:\WINDOWS\system32\services.exe

C:\WINDOWS\system32\lsass.exe

C:\WINDOWS\system32\svchost.exe

C:\WINDOWS\system32\svchost.exe

C:\WINDOWS\system32\spoolsv.exe

C:\WINDOWS\Explorer.EXE

C:\Program Files\DAEMON Tools\daemon.exe

C:\Program Files\DU Meter\DUMeter.exe

C:\Program Files\NOD32\nod32kui.exe

C:\WINDOWS\system32\ctfmon.exe

C:\Program Files\NOD32\nod32krn.exe

C:\WINDOWS\system32\svchost.exe

F:\Bestanden\Programma's\Tools\00 uitzoeken\HijackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.google.nl/

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.google.nl/

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Local Page =

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName = Koppelingen

O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 5.0\Reader\ActiveX\AcroIEHelper.ocx

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java jre1.5.0_06\bin\ssv.dll

O2 - BHO: Adobe PDF Conversion Toolbar Helper - {AE7CD045-E861-484f-8273-0445EE161910} - C:\Program Files\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll

O3 - Toolbar: Adobe PDF - {47833539-D0C5-4125-9FA8-0819E2EAAC93} - C:\Program Files\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll

O4 - HKLM\..\Run: [DAEMON Tools] "C:\Program Files\DAEMON Tools\daemon.exe" -lang 1033

O4 - HKLM\..\Run: [DU Meter] C:\Program Files\DU Meter\DUMeter.exe

O4 - HKLM\..\Run: [nod32kui] "C:\Program Files\NOD32\nod32kui.exe" /WAITSERVICE

O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe

O8 - Extra context menu item: Convert link target to Adobe PDF - res://C:\Program Files\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: Convert link target to existing PDF - res://C:\Program Files\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: Convert selected links to Adobe PDF - res://C:\Program Files\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECaptureSelLinks.html

O8 - Extra context menu item: Convert selected links to existing PDF - res://C:\Program Files\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppendSelLinks.html

O8 - Extra context menu item: Convert selection to Adobe PDF - res://C:\Program Files\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: Convert selection to existing PDF - res://C:\Program Files\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: Convert to Adobe PDF - res://C:\Program Files\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: Convert to existing PDF - res://C:\Program Files\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\OFFICE12\EXCEL.EXE/3000

O8 - Extra context menu item: E&xport to Microsoft Office Excel - res://C:\PROGRA~1\MICROS~2\OFFICE11\EXCEL.EXE/3000

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java jre1.5.0_06\bin\ssv.dll

O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java jre1.5.0_06\bin\ssv.dll

O17 - HKLM\System\CCS\Services\Tcpip\..\{959C29C4-D5AE-45AF-81AB-C3463F73336A}: NameServer = 192.168.0.1

O23 - Service: NOD32 Kernel Service (NOD32krn) - Eset - C:\Program Files\NOD32\nod32krn.exe

Share this post


Link to post
Share on other sites

i also can't drag and drop to the status bar. i upgraded the extension, i see the new features, i can mouse over the info and a little pop up shows my torrents and such. however dragging and dropping there, i also get the forbidden mouse icon.

Windows XP SP2

Firefox 2.0

No other extensions/add-ons i could imagine to conflict.

and a side note, not related to his issue, but now when i use the sidebar, it lags my FF nearly to a halt. it works in shorts bursts until i close FF (often manually terminating the process). this began happening BEFORE i upgraded to the current version. but it seemed to happen from no where. i did not install any new software or addons to my knowledge that would have caused this.

Share this post


Link to post
Share on other sites

Noticed another quirk today if you set a file to Forced it vanishes from the list.

Had a few files that I had forced seeding past my max ul limit & they were not visable until I took the forced off.

Great app though keep up the good work.

Share this post


Link to post
Share on other sites

great addon, now I dont have to check the server every 5 min.

two thing doesn't work for me tho, for the statusbar, everyone say the upload and download speed, for me it just say "uTorrent" and when I hover my mouse over it, all I get is a little box.

the screenshot proablly can explain better.

untitleddi6.png

I have adblock plus and noscript addon install, but I dont think thats the reason why this is not working

Share this post


Link to post
Share on other sites

Beserk1, does the sidebar show the WebUI? Are you able to drag and drop torrent files into the sidebar and do they start downloading? Which version of Firefox? Which version of WebUI? Can you try connecting from another computer and see if that works?

When the sidebar just shows "utorrent", that means it can't connect to the server. That could be because there's too much traffic or you made a mistake when you typed in the address, port, username and password. You could pause your torrents and see if that helps. If not double check the options just in case. Or it could be a bug. I'll need more info before I can fix it though if that is the case.

Does anyone else have this problem?

Share this post


Link to post
Share on other sites

wow so many questions.

does the sidebar show the WebUI?

- yes

Are you able to drag and drop torrent files into the sidebar and do they start downloading?

- haven't tried that, but I tired dragging to statusbar, and yes they do start downloading

Which version of Firefox?

- 2.0.0.1

Which version of WebUI?

- 0.1.5

Can you try connecting from another computer and see if that works?

- same thing, but that because is the exact same image of the computer

p.s. that status box in the option show a bunch of stuff, I dunno if thats an indication of anything

EDIT: after removing couple finished torrent, it seem is working now, dunno if I had too much torrent downloading at a time. If there is a max at displaying, is it possible to increase it?

Share this post


Link to post
Share on other sites

This is a long shot because I can't be sure exactly what's going on but you can try this. Let me know whether it fixes the status bar for you because I need to know whether these changes should go into the next version. I suggest nobody else installs this unless they are having the same issue as beserk1 and want to see if it helps. This version has no new features. Only a possible bug fix.

http://thinkpond.org/files/utorrentext-0.1.5-beserk1a.xpi

Share this post


Link to post
Share on other sites

I will try it right away, gimme sometime to get the bug out again, then I will install the new one.

Thanks

Edit:

I failed to reproduce the bug, but I dont think bandwidth is a problem, as I am using lan ip, so it should use the lan bandwitdh, not the internet one.

I tried downloading 30+ torrent at once, still no luck, sorry.

Share this post


Link to post
Share on other sites

After changing the interval from 10 to 3, the bug resurfaced, all it display is just "utorrent" in the statusbar. I even try the bugfix version you provided, no luck. But I can view the webui by alt+u or typing in the address.

Share this post


Link to post
Share on other sites

So let me get this clear... the status bar was working when the update interval was 10 seconds. Then when you changed it to 3 seconds, it stopped working. Right? If you increase it back to 10, does it start working again? Thanks for the help.

Share this post


Link to post
Share on other sites

ok I just notice it stopped working again, cuz it only had one torrent, and when I added 2 more, it didn't change.

I restarted firefox and is still not working, and when I increase it back to 10, it still doesn't work.

Thanks for helping

Share this post


Link to post
Share on other sites