Jump to content

WebUI doesnt work through firewall!!


Recommended Posts

I posted this afew days ago in the main thread and got no reply:

OK, I upgrated to beta 483, installed the webui.zip, and configured it for basic access on the same port I use for torrents.

my setup: torrent server behind a linksys router/firewall on dsl.

ports are forwarded correctly. utorrent/ftp/remote administrator/pc anywhere all work fine

webui will only work correctly from within the firewall

outside the firewall, I can log in remotely via FF, but I cant see any torrents. It shows me as having zero torrents in all the lists on the left, and nothing shows up in the main window. I can get into options and tweak the settings, it does indeed change them. I even added a torrent from a local file to the remote server. it still didnt show any torrents in the webui, but it did in fact load in the actual program.

any clues as to why it is not displaying my torrents? Have tried this from both dialup and dsl connections outside the firewall.

after about 10 sec. I get 'the request to utorrent has timed out' in both cases.

I tried changing to a dedicated port instead of my default torrent port, same deal.

I'm hoping someone else has seen similar results, seems like a firewall issue of some sort. is there anything I need to do besides port forwarding. I'm kinda stumped. all other remote access programs work fine. I wanted to use the webui instead of full remote access to make it quicker, but I'm gonna stick with remote access for now.

thanks :)

Link to comment
Share on other sites

Well since it works locally its most probably related to your firewall. Maybe a bug in it. Maybe a problem with the many connections µtorrent makes causing it to maybe drop your webui connection.

Maybe there is a new firmware for your firewall?

Try reducing the number of connections µtorrent is allowed to make.

Can you try another router/firewall, set it up properly and see if the problem persists.

Can you try running µtorrent + webui + port maps on a different box in your network and see if it has the same problem?

Maybe there is other things you can think of to see if you can get any other reaction?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...