Jump to content

utorrent embedded tracker woes :(


Recommended Posts

to expedite my request heres a little introduction to my issue-

lets start off by saying i searched the forums for this issue. i read, at least the first 2-3 pages of search results. I have my CCNA cert. A Long with a BS in IS.

any who, i can not for the life of me get the embedded tracker to work. AZ version works, bitcommet's, even abc (?) . I'm going to skip the usual questions/comments about the faq and ports being forwarded. i've read them all and understand them. I have tried literally everything. from a local environment to an internet environment. in fact the only way i got utorrent's tracker to work (technically) was 1.) input the peers manually, or 2.) use a open tracker. both of which i would like to avoid.

i like az a lot. but it uses way to much memory. and plus i like ut even more :D

here are the most common errors -

connection timed out

target machine refused connection

connection reset by peer

listed by most to least common.

a killer BT program. thanks for your hard work. and thanks for your replies.

Link to comment
Share on other sites

i assigned lan IPS. i could ping both computers from each other. so they could talk. i could even xfer files.

the tracker url was the ip of whatever computer it was connected to. ie

or something like that.


ok got something to work. i used az on one machine as the tracker for all. the other systems are using UT. works great until the az machine go's down. after the az machine stops tracking the ut machines will not start to pick up any peers. ive waited just over an hour.

Link to comment
Share on other sites

This may seem crazy, but I think the problem may be what µTorrent thinks the "internet connection ip" is.

In short, it sounds like there's not one...so it either defaults to or 169.something. But either way, it's not really there...and the tracker's listening on an ip:port that will never receive any traffic, while ignoring the LAN traffic.

Have you tried messing with net.bind_ip and net.outgoing_ip? I have a nasty feeling that you'll need both to make it work.

Link to comment
Share on other sites

np man, we're only human. and i just tried the items you sugested switeck. is this the correct config-

net.bind_ip <fake interal

net.outgoing_ip <fake external

port 9800 <fake port

becuase if so, it still says "cannot connect. the machine actively refused it."


i stubled apon a program called hamachi. its a VPN client and it configures everything for you. tried to use that to simply things. still no go. i can xfer through it, just the tracker doesnt work.

Link to comment
Share on other sites

µTorrent doesn't work except with TCP/IP level proxies. A VPN or proxy that's made to carry HTTP/HTTPS traffic is simply not good enough.

I think you need to force µTorrent to bind to whatever ip you internally assign to the computer, and give it the SAME ip for both net.bind_ip and net.outgoing_ip. The first tells µTorrent that "this is what LAN/WAN ip this computer is using." The second tells µTorrent that "this is the LAN/WAN ip this computer connects outward through." ...which isn't the same as which LAN/WAN ip this computer connects outward TO.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...