Jump to content

Confused about Linksys WRT54G Read the FAQ


Recommended Posts

Ok, I have read the sticky on the top which linked me to the guide about upgrading your firmware. It says "The following note does NOT apply to WRT54G/GS v5s! Use the latest official firmware (1.00.9+) with those, they do not suffer from this problem."

Ok, so I went to and it says Firmware Version: v3.03.6, but I still have that problem. I only download at like 20kb/s-40kb/s when I usually download around 200kb/s.

So this may sound stupid but why am I having problems? Do I need to update my firmware? Thanks!

Link to comment
Share on other sites

Eh I dunno, actually, but I kinda assumed it would be rather explicit, considering how a bunch of people manage to find out whether they're using V1-V4 of WRT54G, or V5 or above =T

Try looking around on the box or something... or around the router configuration pages.

Link to comment
Share on other sites

How to know your WRT54G/GS Router Version by Serial number.

Known serial numbers (first few characters) vs versions:

CDF0 = WRT54G v1.0

CDF1 = WRT54G v1.0

CDF2 = WRT54G v1.1

CDF3 = WRT54G v1.1

CDF5 = WRT54G v2.0

CDF7 = WRT54G v2.2

CDF8 = WRT54G v3.0

CDF9 = WRT54G v3.1

CDFA = WRT54G v4.0

CDFB = WRT54G v5.0 (VxWorks)

CGN0 = WRT54GS v1.0

CGN1 = WRT54GS v1.0

CGN2 = WRT54GS v1.1

CGN3 = WRT54GS v2.0

CGN4 = WRT54GS v2.1

CGN5 = WRT54GS v3.0

CGN6 = WRT54GS v4.0

CGN7 = WRT54GS v5.0 (VxWorks)

CL7A = WRT54GL v1.0

CL7B = WRT54GL v1.1

CL7C = WRT54GL v1.1

Link to comment
Share on other sites

  • 2 weeks later...

I have bellsouth. My friend has bellsouth, and he scores over like 500kb/s.

But I fixed it though. :D

I was forwarding wrong. I was putting 0 in on my port forward thing, not the correct setting, so now I score over 100kb/s. Thanks for the help I guess, but it working pretty nice now.

Thanks again for the support and help, I know that I can come here for more help and get a good answer. :)

Link to comment
Share on other sites

  • 6 months later...

I will be downloading at speeds up to 3 and 400 with an open port, then later in the same day I start again and the port is closed. I restored to the following days settings that worked in the morning, but nothing changed. Is there something I'm not checking? Also, my daughters laptop with the same port works just fine. I'm confused.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...