Jump to content

connection closed by peer


Recommended Posts

hi i've been using utorrnt for quite a while now, and always try to keep a fair share ratio, and generally seed out what ever i've torrented for the remainder of that day.

but today in the tracker status i'm getting a 'connection closed by peer' message for anything i torrent, (even from different trackers), and while i can see peers in peers section i don't seem to be able to download from them.

i'm really confused, have i done something wrong without realizing it, and how can i fix this problem?

i really apprecieate any help anyone can offer, thanks.

Link to comment
Share on other sites

I am also getting this error..."connection closed by peer"...and indicator turns red.

I just moved and switched ISP's (im on cogeco)...and I've never seen this b4.

Torrents seem to download/upload fine, but sometimes they dont show im seeding on tracker(s), and that I'm concerned about...

I switched half-open to 8 (i had at 15)...and that doesnt seem to fix it...:-/

I dont use DHT, switched port #'s and tried diff. torrents/trackers...I hope its not my isp (b/c its fast!)...and theres some way around it...

Thx for ur help...

Link to comment
Share on other sites


does any1 know what I can do to fix this?...its killing me!, lol...

My BW is wide open, and I hit my max on everything, but Im getting this error, and I'm afraid its not reporting it to tracker(s) properly...I need to stop and re-start the torrent(s) to get rid of error....but it just comes back after time...:-/

It has to be my new ISP...and I use encryption...plz help, lol...

// sorry for bump, but I have no patience...:P

Link to comment
Share on other sites

You should limit upload speeds to less than max for your connection to prevent just this sort of error. (which is caused by overloads)

Who's your ISP?

What's the tested max bandwidth speeds for your connection and what all settings are you using in µTorrent as shown by Speed Guide (CTRL+G)?

Link to comment
Share on other sites

thanks for any help you can be, my details are also listed below, at one point i thought the problem had been solved, cos it started working again the next day, i put it down to my IP address changing between tries, but the problem has come back once again, with that dreaded message "onnection closed by peer", any help you can provide would be awesome, thanks!

ISP - Pipex at about 2.2Mps

I hit 50/kbps on downloads. On uploads I peak around 45/kbps

Upload limit: 25/kb (just set now)

Upload slots: 8

Connections (per-torrent): 100

Connections (Global): 750

Max active torrents: 9

Max active downloads: 8

Current port: 62226

Link to comment
Share on other sites

chicken, you are allowing FAR too many upload slots and torrents at once for your connection.

With an upload speed max of only 25 KB/sec, you're potentially splitting it 72 ways...so average speed per upload slot is only 0.35 KB/sec. With so many connections total, that too is probably eating into your potential max upload and download speeds.

Try the Speed Guide (CTRL+G) with the xx/256k upload setting -- that's the closest upload speed to your current setting.


Encryption is probably best set to Enabled with "Allow incoming legacy connections" ticked.

A proxy might help, but it will probably result in you always being firewalled (if using a proxy). Most proxys CANNOT handle the kind or amount of traffic that BitTorrent generates, so even if you do find one you will probably need to use VERY conservative settings to prevent overloading the proxy.

Link to comment
Share on other sites

Thx for ur reply Switeck...

Im scrapping the whole proxi idea...lol...thx for the info...

As for encryption, I had a friend tell me to use "forced"...and my torrents didnt go red over night...so I dont think its a problem on my end, it has to be my ISP. But at least they reported correctly w/ these settings, so Im not touching them.

My solution?...restart utorrent when the torrents go red...and all is good.

Thx for ur help...:-)

Link to comment
Share on other sites


I'm sorry that I missed the obvious problems in your stated settings.

You are running possibly too many torrents at once and DEFINITELY too many upload slots at once without any upload speed limits.

Try the xx/1Mbit setting in Speed Guide (CTRL+G). Also check the box to allow additional upload slots if upload speed is <90%. And also set the alternate upload speed while not downloading to 115 KB/sec (or higher if you think your connection can handle it).

You can fudge the numbers Speed Guide recommends a little, but often to keep a balance you need to reduce one to increase another.

Link to comment
Share on other sites

As I said, it has been going much better than b4....but I still receive this msg quite a lot....I was also told the reason could be because, UT was trying to update to the tracker to frequently/much....

Is there a way I can change how frequently UT auto updates to the tracker?....(trying everything, lol)

Thx for ur help...:)

Link to comment
Share on other sites

Well I dont seem to get that msg very often anymore...:)

...but I do have another problem, lol....I can only seem to upload about 10/K (avg), on most sites. (all private)....

They're all healthy torrents w/ plenty of leechers....one of the files, Im the only seeder and I cant give them squat....I know this problem isnt utorrent's, its my ISP....

I still have all the same settings as above, and downloads seem to be ok, its just the upload on most sites, wont go past 10/k....

I've asked on many forums b4 I switch ISP's for some help....

Any incite is greatfull...thx

Link to comment
Share on other sites

ya I found this post here... http://forum.utorrent.com/viewtopic.php?id=9605

sorry for posting it in here first....I have a tech coming from Cogeco today (as they suggested b4 I cancel)...and he wont find anything wrong....so Im going to bell w/ a server from LT!....(screw em, lol)

@ Ultima...PE = encryption?...sorry not sure what that means...

Thx again for all ur help guys...:)

Link to comment
Share on other sites

  • 2 weeks later...

With Rogers, I used to get the same message. It usually happens after large amounts of traffic on the same port that they throttle it. Stop all torrents, change the port (and open them up in your firewall and/or router, use some port in a very different range because they might throttle ranges around your current port) and start again. It is advisable to restart the computer (just in case you have half-open sockets lying around). Usually works for me.

Hope this helps.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...