Jump to content

Rather bizarre speed problem occuring..


Recommended Posts

Hello, I've tried out everything you have in the troubleshooting section, but nothing seems to work. I'm currently downloading a rather large file, and my speed seems to hover at 1-5 kbps, even though it occasionally jumps to as high as 35. When I look at other peers, I see that they're downloading at high speeds, 65+. I've tried the test torrents, but they don't download at higher than 20 (as far as I could tell, anyway). Here is my computer stats.

- Status color is green.

- The port checker says the port is functional.

- My speed guide settings are at 64kbs (even though I have a much higher download connection, my upload is low, seeing as my region doesn't support high upload connections).

- Operating system is Windows XP home edition.

- I have a firewall/antivirus program called BitDefender, version 9.

- Process list: Process PID CPU Description Company Name

System Idle Process 0 92.31

Interrupts n/a Hardware Interrupts

DPCs n/a 6.15 Deferred Procedure Calls

System 4

smss.exe 656 Windows NT Session Manager Microsoft Corporation

csrss.exe 704 Client Server Runtime Process Microsoft Corporation

winlogon.exe 728 Windows NT Logon Application Microsoft Corporation

services.exe 772 1.54 Services and Controller app Microsoft Corporation

svchost.exe 932 Generic Host Process for Win32 Services Microsoft Corporation

hpgs2wnf.exe 328 hpgs2wnf Module

hpoevm08.exe 2080 HP OfficeJet COM Event Manager Hewlett-Packard Co.

svchost.exe 992 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1088 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1140 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1196 Generic Host Process for Win32 Services Microsoft Corporation

spoolsv.exe 1480 Spooler SubSystem App Microsoft Corporation

mdm.exe 696 Machine Debug Manager Microsoft Corporation

nvsvc32.exe 884 NVIDIA Driver Helper Service, Version 84.21 NVIDIA Corporation

svchost.exe 1380 Generic Host Process for Win32 Services Microsoft Corporation

xcommsvr.exe 1584 BitDefender Communicator Server Softwin

iPodService.exe 2252 iPodService Module Apple Computer, Inc.

ServiceLayer.exe 2340 ServiceLayer Module Nokia.

HPZipm12.exe 2448 PML Driver HP

alg.exe 2844 Application Layer Gateway Service Microsoft Corporation

svchost.exe 2652 Generic Host Process for Win32 Services Microsoft Corporation

livesrv.exe 244 BitDefender Security Service SOFTWIN S.R.L.

bdss.exe 3132

vsserv.exe 2552 BitDefender Security Service SOFTWIN S.R.L.

lsass.exe 784 LSA Shell (Export Version) Microsoft Corporation

explorer.exe 1752 Windows Explorer Microsoft Corporation

SOUNDMAN.EXE 1852 Realtek Sound Manager Realtek Semiconductor Corp.

hpgs2wnd.exe 1876 hpgs2wnd Hewlett-Packard

jusched.exe 1904 Java 2 Platform Standard Edition binary Sun Microsystems, Inc.

iTunesHelper.exe 1912 iTunesHelper Module Apple Computer, Inc.

bdoesrv.exe 1956 bdoesrv application SOFTWIN SRL

bdnagent.exe 1968 BitDefender News Agent SOFTWIN S.R.L

bdswitch.exe 1976

LogiTray.exe 1992 ImageStudio Tray Application Logitech Inc.

ICQLite.exe 2016 ICQLite ICQ Ltd.

ctfmon.exe 196 CTF Loader Microsoft Corporation

NMBgMonitor.exe 224 Nero Home Nero AG

hpobnz08.exe 212 HP OfficeJet COM Device Objects Hewlett-Packard Co.

hposol08.exe 256 HP OfficeJet COM Device Objects Hewlett-Packard Co.

msnmsgr.exe 3116 Messenger Microsoft Corporation

iTunes.exe 3076 iTunes Apple Computer, Inc.

firefox.exe 1180 Firefox Mozilla Corporation

WinRAR.exe 1800

procexp.exe 3000 Sysinternals Process Explorer Sysinternals

bdmcon.exe 4092 BitDefender Management Console SOFTWIN S.R.L.

explorer.exe 2564 Windows Explorer Microsoft Corporation

EM_EXEC.EXE 292 Logitech Events Handler Application Logitech Inc.

utorrent.exe 2704

- My router model is DL-614+,

- My ISP is Netivision IL (israel)

- My connection is a 1.5mb cable connection. My dl speed is 187 kbps, my ul speed is 8 kbps

- Computer hardware: 1024 RAM, nvidia 7800 GT, AMD athlon 64 bit 3500+, net cards: 1394 Net Adapter \ NVIDIA nForce Networking Controller

Thanks for the help in advance :D

Yours sincerely, Ori

Link to comment
Share on other sites

Nope.. No significant change after raising the limit to 6 kibs. Could my client be fooling me? I have an all clear in terms of status, but I am only connected to 8 seeds out of 160 and 35 peers out of 1230. I have gotten a success in the port testing and such, but maybe my low peer connection is the key to the problem. Any ideas if it's just the fact that my upload is low or if it's something else? (By the way, if you're wondering, my router has DMZ enabled)

Link to comment
Share on other sites

A router in DMZ mode leaves your computer dangerously exposed to the internet -- requiring the use of a 2-way software firewall on your computer. And even then your computer is still vunlerable to Denial-of-Service attacks that would normally be shielded by the router.

Can you try manual port forwarding instead?

Link to comment
Share on other sites

I tried manual port forwarding, but my router is quite stupid, it keeps.. well, deleting my firewall settings, I don't get why, but I think that one of the firmwares I've installed may have caused the issue, and seeing as they have no support centers nearby, nor is my warranty valid, I'm stuck with a DMZ.

Update, I've disabled my DMZ, but uTorrent's firewall is still there. I tried the firewall test, and it alternates between a "good" and "bad" result, with no real reason. The torrent's status is still green, but I still have the same strange error (the original one, that is).

Link to comment
Share on other sites

Still sounds like a choked connection to me...


- Disable IP resolving in the Peers tab

- Try disabling DHT (Can be found in Preferences > BitTorrent)

- Try disabling UPnP (Can be found in Preferences > Connection)

- Try lowering maximum global number of connections to 200? 100? 50? (Can be found in Preferences > BitTorrent)

- Lower net.max_halfopen to 4 (Can be found in Preferences > Advanced)

- Patched TCPIP.sys and restarted computer after patching? (Assumes you are using Windows XP w/ SP2)

- Connect your computer directly to the modem to make sure the problem is not caused by the router

- Restart your computer, modem, and router after performing any of the above

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...