Jump to content

Good download, slow upload


Recommended Posts

I have had this problem for a while now. If I'm only seeding, my upload speed is fine, but if I'm downloading too, it takes a nosedive and goes to about 50%. If I cap my download, it helps a bit, I can get about 60-75% of my upload speed back.

Since it's the season to be sharing, I'd like to get this fixed now.

I have lazy bit enabled

encrypted enabled

legacy incoming enabled

prioritize seeding jobs enabled

last version, yes

global connections, 80

per torrent, 55

down speed, about 18 KB/s

up speed, about 9 KB/s

number of open torrents does not seem to matter (I've tried).

I've had every weird problem ever (for example, I periodically go not clever for a few weeks, then go clever again), and I'm ready to blame my ISP for everything, but maybe something can be done.


Link to comment
Share on other sites

Found it.

max half open, 8

Btw, I keep maybe 10 torrents open, but the sites I use, I seldom actually seed even just one torrent (that's why I keep so many open, to try and find the one that will get a leech). Still, maybe I should go to 2 upload slots anyway...



I applied the patch and set half-open connections in utorrent to 25. I feel better, but I'll have to check on it for a while to see if there's any change.

Btw, I read in a thread that some guy was advised to uninstall nod32 to get the patch. This is UNNECESSARY (I know you help a lot of people, that's why I'm telling you... I'll try to post this in the right thread later). If you try exiting nod 32, nodkernel or sth will still be running in the background, and you can't kill it with task manager. This is true. But if you disable IMON and AMON modules from WITHIN nod32, you can download and execute the patch (respectively).

Link to comment
Share on other sites

A user offered this explanation in another site. Do you reckon it's correct? (as background info, I mentioned I didn't have this problem with azureus).

"TCP over head sucks. Let's say if you have my bandwidth (625k/48k) and you're downloading something at 300kps. If you're seeding at full upload you'll notice that you're upload will fall by about 20k. utorrent is using that to communicate with the other peers and download at 300k. The higher it goes the lower you're upload goes. Simply because there are so many open connections, each of which requires a little upload to keep open.

You'd have to cap you're download to under 50k not to notice the decrease in upload. Also do not increase you're max peer (locally/global) past 50/300 either as that will just eat you're upload as well. Also if you want to download faster you should limit you're upload speed by 15 percent or more depending on the other peers. Many times you'll notice a massive increase in download speed when there are many seeders or fast seeders. This is because utorrent will use the bandwidth that's left open to download.

Azures does a little better with tcp but only if the other peers are also using azures. Of course the more torrents you have running will affect the upload as well. Albeit you would have to go over a few hundred open and ready for seeding to notice a big difference, although try not to be actually seeding more than 5 - 10 at any given time to be most efficient. Probably best to start removing torrents once you go over a hundred active and ready for seeding."

Link to comment
Share on other sites

  • 2 months later...

So NOD 32 AV interferes with the half open connection limit?

Seems that's probably part of the reason why many people are having problems with it!

To answer the other question, yes high download speeds suck up a considerable amount of upload bandwidth. I estimate it takes at least 1 KB/sec of upload speed to maintain 50 KB/sec of download speed. So if you're downloading at 300 KB/sec, then your upload speed can be reduced by well over 6 KB/sec. Even 20 KB/sec upload speed lost is not impossible if you've got 100+ connections.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...