Jump to content

Problem with Downloading Speed


Recommended Posts

Hi, I recently got a new Sattilite ISP, as it is the only other ISP I can get besides Dial-Up. The ISP is called Hughesnet.

I am also using a Belkin F5D6231-4 Router, and have set the proper ports up for utorrent in my Router configuration screen.

However when using utorrent my download speeds never go above 1.0 kb per second, usually staying at 0.5 kilobits.

I know this isn't normal epecially whe it's a broadband sattalite service with rated speeds at 512 - 768 kilobits per second. I have no problems with download managers, usually reaching 100 - 200 kilobits per second download speed.

Also, even though I forwarded the ports properly in my router configuration screen, I check to see if the port has properly been forwarded with utorrent, and it say's it has not been properly forwarded.

I am also getting the red exclamation light for my status, and have tried everything to fix it. I suppose a NAT Problem might be the cause of my woes???

I already know that hughesnet throttles the speed down to a crawl after you download 176 megabytes, but that's not my problem, as the speed is always like this from the start.

I'm sorry for the spelling and grammar errors in my post, I am however in a bit of a hurry.

I have already read the stickies on speed problems, however non of them helped

Thank you to anyone that can help me.

Link to comment
Share on other sites

"it's a broadband sattalite service with rated speeds at 512 - 768 kilobits per second. I have no problems with download managers, usually reaching 100 - 200 kilobits per second download speed."

You're probably confusing connection speeds in kilobits per second with download speeds of kiloBYTES per second. If that's the case, your connection is even faster than it is rated for!

Is your limit 176 megabytes per day/hour/week/month?

Your useable upload speed is probably <200 kilobits per second, so you probably need xx/256k setting in Speed Guide (CTRL+G) or slower if it can't upload that fast.

Most sattelite connections are LAN-only ip addresses, in short you're ALWAYS firewalled and UPnP won't help. Even DHT probably won't work and is best disabled.

Link to comment
Share on other sites

If I'm always firewalled with a sattilite connection, how do I forward ports properly on the sattilite connection?

Also Just got a linksys WRT54G Router to use, however it made no difference.

I already forwarded the ports properly for the router, how can I do it for the sattilite modem/connection?

It's a Hughesnet modem, and Hughesnet is my ISP (The only Broadband service available in my area).

I've already disabled DHT and UPnP, with no difference as well.

Thank you if anyone can help.

Link to comment
Share on other sites

I have the router WRT54GL with DD-WRT v23 SP2 stable version configured with 4096-240-240 and QoS enabled so that it will be Bulk traffic (specified by static port). The 1.5 version used to work OK with it but now the 1.6 makes it choke when it's been running for a long time. Anyone with the same problem?

Link to comment
Share on other sites

Don't hijack threads. Start your own.

@Xtreme2damax: Switeck's point is that you probably can't unfirewall yourself if you're using a satellite connection. Meaning the best you can do is select a decent/correct upload speed in the Speed Guide, and pray/hope that you can connect to fast, unfirewalled peers.

Link to comment
Share on other sites

I just checked the status of my modem by typing in the modems IP Address, the Status of the Modem indicates that the modem is not firewalled, it say's that the firewall is disabled. The only thing that is firewalled at the moment is the router I am running off of.

I'm thinking it must be something on the routers end, or the connection between the Router and my Computer.

I'd also like to add that for me to connect to the router and get on the internet, I am using a semi-wireless RadioShack Universal Broadband Link, which transmits Data between a unit in my bedroom and a Unit in my Kitchen, and is connected to the router, transmits data using a wall electrical outlet.

However I don't know if that may have something to do with my poor speeds/connection problems.

Thanks to anyone that can help me further, if possible :)

Link to comment
Share on other sites

@Ultima: I didn't mean to hijack the thread. I saw that he used the Belkin router and then the WRT54GL without any improvement and since I own the WRT54GL I though it would be useful to notice that I have a minor problem with 1.6 version doing that too! I had no bad intentions. Sorry.

Link to comment
Share on other sites

Even if you unfirewall EVERYTHING on your end, your satellite ISP probably has you behind THEIR router back at their headquarters/whereever you connect to the rest of the internet. And that's what makes you firewalled...and you can't port forward it.

Wireless connections tend to only get max speeds with unobstructed LOS and less than 10 feet distance. I've read of studies where the wireless max useable speed was only about 1/10th the rated max even at 20-30 feet.

Link to comment
Share on other sites

Thanks for the Reply.

I'm not ready to exactly give up as of yet. I still believe there must be a way to get this to work properly.

Theres a Sticky at the top of this forum, that states there is Speed/Connectivity issues with the linksys WRT54G Routers, and to use a custom firmware or the such called DD-WRT, and theres another one, but I can't remember the name of it. It states if you're having problems with these routers, to flash them with this custom firmware based on the original firmware by linksys.

I have that exact model of linksys Router, however the custom firmware is incompatible with my router, as I have a v6 or version 6 of this router. I don't really need to risk flashing the router with the wrong firmware, end up bricking it, and having my family yell and scream at me because I ruined the router.

Torrent and P2P clients are the only programs I am having trouble getting to work. Download Manager Programs such as Gigaget, that use a port work flawlessly at a normal speed, I just don't understand why I'm just having problems with torrent and P2P clients.

Is there anyway to bypass this, or a program that will enable me to bypass or solve this restriction (If there is even one)

Also what does utorrent require ports to be forwarded on? Is it TCP, UDP, or Both TCP/UDP ?

This speed is not acceptable, especially considering the size of the files I need to get. At this rate it'll take me 5 weeks to complete a 1 - 2 gig file.

No matter what torrent I try, even if ther is a lot a Peers/Seeders, my connection/Speed is utterly poor.

I know there might not be a way as Switeck mentioned, but I am still hoping someone here will post a solution so I can solve my problem.

I'm sorry if I'm annoying anyone, it is not my intention to. I just don't want to give up as of yet and call it quits and not be able to get the files I need such as certain linux distros, freeware programs, and other files that I can legally download, Such as Public Domain content and the such.

Thank you once again, if someone knows a possible solution or a way to bypass this problem/restriction. The model Number or whatever the modem is: A Hughesnet modem HN7000S

Link to comment
Share on other sites

I Just figured out something with a little searching on the net. Apparently the Hughesnet HN7000S Modem had a Proxy configuration or an IP Routing/Web Acceleration feature called Turbo Page.

I disabled it, and it opened up my ports to utorrent so my port was properly forwarded. However I am still getting the Yellow Exclamation point in my connection status. My download Speeds improved somewhat, but not by much.

Now that I disabled the Turbo Page feature of the modem, I am able to open up ports, and run a successful Speed Test on dslreports. My Download Rate is about 650 kilobits per Second Downstream and 128 Kilobits Upstream.

I ran a Download with Firefox and my download speeds were 100 - 130 Kilobits or Kilobytes per second (I don't know which exactly).

Now that my Ports for utorrent are opened up, shouldn't I be getting a much higher download speed.

If it means anything, My router is set to use DHCP, and Not a Static IP. Could that be my problem?

Will placing my computer in the DMZ improve my Download speeds, if I cannot set a Static IP? (Don't worry, I got a good software firewall, so I really don't need the use the routers hardware firewall)

Thanks if anyone can let me know :)

Link to comment
Share on other sites

How would I check my computers Lan IP? Can I view it by using the ipconfig utility included in Windows XP ie... ipconfig /all ?

Should that show me my Lan ip? The IP that is shown when I do ipconfig /all is , is that my LAN ip?

If it is, I have already set the router to forward data to that ip Address.

I heard of an accelerator for bittorent clients. However the only one I heard of that gives a small speed boost is bundled with difficult to get rid of spyware.

Is there anything else or another app, that will accelerate my connection somewhat, and is not bundled with spyware?

I try what you mentioned, however if it doesn't work as expected I'm going to start looking for something that will help me achieve better speeds.

Thank You if you can help me any further ;)

Link to comment
Share on other sites

I found out that I have to make utorrent report my WAN ip, according to an individual in another forum, or else I'm going to have problems.

I also found out that another p2p app, Called DC++ (Please don't get offended by me mentioning another p2p app, I only used it as an example), gives you an option "Firewall with manual port forwarding", and allows you to enter your External / WAN ip Address or LAN.

After I did this with this app, I was able to connect flawlessly without a problem. So my guessing is that the NAT (Which the modem has) is acting kind of like another firewall, and the only way to be able to bypass this, is to be able to enter your External / WAN ip and forward the ports properly, which I don't think utorrent includes this feature (I may be wrong though)

Thank you if anyone may be able to help me finally solve this annoying problem.

I tried a torrent for openoffice from the link you posted, however I am still having the same speed issues.

Link to comment
Share on other sites

Ok I just retried the open office torrent. My download speeds climbed up to 102 - 105 Kilobits per second, and leveled off in the 90 - 95 Kilobit range, sometimes climbing up to 105 Kilobits per second. Is that Normal speed for my Connection type?

Most other torrents are going slower or much slower than the open office torrent did

However, I am still getting that yellow exclamation for my connection status.

In the logger it says, "[5:17:02] UDP Port Bind() Failed"

what does that mean? I am directly connected to the modem now, so the router isn't my problem.

Thanks if anyone can let me know ;)

Link to comment
Share on other sites

Yes, those speeds are just about the max for your connection speed. As for the port issue... again, it's probably due to the fact that you're using satellite -- I'm not sure how you managed to get it to seem forwarded before ;\

And the UDP port binding... have you disabled UPnP in µTorrent?

Link to comment
Share on other sites

Yeah I disabled UPnP in both utorrent and on my router.

The open office torrent downloaded quick at 100 Kilobits per second. Why are all the other torrents going so slow, and the open office one went fast.

Also it seems on most other torrents, that my upload speed is higher than my download speed. I have configured utorrent for the proper speeds for my connection. Would you mind explaining to me why on some of the torrents my upload speed is greater than my download speed.

Thank You.

Link to comment
Share on other sites

Because you're wrongly assuming upload speeds will always be lower than download speeds, which is simply not the case ;\

The OpenOffice.org torrent runs quickly because it's seeded by people on very fat pipes. That you can't connect to other peers properly without your ports forwarded can partly explain your bad download speeds.

Link to comment
Share on other sites

"The open office torrent downloaded quick at 100 Kilobits per second."

Actually, 100 Kilobits per second is rather slow -- at less than 13 KiloBYTES/sec.

Or did you actually mean 100 KiloBYTES/sec?

Connection speeds are typically rated in Kilobits per second, while download/upload speeds are typically measured in KiloBYTES/sec. The conversion between the 2 is about 10 Kilobits per second of bandwidth is needed to download at 1 KiloBYTE/sec.

Link to comment
Share on other sites

I get confused sometimes, I believe the open office torrent was going 100 KiloBytes per second.

I take it that 192.168.x.x is not a static IP Address, so I guess that means I won't be able to forward my ports properly.

Also if I go into the Hughesnet HN7000S Modem control center, and go to system info, NAT and DHCP are enabled. Is there any way to disable these, or am I SOL and will be forced to live with slow download speeds yet again in the torrent clients?

What I don't get is if I click on "Speed Guide" in utorrent, and test to see if the port is properly forwarded, it Say's OK in green, however I still have problems even though my ports are forwarded properly in my router. However forwarding other p2p apps such as emule still greets me with a failed error when I test the port. I can't even use frostwire, as I am totally unable to connect because the modem is using NAT and DHCP :(

[beginning of Rant]

We would get cable or dsl, if it was available in our area. Much better speeds than satellite, No Fap limit, and the ability to download as much as I want or need, with none of this, "Pay us extra in order to get a Non-Routed static ip" , All for as much or less less than the $59.00 monthly bill for satellite , not including the price of equipment needed for satellite.

So basically we're paying out the arse for severely crippled broadband. Basically to my understanding all satellite is good for is browsing the web and downloading small files.

One of the main reason people need and get High Speed or Broadband is Downloading large files and the small majority who run businesses online.

If I wanted to browse the web with near broadband speed and download small files, I can do that on dial-up with a web proxie or accelerator and a download manager, I even managed to download a 409 MB file on dial-up. It took a while, but at least there was no FAP restrictions or limits [/End of Rant]

Link to comment
Share on other sites

Hey Xtreme2damax,

I also have Hughesnet because I have no other broadband options (well.. that wouldn't cost hundreds of dollars a month).

Things were great until somewhere around the end of summer 2006 when I began having the exact same problem that you are experiencing. All torrent progams and many P2P programs began slowing to a crawl. I've tried many, many, many configuration options as have many of the people on the Hughesnet forum at dslreports.com .

The conclusion: Hughesnet is throttling (blocking) torrent and most P2P activity.

I have had limited success with a few P2P programs, Frostwire in particular works to a certain degree. But I haven't found a torrent program that works.

Bottom line: With few exceptions (like the OpenOffice one you experienced), torrents simply will not work with Hughesnet.

Yeah... I wish I had another option in my location, too.

- Nuke

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...