Jump to content

Utorrent causes major CPU slowdown...


Recommended Posts

I've been using uTorrent fairly successfully, but over the past few days, I've noticed that whenever I have the program open, it causes major spikes in my CPU usage (i.e. 100%) and slows down my whole computer. I recently installed a wireless router (D-Link WBR-1310) on my desktop, but I'm not sure if that is (or can) cause the major spikes in CPU usage.

I'm pretty much a noob w/ computers, so I would appreciate any help or feedback...especially if you've experienced the same thing.

Oh, and last night, I set up a forwarded port for uTorrent, but the spikes were happening before I did that.

Really appreciate any help.

Link to comment
Share on other sites

From the FAQ:

My µTorrent/PC freezes or locks up every 30 seconds and/or uses 100% CPU, slowing down my PC (Avast!, possibly others)

This can be caused by Avast!'s P2P shield, which scans P2P apps. Disabling this option will fix your problem.

Here's step-by-step instructions on disabling the P2P shield (thanks to scarface_666):

Double click the left mouse button on your Avast! icon in the system tray (to the left of the system clock) and your On-Access Scanner will open in a separate window. If you don't see the icon, click on the arrow and it should expand to show all the icons in the system tray.

Click the left mouse button on the "Details >>" button at the bottom of the Avast On-Access Scanner to open up more options.

Look for the P2P Shield on the left of you On-Access Scanner window and left click your mouse button on it and the P2P Shield should now be highlighted.

Now click your left mouse button on the "Terminate" Button (Located on the right of the On-Access Scanner window) and you should see some text near the top of the window saying "No task is currently using this provider".

Finally, click the "OK" Button and the bottom right of the On-Access Scanner window and the P2P shield will be disabled.

Alternatively, Avast! has a Customize option button besides the Sensitivity slider bar. You can exclude programs from the P2P shield in there. Excluding utorrent.exe may also solve the problem.

Kerio Personal Firewall / Sunbelt Personal Firewall uses 100% CPU when running µTorrent and/or disconnects my internet every few minutes!

Kerio Personal Firewall / Sunbelt Personal Firewall has a bug where it uses 100% CPU and may cause your connection to drop when using µTorrent.

The fix for this is to:

Open up the Kerio GUI (best to do while no torrents are running)

Click on the Overview tab (top left)

Make sure you are in the 'Connections' section of Overview

Right click in the window where all of the programs currently using a network connection are listed

Un-check 'Resolve Address' option (3rd from bottom)

This will get rid of the issue of KPF using 100% CPU.

The reason it was using 100% was because it was trying to resolve the host name of every address that is trying to connect to your computer. The higher than normal connection attempts from running torrents overloads it.

This fix works for all torrent programs running on systems with KPF installed.

Thanks to Noodlewad for the fix.

Hope it helps!

Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...