Jump to content

Internet disconnects when using uTorrent


pinksteady

Recommended Posts

Hi all,

I've started having problems with uTorrent, to the extent that it will now only run for about 5 minutes before the wireless internet on my PC disconnects. I am using a Belkin F5D7050 wireless USB dongle to connect to a 2Wire (BT) wireless router. Up until about 2 weeks ago I haven't had a single problem with torrents, and now I can't stay connected for more than 5 minutes!

When the disconnect happens, Windows will give a message like "cannot connect to preffered wireless networks" or "wireless network unavailable" and the light on the USB dongle will be stuck permanently flashing as if it has crashed while downloading a torrent. The only way to reconnect my PC to the internet is to unplug the USB wireless dongle and plug it back in again, repairing doesn't work and if I try to disable it instead of unplugging it, Windows says "Failed", but it disables it in Device Manager and I have to manually enable it from Device Manager, THEN unplug and replug it.

Recently Windows would not find the wireless adapter on startup either, and I thought this was related, but today I fixed that by setting a few relevant internet services in Computer Management to 'automatic' instead of 'manual', and now it connects to the net on startup, but the connection problem is still there.

Often, if uTorrent is downloading and then I use something else to download from, like allTunes or Send/Receive in Outlook, the Internet will fail in the same way. The only errors I get in Computer Management under 'System' are always the same:

Event 8033: Browser

The browser has forced an electio on network \Device\NetBT_Tcpip_{registry key} because a master browser was stopped

followed by

Event 4201: Tcpip

The system detected that network adapter \DEVICE\TCPIP_{83605BC6-FCD4-48D0-B226-CAE902EEA3C0} was disconnected from the network, and the adapter's network configuration has been released. If the network adapter was not disconnected, this may indicate that it has malfunctioned. Please contact your vendor for updated drivers.

Sometimes in reverse order.

I still get the Tcpip event 4226 error - tried the patch but it seems not to work.

I occasionally get Event 10005: DCOM

The service cannot be started, either because it is disabled or because it has no enabled devices associated with it" attempting to start the service upnphost with arguments "" in order to run the server {2048......}

I don't use upnp and I think I even have it disabled because my router does not support it so I think that error is irrelevant(?) but thought I'd mention it anyway.

It seems like there are too many connections or something and the router is being overflowed if that makes any sense (I don't really know what I'm talking about here), and I have lowered the number of global connections to 80. Just started logging and found a few entries saying "Disconnect: Too many global conns". Should I lower the global connections more?

Any help would be great, cheers everybody!

Link to comment
Share on other sites

  • Replies 88
  • Created
  • Last Reply

Nope still not working.

(oh and the problem I had where the wireless would not connect upon startup has not been fixed. After Windows starts I have to unplug and replug the USB adapter about 3 times before it connects. It will then stay connected until I use uTorrent. My computer also instantly resarted today for the first time when I replugged the adapter. Also, when booting, after the Windows logo shows I very often get a blank screen, and system hangs, so I have to reboot with the reset switch once or twice more and then it will bot fine). Something is very wrong! I've scanned for viruses and adware, reinstalled drivers, dunno whats wrong, maybe a format is needed!

Link to comment
Share on other sites

Yeah although the latest drivers from Belkin website are the same ones that came on the CD years ago! I don't the disconnects are fundamentally a problem with uTorrent, because uTorrent has worked fine up until a few weeks ago, but uTorrent is the only program at the moment that triggers this disconnection.

Link to comment
Share on other sites

I'm having a problem with the Belkin wireless router as well. I connect just fine, and it runs great for about 5ish minutes or so then my whole connection dies. All I have to to is reset the router (by connecting to the router and choosing Reset) and it comes right back up. The dead connection affects both my laptop (with utorrent running) and another PC hooked up that doesn't have anything running.

It doesn't happen running anything else, and up until the point the connection dies, I get a full-blown connection with no problems.

Anybody else have input?

Link to comment
Share on other sites

I did some tweaking. Putting the uTorrent computer into the DMZ works for the duration of a single torrent. The next torrent I have to start, then reset the router. Seems just like an odd kind of problem. Might have something to do with the fact that my router, while the firewall is globally disabled, all the firewall setting still indicate its on. Might be some kind of "idiot-proof" protection. Upload rates are still a little slow, but it is DSL, so that might not mean anything.

Link to comment
Share on other sites

yeah sounds like the problem I'm having. What gets me is that although I agree my router is probably crap, it has worked fine for ages, so why is it dropping connection now? Actually due to the fact my computer now pretty much doesn't start if the wifi usb dongle is connected, I think there is some driver/hardware conflict or something similar that I don't really know how to fix :(

Link to comment
Share on other sites

  • 5 months later...

I have this same problem starting about 3 weeks ago... it took me a while to actually investigate, but it turns out I too am getting the Event ID 4201. I noticed the problem when my VNC kept dropping

I have a patched TCP.SYS file, so it's not that getting lucked up (plus that's a 4226 ID i think it is).

I notice with or without DHT it causes the problem, so that's not it.

I have the Speed Guide set to xxx/1MBIT as I have 15/5, but am testing... Still the same problem.

Tried the net.max_half_open trick by setting it to 4.. still no go..

WTF is going on!?

Network info:

Happens wired or wireless.

Attempted on 3 separate routers (Actiontec, Netgear, and Asanti) and it happens on all 3.

Re-installed windows fresh, without TCP.SYS hack it still causes this issue.

Read the thread that DreadWingKnight posted... I'm not on a dual core, but am on an AMD64... plus it sounds like bs to me anyway... windows kernels are images, and do not alter based on the chip set it's running on, so that seems like complete crap to me. I build my own Linux kernel on the same box, and don't have any problems on that running kTorrent.

Also, if that were the case, any other application that works similarly with lots of connections (such as bearshare, etc).

One last note, if you search for anything relating to this problem, it points directly back at uTorrent... never have i found anything indicating AMD nor nVidia having this problem; and I know to not have the problem with any other app or OS on the same PC.

This is clearly a bug in uTorrent, and i think anyone that knows a developer should tell them to stop pawning excuses onto other platforms.

Link to comment
Share on other sites

It almost sounds like what I am going through. When i start utorrent my internet CUTS OFF Until i close UTORRENT. WTF??? I do not get it? Once I close utorrent for about 5 minutes the internet works again. This also happens when I use LIMEWIRE.. But it only started about 3-4 weeks ago. Whats going on help me>

Link to comment
Share on other sites

There were some half-open connection management changes, in order to be more accurate and take into account HTTP seeds/connections.

It should be solid, but if it ever goes over the limit that is set in the settings, PLEASE let us know!

Even then though, with the TCP.SYS hack should bypass the XP limit so it shouldn't be a problem then unless the hack didn't work for some reason.

Other then that, I can't really think of any other changes that could cause this...

For finding out which connections are half-open, check out an article like

http://www.securityfocus.com/infocus/1729

Link to comment
Share on other sites

Ryan,

Thank you for the timely response!

I've actually managed to check my TCP.SYS hack... turns out it WASN'T hacked... i hacked it, but to no avail :(

Also wanted to note, this does NOT happen with any other application, including limewire or bearshare (i hate those apps, but used them for testing purposes).

I set the net.max_half_open to 1 (was too weary to try 0) to no avail :(

Also set max connections to 1, again, to no avail.

I'm really stumped on what the issue is..

Disabled DHT, disabled Local Peer Finding (orwhatever it's called), disabled UPnP, and the other port mapping (forget the name atm, and am at work).

Also as a side note, if i am reading your securityfocus article correctly, the half-open problem results in a self caused DOS. The problem we're having is that the network interface is actually dropping connection completely and re-initializing (full hardware reset) and restarts immediately.

For standard web browsing or torrenting this is tolerable (as long as a webpage isn't loading during a reconnect), but for VNC and other services, it's rather annoying as I lose connection, and can never gain full speed while uTorrent is loaded.

I do notice that if I pause all torrents (note, this still happens with only 1 torrent running), that I get the error very infrequently as opposed to when actively downloading torrents..

If there's any more information I can give, let me know.. I'll be happy to help get this resolved.

Link to comment
Share on other sites

I'm having a similar problem.

My connection seems to die as soon as i download 100mb~

doesn't matter if i use utorrent, azureus or even emule

it only takes longer with emule because it's so slow.

I tried all the possible tcp/ip net.max_halfopen dht and above mentioned setting with no success.

I believe it's worth mentioning this started happening after i got a new motherboard.\

ASUS A8R-MVP. Though i installed everything by the text-book.

Link to comment
Share on other sites

Hi guys,

I have the same problem - in some time uTorrent or eMule disconnect my inet. The difference is that even after quitting uTorrent the internet connection is still unstable. Found out it just recently. I use a standard Motorola router given with Vonage phone number. UPnP is on and I suspect the incorrect work of it might be a problem. I am just thinking of trying to switch it off and forward the ports manually - btw, has anyone done this? Any results?

P.S. Btw, since it happened recently to all, could it be somehow connected to, say, some latest Microsoft updates? :-)

P.P.S. One more thing I noticed - if I run eMule 0.48a and uTorrent simultaniously, inet is cut off, uTorrent stops completely - not seedig, not downloading, eMule seems to be more or less OK. They both use UPnP, but through different ports. The same things if firewall is off.

Link to comment
Share on other sites

ok i believe the (or atleast my) problem isn't hardware based.

I bought a pci 10/100 nic and the problem's still there.

I tried downloading through a laptop (while disconnecting the network cable from the pc and moving it to the laptop). The problem was still present.

But after a firmware upgrade of the router i managed to download 4 GB without a hitch.

Then I happily reconnected the pc but 30 seconds later the speed went down hill and my connection died (although the flashing little pcs near the clock didn't show a network disconnected message) so i had to disable and enable the network connection like always.

*frustration*

edit:

after updating the firmware of my fritzbox 7170 to a beta version the speed still goes down but jumps back up within 5 seconds

atleast i can finish my download now...

the question is, why is the speed going down to a crawl for a few seconds?

Link to comment
Share on other sites

Okay i FIXED IT.. KIND OF.. I downloaded Bitcomet BECAUSE I needed my torrent client and my torrents. And when I opened it it told me something about my HALF OPEN being too low. It was like an automatic alert from the BITCOMET client. It said it would fix it automatically. SO CLICKED OKAY. After that UTORRENT WORKED!!!! No more disconnecting from the internet. UTORRENT IS BETTER, but Bitcomet fixed the settings. Don't know how but it did.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...