Jump to content

DHT return 0 nodes forever (but d/l seems okay but not good)


bennyhill2

Recommended Posts

Hi all,

I have a question. This is my PC:

Windows XP SP2 (with firewall disabled/enabled --> both tried)

bell sympatico ISP (sometimes they will block my port (red icon) but it will changes back to (green) after I changed to another port in the router)

Speedstream 4200 ADSL+Firewall Router (all port configuration are going to there)

Somedays I suddently realized that the DHT returns 0 nodes.

So I changed to another port to see if it works but the answer is no.

I have another pc. (which not always use but it return 280+ nodes in DHT last time)

Turn this on and getting same results.

And I have installed Bitcomet in another pc and no change.

Download seems okay (at this moment this pc d/l in 100k/s)

So I think this is not my pc(s) problem....

Any ideas/clues?

Thanks.

Link to comment
Share on other sites

Thanks Switeck,

But, how come? Everytime it will be okay when I changed the port.

And this time the DHT always returns 0, no matter which port I have changed.

All I have done on the firewall is to forward the UDP and TCP (same port number) to my internal IP.

Any ways to solve this issue?

Do I need to try to use another ADSL router? (Currently they give me is ADSL+Firewall modem)

Or, is it the problem of UDP port? As I know DHT uses UDP.

If so, how can I test the UDP port is working?

Thanks a lot!

Link to comment
Share on other sites

If an ISP sees fit to mistreat its customers to 'improve' profits, (such as blocking ports) it's often interested in increasing profits further in that regard. ...If a cheap way to kill BitTorrent traffic appears, they'll probably use it.

I use cable internet, so my knowledge about ADSL special setups is too limited really to help much futher.

Link to comment
Share on other sites

Hey Folks,

I got the same problem too.

At first, I tought that it will be over in a few hours but as time went by and DHT was still wrong, I started to wonder.

There is another thread (http://forum.utorrent.com/viewtopic.php?id=18482) and at Gulli (http://board.gulli.com/thread/685789-utorrent-dht-problem-/), the DHT-problem is mentioned again.

I don't think there's any firewall messing up and no bad configured router at all.

I realised, that DHT started to struggle after christmas.

You got some idea ?

Greetz

Sunbird

Link to comment
Share on other sites

Problem solved! ;-)

Here's how I did.... see if it helps everybody....

0. Turn the DHT off and shutdown the utorrent.

1. Use SFC /SCANNOW to re-sync all the system files, make sure they are update and correct (They will ask you to insert the XP CDROM)

1a. Reboot PC

2. Reinstall the service pack 2.

2a. Reboot PC and then shutdown when okay.

3. Factory Reset (Not just reset) the ADSL router firewall .... (my ones is a ADSL modem + firewall model)

But there is a problem...... I forgot the ISP logon username and Password !!!!

4. So I called the customer service to reset the password.

It takes more than 12+ hours becuase I can't find the information and their logon server was down. :-(

5. Fire up the PC, and then I reenter all Port forwarding rules in the ADSL Firewall.

6. Turn on the utorrent and turn DHT back on after approx. 15 mins.

7. It's done!!!

See if this information can help any guys....

Good luck!

Link to comment
Share on other sites

@bennyhill2: Are you sure, a reinstall of SP2 is necessary ? o.O

This leads to a new patching of the tcpip.sys to rise the halfopen-limit. :(

For me, the problem isn't solved as long as you have to reinstall SP2 or any other part of your OS....

DHT is not as important as the waste of time for the reinstall...

Greetz

Sunbird

Link to comment
Share on other sites

to:Sunbird

The reason I run sfc.exe and reinstall the sp2 is that my computer was attacked by virus. (Probably I running utorrent and open the port. I have try to turn on my computer without running utorrent and it's fine.)

So I reinstall those stuffs to make sure no corruption file in there.

The reason of resetting the adsl router and account is that I wondering if the router got any problem (eg: overflow stacks in the router, as you know the router keeping running on DAYS or even MONTHS). And, I HOPE the ISP will erase my block rules for my internet connection when they reset my account.

Link to comment
Share on other sites

@bennyhill2: I don't think the router is the problem.

Maybe Microsoft "closed a securityhole" with a automated update and this will deny DHT-function ?

(like half open connection limits...)

@Ultima: Thx for the link. I found it already during search in uTorrent forums but now I will try the method.

More to come soon...

Sunbird

Link to comment
Share on other sites

  • 2 weeks later...

> Problem solved too.

> Everytime I use the DHT-Torrent in the Link above, i got DHT-nodes.

> If the Download is not in my uTorrent, i got no DHT nodes.

> Maybe the next version of uTorrent can be fixed to use this link as a "introduction" to DHT.

Dear Sunbird: Can you explain this in more detail? Cos my problem go back again :(

Link to comment
Share on other sites

Hi all!

@Bennyhill2:

The link with the bootstraps doesn't exist anymore. That's a pitty! :-(

Fortunately, the new version of uTorrent solved my DHT problem. Everything works fine for me, now.

ok, now in detail:

The .torrent-files u got following the link had DHT-nodes.

So you leeched the torrent and got introduced to the dht-network.

@Firon:

Why PG2 is useless?

Can you explain it in detail please?

@Ultima:

You got point!

PG2 blocked router.utorrent.com (what ever this domain is needed for... :-/ ).

Suddenly everything worked fine, but i didn't change anything. *wired*

---

At the moment, i got DHT nodes - and i dind't change anything except updating uTorrent - so thanks for your help, guys.

Greetz

Sunbird

PS:Bennyhill2 good luck - i'll check this thread regulary. Just post! :o)

Link to comment
Share on other sites

i take the "why PG2 useless question"

because those that want to extort money from you can simply use an ordinary home IP address to do all the recording they need. PG2 can NOT protect you from copyrightenforcers.

easy to understand explaination here:

http://neuron2neuron.blogspot.com/2006/05/blocklist-balderdash.html

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...