Jump to content

uTorrent v1.6.1 & WRT54G v5 - UPnP not working like uTorrent v1.6


Recommended Posts

Hi all,

The new update of uTorrent to v1.6.1 seems to have borked my UPnP.

Previously on v1.6 I was able to fire up uTorrent, a random port would be selected and it would map this straight away. I'd often get the green light and DHT working within about 10 seconds.

Now, when I first load uTorrent, it always fails with an ERROR 718 and the only way I can get it to map properly is to go into OPTIONS > PREFERENCES > CONNECTION > 'click' RANDOM PORT a few times > APPLY.

I have to keep doing this until I find a port that works, and there doesn't seem to be a pattern to it. Just keep clicking a random port and applying until it works.

This is weird and annoying. Why would it stop working all of a sudden with v1.6.1?

If it is of any help to anyone I am using the latest Linksys WRT54G v5.0 firmware (version 1.02.0) which has only just been released and is reported to increase torrent performance in the changelog for this firmware release.

I'd rather not manually port forward and all that because it worked fine in the past and there is no reason why it shouldn't work now. In fact it does work, just not straight out of the box as it did previously...so this proves that UPnP is still possible with v1.6.1.

If you need more info then just ask.

Thanks in advance.

Link to comment
Share on other sites

Hey man,

You aren't alone in this problem. I have the same setup except I manually forward my ports and ever since I upgraded to uTorrent 1.6.1 I am getting the connectivity triangle in the lower bar and then becomes a red circle stating I am not connectable. I too have the wrt54g v5(POS). I am going to revert back to 1.6 for now because I have tried many ports and nothing is dependable. Does anyone know why 1.61 would have triggered this issue? Is there a more sensitive connectivity detection?




My Setup:

WRT54G v5(VxWare), Belkin Wireless G PCI, BitDefender Pro Plus 9(setup for uTorrent to get through)

I have all the ports forwarded and even tried using DMZ to send all connections to this pc but no avail, ratios are suffering. Download is slow, and upload is near non-existent. I even get this :

Welcome to the µTorrent Port Checker.

A test will be performed on your computer to check if the specified port is opened.

Checking port 31378 on xx.xx.xxx.xxx... I exed these out.

OK! Port 31378 is open and accepting connections.

You will be able to receive incoming BitTorrent connections.

Link to comment
Share on other sites

Alright, so far I have updated firmware on my devices, reverted back to 1.6, changed ports, disabled uPnP(because my ports are manually forwarded) enabled and disabled DHT, uTorrent port checker still says OK!, I'll be able to receive connections but uTorrent is still red circled saying I'm not connectable. I am at a loss right now. Some help would be much appreciated.

Currently back to 1.6.1

Link to comment
Share on other sites

Glad to hear I'm not alone in this.

Eventually I might just go back to v1.6 until this issue is sorted out. Any ideas where it is located? The download on uTorrent website only has latest version and doesn't seem to have any older versions.

There has to be a solution though....I'll keep banging at it to see what works and what doesn't.


Link to comment
Share on other sites

Seems a bit lame, I didn't really ask for your SUPPORT FOR AN OLD VERSION, it was a question about support on a new version and if there are inconsistencies in the new product, what's the harm in reverting back to the old uTorrent which is almost identicial. It's not like 1.6.1 is a new GUI that requires a whole new set of instructions so I don't think it would cause you that much of an inconvenience.


Link to comment
Share on other sites

I am going to get back on track here, I did reinstall a 1.6.1 and as I said in my deleted previous post, after I changed the static IP on my tcp protocol, swapped out forwarded ports on the router, I achieved a green circle saying I was connectable. I do notice something different now, if uTorrent is idle as it frequently is for me, I still get the caution triangle which says I may not be connectable. But if I download a linux distro it goes back to green for the duration of the download and then goes back to the caution triangle. What exactly is the uPnP update that took place? Did it make the port detection more sensitive?

And tedrogers, again, you can run a DHCP server on your router and make other computers that you need to port forward static ip addresses, let me know if you need help.

Link to comment
Share on other sites

My setup is really quite simple. I have the router assigning IP's by DHCP to my main desktop PC running XP and my laptop running Ubuntu - where I actually spend most of my time these days ;) cos it's better than XP!

My IP is not static, my ISP will refresh this as it pleases them...but certainly the IP of my machines are static.

The thing I really liked about v1.6 is that for the first time ever I found a torrent application that worked with UPnP out of the box. My router was happy, utorrent was happy and so was I. Now it's just a big pain in the butt refreshing the random port and clicking apply until I find one that works.

I must admit that previously in 1.6 there was a certain amount of delay (a few seconds or so) between trying to assign a port by UPnP and achieving it successfully.

Now in v1.6.1 it seems a lot more aggressive in trying to get that port opened with UPnP...so much so that the router simply rejects the attempt.

Could it be that the attempt at UPnP port opening has been accelerated too much and that the router (wrt54g v5) just can't deal with it?

BTW, the first thing I tried was removing uTorrent from the Windows Firewall and letting it re-add itself...this made no difference for me.

Feel like I'm grabbing at straws here but that's all I can do.

To commend the new release though it does seem much faster when I'm downloading large linux ISO's and I get more consistent speed over the duration of the download and it is quicker to get up to speed. However, this might also be related to the new 1.02 firmware for the wrt54g which is supposed to have better handling of torrents.

Any more ideas? Is this definitely a known issue and will it be fixed please. I love uTorrent and would loathe to go back to Azureus...but I would cos with some tweaking this works well with UPnP and my setup.


Link to comment
Share on other sites

@okayplayer: The behavior you described regarding the network status light is absolutely normal, and is how every version of µTorrent has behaved since the network status lights were first introduced. If you're not transferring anything, how is µTorrent supposed to detect the state of incoming connectability if there are no incoming connections to be gauging in the first place?

Regarding UPnP, I'm not sure myself, as I'm unaware of what exactly was changed/fixed.

Link to comment
Share on other sites

It works just fine if I manually port forward...as it does under wine in Ubuntu or with the plethora of other clients I have used, such as qbittorrent, azureus, ABC etc

But the point is I can't be bothered to do this because I don't like leaving ports open / leaving certain security features disabled and I have to remember to go back into my router and enable / disable the relevant features all the time.

If UPnP worked fine under v1.6 of uTorrent in XP and under wine in Ubuntu, and other Linux clients like ktorrent open the ports via UPnP with no problems...then why is uTorrent v1.6.1 acting up so much in this respect?


Link to comment
Share on other sites


Well, after much testing and playing about I have found out what the problem was for me specifically with uTorrent 1.6.1 and WRT54G router....it was the firmware on the router.

The new Linksys WRT54G 1.02 firmware (from the US site) does not work with uTorrent 1.6.1 and UPnP.

As soon as I reverted back to the official latest firmware release for my region, which is 1.00.6, all my UPnP problems vanished and I am able to use uTorrent with Random Port selected. It is very quick to open up the relevant port and I get the green light in uTorrent almost immediately.

All I can say for anyone else experiencing this problem, try going for the firmware that is in your region by changing the language settings on the Linksys website. It actually warns you at the top of the page on the US download section that the downloads are for US routers only....maybe I should have paid more attention to this as it seems to make a bit impact for me at least.

Hope this helps some of you other people.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...