Jump to content

why cant utorrent setting folder/file permissions??


Recommended Posts

some of the recent updates for SP2 has file indexing for fast search, and also windows media player is changing the file as u play it...

so when u play a file, its changed and so when u try to rehash it, it's different to the one downloaded or reported as different and the client redownloads

SO whats needed is that utorrent DO a rehash on ALL files AFTER DOWNLOAD and then set them to be READ ONLY !!!

Link to comment
Share on other sites

"1.4 I get "Error: Access Denied" / "Error: The process cannot access the file because it is being used by another process" and µTorrent halts the torrent! (Google/MSN Desktop, possibly some anti-virus software, Explorer's thumbnail view, may not be any of the above)

Error: Access Denied can be caused by numerous things. The most common cause seems to be Google and MSN Desktop. A possible fix is turn off the indexing feature, or to uninstall them. Excluding the download folders from indexing should work.

Another fix is to turn off diskio.flush_files, but you will lose the benefit of flush files (diskio.flush_files makes µTorrent close file handles every minute. This helps reduce the effect of Windows managing the system cache badly). Since flush files closes the handle every minute, Google/MSN Desktop try to open the file every minute, and this prevents µTorrent from writing.

The best solution is to simply uninstall Google/MSN Desktop, though.

One of the simplest causes of this is that you inadvertently have two copies of µTorrent running and using the same torrents. Open the Task Manager (CTRL SHIFT ESC or right click on the system clock -> Task Manager), and see if there's more than one utorrent.exe in the Processes tab. If this is the case, close both of them and start up µTorrent again.

It is possible that an anti-virus' real-time scanner may cause this, but there is no known AV that causes this error. If it does, the same fixes for Google/MSN Desktop apply (exclude the folder(s), uninstall the AV/disable the real-time scanner, or turn off flush files).

AVG7 may cause this, it seems to think that some files are a JPEG exploit (a false positive), and it attempts to quarantine them.

A third possibility is that you are viewing the folder while it's downloading, and Explorer is set to thumbnail mode. If this is the case, Explorer would try to access these files while viewing the folder in Thumbnail mode, and lock out µTorrent from writing. The solution is to not view the folder until the download is finished, don't use Thumbnail mode, or turn off flush files.

It's also possible that Explorer is trying to read the media files (MP3, AVI and so on) in the folder to make thumbnails, show you information about them, or preview them. You can unregister the media indexer (Start -> Run -> regsvr32 /u shmedia.dll ), and/or unregister the image indexer (Start -> Run -> regsvr32 /u shimgvw.dll ) as an alternative for either case, not view the folder, or turn off flush files.

A fourth possibility is that you set the files to read-only, which would prevent µTorrent from writing. This only affects downloading; µTorrent can seed files that are set to read-only. However, if the error appears when trying to seed, it may mean that the original files are damaged and are failing the hash check."

if you read your FAQ then you should know it s a problem !!!

How do i reverse these

(Start -> Run -> regsvr32 /u shmedia.dll )

(Start -> Run -> regsvr32 /u shimgvw.dll )

I dont know if you program the client, but you should try to help users rather then make opinions of a problem that you are not lucky enough to experience.

BTW that problem has a sympton, my problem doesnt show any symptom, utorrent just doesnt save the file.

Link to comment
Share on other sites

  • 1 month later...

I too am in the same situation.

Can anyone help??

I really need to undo this because now NONE of my images will open :-(

Please Help


Great forum Too :+)


Edit: Fixed it.

Ok, here's what to do

regsvr32 basicly selects and deselects with .dll s Windows can use. regsvr32 /u (file) tells it not to use a DLL.

To revese theme commands, (as admin) go to start > run and type "cmd" then type the following.

regsvr32 shmedia.dll

Press enter.

regsvr32 shimgvw.dll

Press enter and you're done!

Link to comment
Share on other sites

  • 3 weeks later...

I too have recently been receiving this error message. I tried disabling Google Desktop's indexing service. That did not work. I don't use Winzip's QuickFind. There was only one instance of utorrent.exe running. I was not viewing the download folder's contents (in fact no Explorer windows were open), and my files were not set to read-only.

It wasn't until I turned off diskio.flush_files, that utorrent stopped presenting this error.

Something noteworthy though... I believe this error only presented itself when I was downloading to my internal hard drive. I don't think it ever occurred when I was downloading to one of my external drives.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...