Jump to content

Wacky download speeds


Recommended Posts

Hi all,

Hello, I am a new user to uTorrent and am having some odd d/l speeds. I was hoping someone could help me on this.

Here are two examples.

1. Trying to download a torrent that has 900 seeds and 7000 peers. Availability is at 21.999. uTorrent will start d/l and my d/l speed will go from 20kB/s to 50kB/s with occasional spikes of a minute or two to 400kB/s. Then it will drop down to 20kB/s to 50kB/s. My upload speed remains at a rock steady 44kB/s. Thinking that was odd, I stopped the d/l on uTorrent, and I tried d/l using another client, BitComet, and got a rock steady 350ish kB/s.

2. So, I decided to check using the recommended Open Office torrent. It shows as 21 seeds and 6 peers. Availability is at 11.979. uTorrent again will go from 20kB/s to 50kB/s with an occaional spike of a minute or two to 300kB/s. Then it will drop back down to 20kB/s. Again tried using BitComet got a rock steady 300ish. Weird no? Anyhow....

My setup.

Windows XP with SP2 on an AMD 64 3400 with 2 gigs of ram. The TCP/IP half open patch has been run. No firewall either on the router nor using Windows firewall. COX cable service with 7616Kb/s down and 477Kb/s (as per dsl reports). Buffalo router running dd-wrt.v23 SP2 instead of factory firmware.

Static IP set to 192.168.1.xxx with the port 66xxx assigned by uTorrent opened in the router.

Running uTorrent 1.6.1.

Randomize port each time uTorrent starts: unchecked

Enable UPnP port mapping: unchecked

Add uTorrent to Windows Firewall: unchecked

Global Maximum upload Rate: 44

Global Maximum Download Rate: 0

Global Maximum number of connections: 250

Maximum number of connected peers per torrent: 90

Number of upload slots per torrent: 4

Use additional upload slots if upload speed <90%: unchecked

Enable DHT Network: unchecked

Enable DHT for new torrents: unchecked

Protocol Encryption: Enabled with allow incoming legacy connections checked

Max number of active torrents: 3

Max number of active downloads: 2

net.max_halfopen: tried 4~40....no change

peer.laby_bitfield: tried both true and false...no change.

BTW, the green checkmark on the status bar is up.

Does anyone have any suggestions? I would keep on using BitComet, but have been noticing I have been getting blocked from some tracker sites. So, I would really like to get uTorrent running just right. Thanks in advance.



Link to comment
Share on other sites

There doesn't seem to be anything wrong with your settings, although setting your net.max_halfopen over 8 will cause problems if you haven't patched Win XP to handle that.

I think I read that Cox ISP has interfered with BitTorrent traffic in the past, so they may be doing more now.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...