Jump to content

Weird problem when I'm downloading large files


Recommended Posts


I've a strange problem when I try to download large files (200mb+). I open the torrent and start the download, everything works fine until I connect to other peers and seeds. Then, my computer becomes really slow, and I can't do anything with it. Even the mouse-cursor "lags". After about 3-5 minutes (depends on the torrent's file size) the computer is fine again, and it runs smooth. The torrent starts and It downloads at full speed (400Kb/s) It seems that the files need to be "loaded" to the HDD or something.

I haven't changed the disk cache settings yet, because I don't know if that's causing the problem.

My system is:

Windows XP SP2

P3 500Mhz

256Mb RAM

System drive (Windows etc.): 13Gb P-ATA NoName HDD

File drive: Samsung Spinpoint 80Gb (8Mb cache, 7200RPM)

Link to comment
Share on other sites

Hi, I have the same problem. I wonder if you guys could help me out.

In my devicemanager it looks like this:


I have 2 IDE Harddrives that's connected to the same IDE cable. So I guess the marked driver on the picture is the one I use for them. The one with windows on it is Master and the other one is set to Slave.

I tried to delete that driver as someone wrote above in this post. Although it didn't affect anything, still the same problem.

I've also got a extern harddrive that is connected through USB, but I don't think that one is causing my pc "lag".

I'll appreciate any help, I can't do anything while downloading atm. It's very annoying.

Edit2: I forgot to say that I'm using Windows Vista.

Edit: Btw, I used bildr.no just because it was fast. I'm not norwegian, so please don't answer in norwegian :)


I just tried downloading a file, (big dvd), lan through dc++ in 10mbit lan-speed constantly. This didn't affect my pc's perfomance at all, so I guess there's nothing wrong with how my harddrives are setup after all... I could even play games at normal fps.

I think the problem lies somewhere in uTorrent. I will try to switch to another bittorrent client soon and see if I still have this problem. I'll report back if it solves this problem.

Or the problem might be that uTorrent doesn't really support windows vista yet.

Link to comment
Share on other sites

I'm not sure, is that a problem? =)

I didn't think it was IDE channels.. I thought I only had one IDE channel, the marked one on the picture.

Practically I only have one IDE channel, but I've got 2HDD's on it.

My DVD-reader is on SATA.

So I have no idea why it's like that, as I said I thought it was something else.

Link to comment
Share on other sites


Did you install the proper chipset drivers for the motherboard?

Also, what is the rest of that Device Manager entry (hidden by the other window) whcih starts with Andre enheter... with Nettverksk right below it.

That's definitely missing a driver by the looks of it.


Remove the bottom two references to ATA Channel 1 and ATA Channel 0 in Device Manager by right clicked on the entry and selecting Delete.

Make sure that you are not running any apps of any sort.

Reboot your system.

Link to comment
Share on other sites

The network device under "andre enheter" was just an old 56k modem I hadn't installed the drivers for, so I uninstalled it. My computer is a Compaq Presairo 5726 and it's very old (7 years or something), I know I should update the drivers and BIOS, but I can't find them anywhere..

Link to comment
Share on other sites


I changed from my onboard network to a pci network card and there's still some problems for me but it seems like it's better. So if you have more than one network card, try the other one.

Although, I think my problem is more Vista related even if we have the same kinda "symptoms".

Link to comment
Share on other sites

  • 4 months later...

When try to download large torrents > 1Gb it never loads all the parts completly and I sometimes get the red cross after several hours.

I'm left with some incomplete files (ie if I'm downloading the complete series of a TV show I get some episodes which state they are incomplete files).

Does u torrent have a limitation on size of file that can be downloaded?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...