Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 1.7 beta 2951

Recommended Posts

They look around the forums fairly often, so I'm sure they've already noticed the Todo subforum :P

By the way, 1355 is awesome ;D

Share this post


Link to post
Share on other sites

I would test RSS, but I don't actually use it, so I can't really say much about that aspect of µTorrent :\

You're (basically) our resident RSS-polisher, though, so do test 1355 and provide more feedback :P

Share this post


Link to post
Share on other sites
You're (basically) our resident RSS-polisher, though, so do test 1355 and provide more feedback

sure ... :)

edit: RSS problems...

1. bad RSS behaviour... downloaded two of the same LOST 17 appisodes (two different feeds, smart ep filter is on...)

2. also: [07:53:02] Unable to load "<NULL>": Torrent is already loaded! - logged in the logTAB. No file/torrent name...

Share this post


Link to post
Share on other sites
- Feature: Handle different half-open limits on Vista flavors

How does it handle it? net.max_halfopen is still 8, is that what it should be for Vista Ultimate? I still can't find a definite answer whether the limit is 10 or 25.

Share this post


Link to post
Share on other sites

I was thinking about if the new way to select files to download could also be implemented in the files, where you are able to set priority when the torrent is started. I love this new system, it's much more manageable. I look forward to see the new beta when i'm home from school.

Share this post


Link to post
Share on other sites

For some reason upnp is not working perfectly for me. I am still getting great speeds, and other computers connected to my network are getting the green check-mark, but I am not getting the check-mark I am getting the the red "!".

BTW any word on if you guys are gonna implement SET (Similarity Enhanced Transfer) in the future. I would like to see it.

Share this post


Link to post
Share on other sites

@ Yochanan

The main issue is that the halfopen limit on Vista Home Basic flavors is < 8; we've handled that case.

@ rafi

Thanks for finding the issues so quick. When you got 2 episodes of Lost, were the episodes both found during the same feed update?

@ matthaeus123

Did UPnP work for you on previous builds of 1.7 beta?

Share this post


Link to post
Share on other sites

yes, the same feedS update . I have ~6 feeds being scanned. I got them from 2 different feeds...

Possible reason -

The smart ep filter is not being updated with the first download ("thought" it was a bad one). May be it had to do with the bad message in the log as well. Both things happened the same time...

Also, be aware that there is one "legal" reject for torrents not being auto-downloaded - in case they ARE already downloading. In this case - if you do a manual DL from the releases TAB - it asks you if you like to add the tracker. Now, you should take care NOT to count it as an error, but "natural" behaviour... if you do and delete it from the smart EP filter list , double downloads may accrue for the next feed....

Personally, I would add an option if to auto-add the tracker or not... in both cases - this is no error, but can be logged as info message...

Share this post


Link to post
Share on other sites

FR: In Add Torrent Dialog, show the total size of the contents in a folder, like you do for individual files. Not standard Windows behaviour I know, but it would be useful.

Bug: Scroll bar on general tab. I have it set so that my general tab is tall enough to see first line of comments. If i highlight a torrent that doesnt have a comment then the scrollbar doesnt show, then i switch to a torrent that has a multi line comment, then the scrollbar still wont show, even though it should. If I try to make the general tab taller, then i can see the scrollbar drawing/undrawing itself, the only way to get the scrollbar to show is to make the general tab shorter.

FR: In the Create New Torrent dialog, in the Other section, have a check box for the "Initial Seeding" option that is linked to the "Start Seeding" check box. If Start Seeding is unticked then Initial Seeding is greyed out, etc, vice versa.

Apart from that. I'm loving the work you guys are doing...

Share this post


Link to post
Share on other sites

To answer your question (was AFK), yes, the description of the scrollbar bug is (IMHO) clear :P I've seen it too, but neglected to mention it :\

Share this post


Link to post
Share on other sites

I was just wondering if uTorrent or the official BitTorrent client is going to implement SET (Similarity Enhanced Transfer) to the protocol in the future? I've read a lot into it and it does seem like it would be beneficial to the bittorrent network.

Share this post


Link to post
Share on other sites
How does it handle it? net.max_halfopen is still 8, is that what it should be for Vista Ultimate? I still can't find a definite answer whether the limit is 10 or 25.

Home Basic: 5

Home Premium: 25

Business: 25+

Enterprise: 25+

Ultimate: 25+

Share this post


Link to post
Share on other sites

Eh? Where'd you get those numbers from? Last I heard, the numbers for a bunch of the Vista editions were much lower than that, and µTorrent 1.6's behavior on Vista (even with net.max_halfopen set to default) confirms that it was definitely lower than 25...

Share this post


Link to post
Share on other sites

Additional RSS problem :

3. in "released" tab - downloads that are being rejected (due to errors/same-file etc) seem to be marked/checked with the "downloaded" blue sign...

Share this post


Link to post
Share on other sites

Any way to adjust how aggressive the automatic upload rate is?

If I turn it on, even after giving it an hour to settle in, its uploading at 90% of my max speed (768kB up (or 96kB) theoretical, and uTorrent is setting itself to 85kB or higher), which results in horrible performance for everything else, and drags my DL speeds down quite a bit as well.

I like the idea of it ramping up when my connection isn't being used by other apps/computers, but its trying a little too hard.

Share this post


Link to post
Share on other sites

1137 seems to have fixed the UPnP problems I was having with the previous 2 betas, but it still seems to not use a true "random" port at startup (see my post #229). The manual randomize button does give various ports, but startup ports always seem to be low (2000-4000) "generic use" numbers.

Can anyone confirm that they ever get high range random ports (up near 40000-65000) at startup??

Also, uTorrent doesn't "unmap" the UPnP port when closed ... my modem shows it still open.

Trevor

Share this post


Link to post
Share on other sites

@Yat

@laimanl

@cyRq

Thanks for reporting these - the incorrect peers list display of uTorrent versions 1.5.1-1.6.1beta and on non-english/japanese locales should be fixed for the next beta release.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.