Jump to content

µTorrent 1.7 beta 2951


Firon

Recommended Posts

  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Running on XP Pro with Netgear DG834GT ADSL2+ modem (Kerio firewall off while testing)...

1.6.1.490 - never a hiccup; everything as per the book

1.7 build 1111 - auto-randomize startup port fine; display issues on General tab & Move Up button; port not unmapped on exit

1.7 build 1137 - always had zero port number at startup; never auto-mapped a startup port; manual randomize would kick in fine (including unmapping old port); port not unmapped on exit; display issue on Move Up button

NOTE: even though it showed zero as startup port, uTorrent was "listening" on what appears to be the first "generic" port number it uses. All further connections begin numbering sequentially from this.

1.7 build 1170 - startup port now shows non-zero (but never gets mapped - even after a 10 hour period); startup port isn't "random"...always seems to be a low-thousands generic port as above; manual randomize ok (including unmapping any previous port); port not unmapped on exit

Trev

Link to comment
Share on other sites

i found a BIG bug, when i executed the "utorrent-1.7-beta-1170.exe", the exe is auto deleted itself for no reason and no message and no error (program is still running fine).

i tried to download the latest beta again and again, also keep deleting itself.

then i used back v1.6 and try 1.7 beta again, the problem is gone, what's wrong????

Link to comment
Share on other sites

Hi!

One usefull thing to the build 1170: when you are moving a torrent in the list with CTRL+ALT+UP/DOWN, you doesn't see the moving list. It's usefull when you have 50 torrents in the list.

I have NO problems with build 1065,1137,1170!

THX!!!

Link to comment
Share on other sites

Switeck,

thanks! I have now changed to have global max as 100, and 15 max per torrent, and half full value changed from 8 to 4, so lets see if that makes a differance.

Is it possible to edit the torrent file, removing the udp announce and possibly a few other or will that makes it invalid in some way?

I also have tried to change the net.outgoing_port and net.outgoing_max_port, to set an outgoing range (dev CodeRed gave this tip in other threed) but it seem like only the port set for net.outgoing_port is used for new connection, not anything in the range.

Link to comment
Share on other sites

I'm getting major memory leaks in the standard beta here. Using the PECompact compressed normal ver, build 1137 shot up to as much as 450 mbytes when minimized (after a half day of running it). Build 1170 had same problem, nuked it after it reached 100megs.

I've switched to the UPX version, will report back later.

Link to comment
Share on other sites

after installing the 1.7 beta build 1170 i noticed that after running uT for a few hours, firefox stops working. I cant access any web pages and get a timeout error. The only way to fix this is to restart my computer. I can still get a connection when torrenting or on irc channels or IMing. I only have the problem in browsers. I tried Firefox, IE, Opera, and maxthon. I get the same error in all these browsers. I never had the problem with 1.6.1. This only occurs when running uT

BTW-I am running Windows vista Ultimate

Link to comment
Share on other sites

You need to set net.max_halfopen to 8 or lower on Vista.

I think 8 might be a high value in many cases, on my XP Pro SP2, P4 3 HT and 2G RAM, a value of 8 results in uT just keep on open connections making Firefox unusable after a while. If just seeding it takes longer but if d/l it goes rather quickly. I decreased it to 4 and since have no problems.

Another thing I noticed as well was that uT didn't seem to honer my global Max connections value, although I set it to 250 it just kept on open connections until computer finally crashed. After lowering half_open to 4 and global max to 100 all now is well, but there seem to be a hell of activity with incoming connection replacing each other.

Link to comment
Share on other sites

XP SP2, Server 2003 and Vista (besides Home Basic) are capable of 10 half open connections. 2000, XP and XP SP1 are capable of something like 65,535 half open connections (anyway, a really high number, at least what I wrote). The thing is that it should be higher than that, at least 32 or 64.

Link to comment
Share on other sites

yettyn,

Yes, you should be able to edit the torrent file and remove the udp announce and any other 'dead' tracker announces as well.

If you're not running more than 5 torrents at once, you may want to increase the connections per torrent from 15 to 20+.

Link to comment
Share on other sites

I have just come across a small problem with the automatic upload

speed in utorrent 1.7 1170 the problem is thet i if the automatic upload

reduced the upload speed below 6K it reduces the download speed

and since my upload speed is only 16K thet is a problem so if you can please

fix the problem thet either the automatic upload speed want go down below

6K or thet it wan't limit the download speed because as long as this problem

might occure i can't use it safely without worrying thet the problem would

happen again.

thanks in advance.

"Uplink limit auto adjusted to 5.40 kB/s"

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...