Jump to content

µTorrent 1.7 beta 2951


Firon

Recommended Posts

  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Firon, thanks. I just tested this with a batch file opening several instances of telnet and you are right about this. Upon opening the X+1 incomplete connection attempt, the SYN is delayed until one of the first X attempts is answered, closed, or times out.

This is much worse than I presumed. Furthermore, Microsoft has removed all mention of the actual limits from their website. This generic text (from an SP2 rollout doc file) is pretty much all that remains, and it's probably what I read when I misunderstood:

Limited number of simultaneous incomplete outbound TCP connection attempts

Detailed description

The TCP/IP stack now limits the number of simultaneous incomplete outbound TCP connection attempts. After the limit has been reached, subsequent connection attempts are put in a queue and will be resolved at a fixed rate. Under normal operation, when applications are connecting to available hosts at valid IP addresses, no connection rate-limiting will occur. When it does occur, a new event, with ID 4226, appears in the system's event log.

Why is this change important? What threats does it help mitigate?

This change helps to limit the speed at which malicious programs, such as viruses and worms, spread to uninfected computers. Malicious programs often attempt to reach uninfected computers by opening simultaneous connections to random IP addresses. Most of these random addresses result in a failed connection, so a burst of such activity on a computer is a signal that it may have been infected by a malicious program.

What works differently?

This change may cause certain security tools, such as port scanners, to run more slowly.

How do I resolve these issues?

Stop the application that is responsible for the failing connection attempts.

Link to comment
Share on other sites

@kurahashi

How do you reproduce " launching two instances of utorrent when in autostart (or rather in run registry)." - I've tried a few different locales and it seems to perform correctly.

EDIT: Ok, I think I can guess what is happening here. First, a little background - one of the only parts of uTorrent that is not unicode complaint is registry key manipulation.

In the past uTorrent use to write the run entry with a value name of its product name with the micro sign, which is not portable across locales - so if you went from english to japanese you would have two run entries.

To combat this, later 1.7 betas write the run entry value name with product name "uTorrent" instead of the one with the micro sign so that it ports across locales since registry manipulation is not unicode compliant.

So, anyone having this problem will need to remove all uTorrent entries manually in the "HKEY_CURRENT_USER\\Software\\Microsoft\\Windows\\CurrentVersion\\Run" registry key, and then set uTorrent to run at startup again. Now, uTorrent should only launch on startup once.

Link to comment
Share on other sites

in Build 1170 there is still (or a new?) problem with UPnP. Random Port at every start and UPnP are enabled but when you start µTorrent the port changes but UPnP doesn't do anything. When i disable UPnP, close the prefernces, and enable UPnP again, everything works fine. I'm running Windows XP SP2 right now and this evening i could try out on a Vista (32Bit) Machine

Link to comment
Share on other sites

bt.limit_local_peers doedn't work.

I have 2 PCs in the same subnet:

PC1:

172.16.5.1

externalIP.1

bt.limit_local_peers false

Upload limit 200

PC2:

172.16.5.2

externalIP.2

bt.limit_local_peers false

Upload limit 200

externalIP.1 and externalIP.2 are cross blocked by IPfilers. External peers and a local peer are share the same upload bandwidth (200). I see it on Send/Recieve ghaph.

I can set false|false, true|true, false|true, true|false in bt.limit_local_peers, the same result.

And I must to add local peer manually (Local Peer Discovery doesn't work too?)

GarryTom

Link to comment
Share on other sites

dAbReAkA,

I can see all of local peers, traffic correctly counted, there are no problem, but limits cut my local traffic. If I set limit to 0, I see 10-12 MB/s in local net.

By the way, what is "local net" in utorrent terms? I have 3 network connections: 172.* for Wi-Fi, 10.* for my ISP local net and ExternalIP. 172.*? 10.*? Both?

Link to comment
Share on other sites

Yeah.. But you don't know about that the first time. Usually you presume that you can choose installation directory when you hit install.

It would be better if the dialog said:

"Do you want to install µTorrent ? (Copy the executable to %program files%\utorrent)

(Y/N)

Link to comment
Share on other sites

Tbh it happened to me too. I pressed Yes. And it moved to program files whilst I didn't really want it to. But it took less effort to fix it then it would have taken to complain about it here :) Besides. I'm a pro (at least I have the arrogance to think that) and instantly knew what had happened and how to fix it.

For a new user this is actually a nice feature, we've had numerous post about what to do with the utorrent.exe after you download it.

Link to comment
Share on other sites

@Ryan Norton

Thanks for the help with the registry mess. I'm ashamed I didn't check it by myself, my only defense is the fact the same thing happened with some earlier beta, but it was gone with the next release so I thought it would be the same this time... ehm, nevermind.

Nevertheless, the second problem (incorrect µ symbol in the utorrent's name in peers tab) remains.

I'm using windows 2000 pro, with japanese fonts installed and set as default in my regional settings. And yes, if I set english localization as default, everything is fine. Unfortunately this is not an option for me.

Well, it's not a big deal after all, because it does not affect functionality of the software, but still it would be nice to see some µTorrent peers instead of an "oTorrent" ones (オTorrent) :) ...especially remembering the 1.6 was working perfectly fine in this matter.

Link to comment
Share on other sites

Pros (like us... ) usually do not appreciate it,but a standard installer can make the difference (in convenience) for beginners. Maybe uT should have one too...

BTW - here is another problem with V 1.7 BETA - an RSS problem. There was a new "feature" added in 1.7 - logging RSS errors into the log tab (not the history). Now, here is the problem :

1 - RSS scans a feed

2 - RSS finds a suitable torrent (per the defined filter) and tries to open/download it

3 - RSS - has an error opening the torrent, and logs it to the log (new feature)

4- BUT - the RSS does mark it as "downloaded" and puts it in it's history as well as in the DLed episode list

5 - that's it, if the smart episode filter is ON you miss this episode forever ... :(

It should be fixed so that:

* the RSS downloader continues to try to DL this torrent from alternate feed(s) if available

* if not successful - do not mark it as downloaded, and do not put it in any history. Retry during the next scan.

I hope the new devs will find the time to attend to it !

Link to comment
Share on other sites

Using Version 1.7 (build 1170) seems theres a problem with force re-check.

Sometimes the torrents with missing pieces are removed from utorrent and need manual readding for the last pieces to be downloaded. The once that completes re-check with no pieces missing stay proper.

I did search but couldnt find any report of this, sorry if its been mentioned.

Link to comment
Share on other sites

@kurahashi

The incorrect display of the u in the peers tab is fixed for the next beta.

@[installation] - uTorrent has a fairly intelligent installer - if you move it to where it is associated, for instance, it will not ask to install. However, if there are no indications of where to install it will choose program files. We are still working on making it smarter though and comments about the functionality of the installation as well as its overall usefulness are welcome.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...