Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 1.7 beta 2951

Recommended Posts

@ wyrmchild: regarding the crash on HTTP 302 response, we have identified and fixed a problem in the HTTP code that caused a crash. It will be in the next release.

Share this post


Link to post
Share on other sites

i don't understand... i can not create a .torrent file larger than 1 gB, my entire ram gets occupied and i can not even move my mouse smoothly. if i make a 4 gB torrent... 2.5 gB ram is occupied... and the same story.

Share this post


Link to post
Share on other sites

Hi,

I'm using the latest beta on my laptop, random port as well as UPnP port mapping is enabled and works fine.

If I put the computer to sleep though and wake it up later, there are no incoming connections. The reason:

While the laptop was in suspend, the router unmapped the port (some timeout mechanism, I guess).

µtorrent on the other only seems to remember internally, that it has already mapped a port earlier. It doesn't "ask" the router about it.

So, I get the normal message in the logger: "[01:34:18] UPnP: Port xxxxx is already mapped. Not re-mapping." every 20 minutes or so, but the port's not really mapped.

Share this post


Link to post
Share on other sites

It actually asks the router every 20 minutes to remap the port. It doesn't "remember" that it mapped it.

Share this post


Link to post
Share on other sites

Hi all,

I did not have internet connection on my laptop for over a week. Was getting Limited Connectivity and Access: Local Only errors. Had to reinstall Vista Ultimate. All works fine now. I have one question though. I am a regular member at Demonoid, a private tracker. It updates your ratio everyday. Ever since I got the new beta for UTorrent, it hasnt updated at all. When I went to the FAQ page in Demonoid, it says beta versions may have problems with the ratio updating. Is this right?

Thanks.

Share this post


Link to post
Share on other sites

DreadWingKnight, the piece size is set on Auto Detect. I just don't understand. I have a very very powerfull sistem and i just can not create a torrent.

Share this post


Link to post
Share on other sites

>>- Change: Prioritize seed queue based off seed/peer ratio (use_seed_peer_ratio)

- Change: Sort advanced settings by name<<

Thanks for fixing some of the problems from before like when completing a download it only moves the files from that torrent only and not the entire directory...

Now where do I find these settings?

A problem here is some Queued torrents waiting to seed end up in the middle of completed torrents. This problem was not there is very older uTorrent but only became a problem like after v1.5 or something, not exactly sure. Most of the queued torrents waiting to seed will be in between those uncompleted or waiting to download and finished, but some for some reason end up the middle of the finished. Doing a Force start will move this UP to the other queued or seeding torrents. It also does not seem to sort by name. Well it does for most but not all files in the Que. I am using the # to sort the torrents. Maybe the finished torrents should also have a number? its blank now.

dang forum rejected my other message which had to do with uTorrent creating incompatible torrent files. Bit comet, bit spirit and Azureus creates identical checksummed files but uTorrent for some reason makes it different on a few torrents. Pirate bay will reject these are broken torrent files but other sites accept them and they do work.

Share this post


Link to post
Share on other sites

B 1825:

- Change: RSS filter by episode with just starting point

does not work, "lost* + 2X21 - does not retrieve the current 3X21. it should download any episode after 2X21 including later seasons.

Share this post


Link to post
Share on other sites

Will be the local peer discovery fixed ?

Coz now ut can only discover the local peer but can't work with him correctly...

My computer is sending to the other local computer about ~4mb (with ~100 kb/s) and the wait some time and then send another ~4mb....

In 1.6.1 I was sending to the other local computer with max local network speed (2-3 mb/s) and there wasn't any pauses in transfer but I need to limit my up speed ;/

Share this post


Link to post
Share on other sites

@ rafi - I could not duplicate... are you sure the episode in question was not already in your history? It will not attempt to re-download entries already present in the RSS history (or if the smart ep filter has already matched that episode)

Share this post


Link to post
Share on other sites

rogal... local peer discovery is still getting things worked out in it...

trust me, they're working on it. :) it wouldn't suprise me if I got an /ignore or two over the past week about it too. >:)

-- Smoovious

Share this post


Link to post
Share on other sites

1.7.1825, few min running and get the msg:

---------------------------

D:1.7k U:18.1k - µTorrent 1.7 BETA: utorrent.exe - Erro de aplicativo

---------------------------

A instrução no "0x773c1dcc" fez referência à memória no "0x000fdf90". A memória não pôde ser "read".

Clique em 'OK' para encerrar o programa

---------------------------

OK

---------------------------

running again to see if any issue appears

Share this post


Link to post
Share on other sites

working still since last crash. its GOOD :Ð

the inscruction 0x773c1dcc did a memory reference at 0x000fdf90. So memory cant be "read".

os: xp-sp2, 1.5G ram..

Share this post


Link to post
Share on other sites

I noticed this in the release notes for v1.7 beta 1825:

- Change: more even distribution of random listening port on startup

So far, however, this beta has not auto-generated a port number higher than 3 digits (it usually sticks to the low 100s range) and even chooses ports in the double-digit(!) range on startup. Is this the intended behavior of the change? I wonder if this could be problematic if it generates a port number that's used by other software such as NewsLeecher which depends on ports such as 119, 443 or 563 for NNTP access. Interestingly enough, if the random port button in the connections option page is clicked, the port numbers there are much higher.

On another matter, is it just me or is the automatic upload limiting not working in this latest beta? The status log makes no mention of it even when it's enabled in the options.

Share this post


Link to post
Share on other sites
@rafi: Have you tried 2X21- (notice the hyphen)?

no just 2X21... I will try...

edit: looking good with this "-" ...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.