Jump to content

Can only upload while downloading


Recommended Posts

I have some difficulty with uploading using Utorrent.

People connect to my files, but then quickly disconnect. I see their IP in my peer list for a second, but then it breaks off.

Here's my settings:

* No firewall of any kind (hardware of software)

* Global maximum number of connections: 60

* Enable Upnp mapping: OFF

* Protocol encryption outgoing: ENABLED. Allow legacy connections: YES.

* DHT Disabled

* net.max_halfopen: 4

* peer_lazy.bitfield: true

Is there anything obvious I'm doing wrong? The strange thing is that when I download, the uploading seems to work fine.

Link to comment
Share on other sites

Thanks for the response. I have uTorrent open for ages, but no uploading is taking place.

I turned 'Log peer traffic' on, and this is what the log looks like:

[time] [ip address]: [Ktorrent/1600]: Encrypted handshake completed

[time] [ip address]: [Ktorrent/1600]: Disconnect: connection closed

[time] [ip address]: Connecting port [some number]

[time] [ip address]: Connecting port [some other number]

[time] [ip address]: Disconnect: time out

[time] [ip address] : Disconnect: Peer error: No connection could be made because the target machine actively refused it.

[time] [ip address]: [utorrent/1601]: Encrypted handshake completed

[time] [ip address]: Disconnect: connection closed

And so it goes on and on. Somehow my machine doesn't allow people to download from me, even though they can connect.

Link to comment
Share on other sites

I've had a similar problem as well. At least on the surface, it looks very similar to the problem explained in this thread. I can upload without any problems at all to other people while I have an incomplete file, but the moment I turn into a seeder, all of my peer connections begin dropping.

My logs look exactly the same as yours. I'll be seeding, acquire a peer, begin uploading to them, and all looks fine at first, but usually within ten seconds, the connection gets suddenly dropped. In the log file, it's always the same error: "Disconnect: Connection closed". I've had this problem with all the other Bittorrent clients I've tried. Azureus's log file reads a succession of connections and "{peer} Peer connection closed: connection exception: An existing connection was forcibly closed by the remote host;". The same dropped peers will periodically try to reconnect with me, but the same thing occurs each time.

So I say it, the dropped peers I'm talking about were not other seeders, on nearly all of these torrents there wasn't an excess of seeders to downloading peers, and the same behavior occurs with a large number of different torrents on different trackers. Also, I've made the necessary firewall exceptions, and my port(s) is forwarded properly. I've gone the step of forcing encryption and refusing legacy connections and I have lazy.bitfield enabled. I went for two months or so without any problems using Bittorrent -- everything was in working order -- and then, one day, this started happening.

There doesn't seem to be any pattern to the IPs that get dropped. Everyone gets it.

d_x_b: I'm curious. What's your ISP?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...