Jump to content

Hash Check Fails With New Torrent


Recommended Posts

I create a new torrent

Upload it to the tracker

Download the new torrent (with the passkey)

Start seeding the torrent.

Here's the problem: The pre-seeding hash check fails EVERY time; averaging about 85%-95% completion. And, every time I force a hash check, the errors show up in different parts of the file.

Anyone have a clue as to what is going on? DHT is off. DMZ is off. Game Mode is off. It's a D-Link DI-624 router...

Link to comment
Share on other sites

I downloaded uTorrent 1.5, and have the same problem. I'll try yet another client. I know that the files are not being changed in any way. I read somewhere that other people have had this problem, and the only common denominator was that they all had SATA drives...

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...

I've got the same problem.

Hash check fails every time. Failed pieces are always in different places.

The same happens in Azureus.

Important note: it fails on every large (~5+ GB) file. Small files are ok (not sure that all, but I checked some).

Memtest86 tests said it's ok (8+ hours test).

Didn't try to replace RAM though.

Link to comment
Share on other sites

no, in my case those are hdtv quality movies (5-25 GB in size)

and it's not auto updated someway for sure

the key fact is that just 5 seconds after those 1-2% of "hash failed pieces" have been completed I force recheck and it's not completed again

some times it's even more than initial 1-2%

tonight i'm gonna try other RAM and/or BIOS

because my current RAM (OCZ DDR2 6400) is not in qualified vendor's list of motherboard manufacturer (asus p5k deluxe)

Link to comment
Share on other sites

Here's another possibility: I use an offsite internet backup service that works in the background; automatically backing up any file that has changed. It's possible that the backup client software is "tagging" the file after the torrent is created, which would ruin the hash check?

Now that I think about it, anti-virus software that continually monitors your files could be a culprit as well.

Yet another possibility: This all started when I migrated to a SATA drive. It shouldn't make a difference, but I've heard of other people having problems with certain SATA controllers. The problems were solved by either using a different controller, or switching the SATA controller from IDE to ACPI mode in the BIOS, but the latter is difficult to do AFTER the OS is installed.

Link to comment
Share on other sites

So, 6 hours, lots of tests and... the same reason ConsoleKing had - bad RAM.

Actually, the reason is that my asus p5k deluxe is not compatible in dual channel mode with ocz nvidia sli ready pc 6400. Tried other (2x cheaper) RAM in dual channel - it's ok. Tried mine ocz in single channel mode it's also ok. I mean that there were no errors during hash checking of 5 torrents (10-50 GB in size each). In dual channel mode with my RAM it has passed 2 of 5 with no errors once. But it was an occasion I think, probably set some checks in BIOS or somewhat like that.

And memtest86 is still OK with this dual channel :)

Thank you for help and personal thanks to ConsoleKing.

So, talking to myself :) but may help asus p5k deluxe owners.


OCZ DDR2 PC2-6400 SLI-Ready Edition 2x1 GB dual channel


with Corsair TWIN2X6400C4 (also 2x1 GB duan channel)


that is in asus p5k qualified vendor's list and not a single error!

As I'd mentioned before - memtest86 have found no errors with OCZ.

Seems to be that large torrent files hash check is the best RAM test :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...