Jump to content

Program crashed


Recommended Posts

I had just added a new torrent for DL and went to eat - when I came back I found the program crashed. Said something about creating a dump file, I allowed it to send it and also something about NOD32 - my AV program.

Now the question - is it possible NOD32 is the issue?

Link to comment
Share on other sites

Sorry to hijack this thread but i'm facing a similar problem.

uTorrent 1.7 Beta Build 1355 crashed saying NOD32 IMON caused some problems. Each time i restart the program, i get this error message:


The last beta didn't do this so i don't think this is NOD32's fault. And yeah, i disabled IMON and it's still the same.

Link to comment
Share on other sites

We understand that Lucifer.

We are not blaming NOD32 out of hand. But in our humble opinion and experience it is the most likely culprit. If you properly uninstall it and still get the same error you'll convince us it isn't the likely culprit and we could move on to other possibilities. And although in that case we would like you to keep NOD32 off your system until the real problem has been found you could install it again right away.

In any case as soon as we find the problem you can go right ahead and reinstall NOD32 if you want. Even if NOD32 was causing this trouble for µtorrent its your choice to abandon µtorrent and keep using NOD32. We won't think any less of you :)

Just trying to help.

Link to comment
Share on other sites

@martix: I could actually say the same about NOD32... Is there ANY BitTorrent program NOD32 does *NOT* have a problem with? I mean - just look at the AzureusWiki, and all the posts on the forums!


In all seriousness, though, NOD32 is known to cause problems with P2P, same as ZoneAlarm for some people -- it's simple as that. Kaspersky AntiVirus works perfectly fine with µTorrent, and quite frankly, it's the best antivirus out there (yes, plenty of tests have ranked it at first place).

Link to comment
Share on other sites

oh sorry, i wasn't trying to be rude. It's just that i think it's quite solid that beta 1355 has problems since earlier builds work fine. From your posts, it kinda sounds like the blame is placed on NOD32.

And so, i followed your advice and uninstalled NOD32. Rebooted and no more error message saying IMON crashing uT BUT the memory could not be "read" error is still there. Besides that, explorer.exe will sometimes crash as well.

Ultima : There is no end to the debate which AV is the best. No softwares are built perfect, including NOD32 but it does aim to be one. Some people prefer Kaspersky while others don't, i simply find it too bloated to my taste. I have been using NOD32 for years now and like martix, i would definitely choose to keep NOD32 if it has compatibility issues with uT. I just hope uT developers can find a solution to this problem so everyone can be happy.

And i reinstalled NOD32 since i can't risk my pc getting infected.

Link to comment
Share on other sites

Mm... Alright, that read error comes from something else... In that case, can you get Process Explorer from sysinternals.com, run it, File > Save, then post the contents of the saved process list in the .txt file here?

Also, can you check the properties for µTorrent in Process Explorer to see what's hooked onto the process threads?

Link to comment
Share on other sites

Sure thing.

Process PID CPU Description Company Name

System Idle Process 0 57.28

Interrupts n/a 0.97 Hardware Interrupts

DPCs n/a Deferred Procedure Calls

System 4 4.85

smss.exe 740 Windows NT Session Manager Microsoft Corporation

csrss.exe 796 4.85 Client Server Runtime Process Microsoft Corporation

winlogon.exe 820 Windows NT Logon Application Microsoft Corporation

services.exe 864 2.91 Services and Controller app Microsoft Corporation

svchost.exe 1028 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1108 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1288 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1300 Generic Host Process for Win32 Services Microsoft Corporation

spoolsv.exe 1344 Spooler SubSystem App Microsoft Corporation

spd.exe 1416 cFosSpeed Service cFos Software GmbH

nod32krn.exe 1440 NOD32 Kernel Service Eset

lsass.exe 876 LSA Shell (Export Version) Microsoft Corporation

explorer.exe 1776 Windows Explorer Microsoft Corporation

ctfmon.exe 1808 CTF Loader Microsoft Corporation

nod32kui.exe 1872 NOD32 Control Center GUI Eset

cfosspeed.exe 676 0.97 cFosSpeed Window cFos Software GmbH

outpost.exe 756 Outpost Firewall main module Agnitum Ltd.

utorrent.exe 1020

Opera.exe 1688 Opera Internet Browser Opera Software

procexp.exe 472 29.13 Sysinternals Process Explorer Sysinternals

Click the thumbnail for full view


Link to comment
Share on other sites

Er, sorry, I'd meant to also ask for the stacks on the utorrent.exe threads too, so can you take screenshots of those too and edit the previous post? Thanks :)

I'm not trying to blame everything left and right besides µTorrent, but just to narrow things down, would you mind uninstalling GeSWall temporarily (enable Windows Firewall if you feel unsafe) to make 100% sure it's not what's incompatible with 1.7?

*confuzzled by the issues at hand here*

Link to comment
Share on other sites

Bah... right now security on my comp is with NOD32 and Outpost Firewall - just for me - no-brainer programs. Fast ones too... Virtually no configuration. :)

uT is also like that. :) I don't know about Kasperski AV, haven't tried it. Now I guess, you'll tell me to try it. :P

I'm slowly getting to the conclusion that there is something wrong with the whole P2P/Security/Networking concept. But it'll have to do since we don't have anything better.

Link to comment
Share on other sites

@martix: What version of µTorrent are you using, and when did this start happening? Can you send the crash dump to greg AT bittorrent.com along with a description?

@Lucifer: If uninstalling GeSWall doesn't help, then I'm almost entirely spent on ideas -- the devs might probably be the only people left who'd be able to answer :\ 1170 isn't problematic, right? Do you have any crash dumps on hand?

Link to comment
Share on other sites

martix : You can just use earlier beta builds like 1170 or the stable version 1.6.1

Ultima : Yeah, 1170 didn't have this problem but it seemed to use a lot of VM and CPU usage which caused my pc to slow down. That's why i'm now using v1.6.1. I submitted the crash dump the first time i received the IMON error. I have also deleted the original uT folder and settings just to be safe so the crash dumps are gone.

Link to comment
Share on other sites

Thanks for the process explorer shots Lucifer. When it crashes, do you see a .dmp file anywhere that is produced when the dialog comes up? I'd also try quitting all other applications and uninstalling outpost - maybe we can get the custom crash dialog to show up or a better stack trace....

Link to comment
Share on other sites

If this is about me - I'm willing to think that this is an isolated case. Hasn't happened since, and since I wasn't at the computer at that time I have no idea how I might be able to reproduce it. I have a dump file, when it asked me whether to send it to devs, I allowed, still, I can attach it if you want me to.

Now - that program up there on the thumbs - whats it called?

Link to comment
Share on other sites

The crash dumps were all IMON errors and i have already submitted them. The memory could not be read error will follow right after the IMON error but no crash dumps are generated.

I redownloaded build 1355 and will let it run for a while with NOD32, Outpost and GeSWall installed. Will screen capture the stacks if it crashes again.

EDIT : No crash after 3 days but memory usage is larger than before.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...