Archived

This topic is now archived and is closed to further replies.

patrickbrans

µTorrent Sidebar Gadget Beta

Recommended Posts

In the µTorrent sidebar gadget settings, you need to follow the instructions and enter the word 'blank' for password since you're not using one for the WebUI settings. Otherwise, everything else looks fine.

Share this post


Link to post
Share on other sites

Do you have port 8080 forwarded in your firewall and/or router? Alternately try using a password. Some programs (even Windows sometimes) don't like it when you don't use a password.

Share this post


Link to post
Share on other sites

after weeks... i tried every thing to make it work... did not...

ok so thats my probleme.. i can connect to utorrent from webui but not from the gadget from IE7...

i tried every thing i read every thing nothing works... and i cant even see the lamp icon weird... can some one help??

Share this post


Link to post
Share on other sites
Would be nice if it'd show the active torrents in the main window (similar to the rss feeds gadget)

Uh, if you do this, please make it optional. I use this on my HT-PC and I don't want guests seeing specific things being downloaded, and I also don't want friends bugging me for copies of things listed as being downloaded (not because I mind sharing with them, but because I already have too many things to do). The current situation of requiring a click to see the specific torrents is thus a lot better for me.

And, many thanks for this Gadget !

UPDATE: One "gotcha" to watch out for.

On the gadget, there is a pause button, a stop button, and then a green button (presumably, green for "go").

I pressed the pause button to pause all my currently running torrents - several uploading and one downloading - so that I could download a utility more quickly. When that was done, I pressed the green button, thinking that it was equivalent to "resume paused torrents".

What happened is that every torrent in my utorrent list was started - including a number of torrent files that I had gotten for much later. Fortunately for me, I happened to be out of disk space, so all the downloads failed - otherwise it would have downloaded a bunch of stuff I was not ready for - and ruined my "ratio" at more than one site. :(

The two commands in the utorrent tray icon are "pause" which pauses all currently active torrents - and "resume" which restarts only those ones that were just paused - neither works on stopped torrents.

So, either the green button should be changed from "start all" to "resume all" to parallel the two commands in the utorrent tray icon, or a fourth "resume all" button needs to be added.

Share this post


Link to post
Share on other sites

I found that I had to change the WebUI URL to my IP not just 127.0.0.1, even though I am running it on the same computer as uTorrent. This wasn't a problem but just for people to be warned if they are having troubles with it working.

Share this post


Link to post
Share on other sites

Any chance of having a field where you can input an url and it'll take the .torrent and start downloading? That would be great.

Share this post


Link to post
Share on other sites
Any chance of having a field where you can input an url and it'll take the .torrent and start downloading? That would be great.

It is called drag&drop :)

You click on the .torrent link but you don't release the click.

Drag to the gadget, and when you're on it, release the button and the .torrent will load into you µtorrent (offcourse when the .torrent doesn't need authorization before downloading)

Share this post


Link to post
Share on other sites

As I said in the post about the google gadget I think that the creator of this as well as the google gadget should consider implementing Clearspring widget analytics in order to track the total data being sent by all users of the widget.

As far as implementation I love it, I just hope that when the widget is not docked on the side that it might expand to have a bigger more detailed window.

Share this post


Link to post
Share on other sites

Somehow I can't get the gadget to save/load its settings. Any ideas?

{-Global debug-}

Gadget version: 0.9.1

OS: Microsoft® Windows Vista™ Ultimate

{-End global debug-}

Share this post


Link to post
Share on other sites

Just deleted a long message because I figured a solution, Finally.

I have server 2003 running utorrent webui as a windows process. I installed the gaget on a vista comp on the local network and couldn't get the gadget to work for many.... many.... hours.

I wasn't even getting an error message, just wasn't registering.

I noticed when I clicked the utorrent logo on the flyout it was cutting off part of my password. I changed the settings in webui to a shorter password, edited the profile and now it works.

I'm sure I'm not the first person to run into this problem so heres a little note to anyone perusing forums for hours looking for solutions like I did, all day.

Share this post


Link to post
Share on other sites

Any chance of having the gadget shrink to a smaller size when it cannot reach the WebUI?

I run utorrent at night time only (using scheduler etc) so that it is automatically started at set times.

Basicaly instead of displaying 'check settings' it would display 'Not running.' and take up the minimal amount of room on the sidebar.

Share this post


Link to post
Share on other sites

I cant get it to save either, I just get the default screen that tells me to "open options to choose a profile". "Save" does nothing. I've reinstalled the latest version posted in this thread, i tried restating the computer etc.

Maybe there's some old settings left somewhere from the first beta i installed that needs to be deleted? I have no idea where the gadgets saves their options though.

Any help would be appreciated, this looks like a cool gadget :)

Share this post


Link to post
Share on other sites

ive modified my version to let me know when utorrent is not running, and to have it take up less space if it's not running. much happier with it now :P

capturebr5.jpg

captur1ezw3.jpg

i have also tried to change the background color of the skin to match my other gadgets but i need to find a good, free image editing program that handles transparent pngs :)

Share this post


Link to post
Share on other sites

Quick request:

It would be useful to be able to delete and open torrents up.

In my situation, my torrents download to a network drive and are all accessible via shares etc. If there could be a setting for local path, then it could just open the torrents etc "remotely" via the gadget.

Thanks.

Share this post


Link to post
Share on other sites

ok, here is my situation. The gadget worked great when both utorrent and gadget on the same pc, but now I moved utorrent to my second pc and its not working. I want to monitor utorrent on my second pc. My utorrent port is set to 4321 for example. So I put in the id/password, set the ip to 192.168.1.4(second pc), port 4321, and get nothing on the first pc. I already checked the router and that port is open for that ip.

Share this post


Link to post
Share on other sites

This is driving me mad!

I changed the tab in utorrent to enable webUI and can access it from firefox and another utorrent gadget someone made but I want to use this one with more features. I get this error message when I try and load this gadget: Windows Sidebar Error Unable to load "C:\Users\Big Bad Bruno\AppData\Local\Microsoft\Windows Sidebar\Gadgets\utorrent.gadget".

This is Driving me crazy! I want to use this so bad! I am running windows Vista Ultimate x64 with SP1.

Can someone help? Thanks!

Share this post


Link to post
Share on other sites