Jump to content

Problem with my Comodo Firewall.


Recommended Posts

I was using Utorrent V1.6.1 fine until I decided to do a clean install of XP MCE. Now I have a "clean" system but I am having problem with Speed Guide now and cannot get the ports to forward correctly.

I am using a Netgear WPNT834 (and have not changed the port forwarding settings from the ones that worked a few days ago). This connects to a cable modem.

The PC connects to the Netgear on IP and the Netgear connects to the cable modem DHCP client on IP The PC is using Comodo Pro firewall, and Avast! anti virus.

When I run Speed guide it says Checking port 5555 on Error! Port 5555 does not appear to be open.

However if I disable the Comodo firewall I get Checking port 5555 on OK! Port 5555 is open and accepting connections.

I have tried all sorts of settings in Comodo to try to make things work, but I am just getting very frustrated. Could someone help me please. I have browsed this forum and have tried the various suggestions but have almost given up. I know it worked fine before.....

Link to comment
Share on other sites

Thanks, it's a free firewall, sorry I am not very computer savy. What kind of a rule am I looking to need.

On the network control rules I have tried

Source IP = allow, IP, any

Destination IP = single IP

IP details = IP protocol, any

But I know thats wrong because it didn't work.....

There are three sections that can have rules

Application Monitor, Component Monitor and Network Monitor.

If someone could head me in the right direction I would be very happy - thanks.

Somehow before Comodo had set itself up correctly, but this time not.

Link to comment
Share on other sites

Afaik the monitors work independently. Making a rule for it in the Network Monitor won't help if µtorrent is blocked in the Application Monitor. Make sure µtorrent is allowed in the Application monitor. You can try turning off the Network Monitor to see if it solves the problem. If it doesn't it isn't a Network Monitor problem. If it does see below.

The µtorrent check is a incoming connection with source any and destination IP

Action: Allow

Protocol: TCP or UDP

Direction: In

Source IP: Any

Destination IP: Any

Source Port: Any

Destination Port: A single port: 5555

Try that. You can also try filling in your local IP (Start -=> Run -=> Cmd -=> ipconfig -=> look for the IP-adres line) as destination or try but it should be safe to leave at any since you already told it has to be a incoming connection with the direction option.

Link to comment
Share on other sites

Thanks, I did not realise that I could turn Application Monitor, Component Monitor and Network Monitor on and off independently.

Doing this I found out that the problem was in the Network Monitor section, and the following Comodo rule was the problem.

(Rule #8) Block and Log IP IN or OUT from IP [any] to IP [any] where IPPROTO is ANY

At your suggestion I have added a higher priority rule

(Rule #7) Allow TCP or UDP IN from IP [any] to IP [any] where source port is [any] and destination port is 5555

Success! OK! Port 5555 is open and accepting connections.

Sorry I didn't understand your advice about filling in my local IP, using ipconfig, here is my ipconfig /all result.

Microsoft Windows XP [Version 5.1.2600]

© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\HP_Administrator>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : GKG

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Hybrid

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : NETGEAR RangeMax 240 Wireless US

B 2.0 Adapter WPNT121

Physical Address. . . . . . . . . : 00-18-4D-0C-E1-65

Dhcp Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

IP Address. . . . . . . . . . . . :

Subnet Mask . . . . . . . . . . . :

Default Gateway . . . . . . . . . :

DHCP Server . . . . . . . . . . . :

DNS Servers . . . . . . . . . . . :

Lease Obtained. . . . . . . . . . : Friday, May 11, 2007 9:09:52 AM

Lease Expires . . . . . . . . . . : Monday, May 14, 2007 9:09:52 AM

C:\Documents and Settings\HP_Administrator>

Link to comment
Share on other sites

  • 4 weeks later...

I am having similar problems getting Comodo (which I hear is pretty good for a freebie) to play nicely with utorrent.

In the application monitor, I have utorrent being allowed full reign (TCP/UDP in/out on any ports - is this too generous? Should I be restricting the ports on some of these options?).

In the network monitor, I have created a new rule which is: Allow TCP/UDP in from any IP to any IP where source port is any and destination port is 12777 (the port I have designated in utorrent). This rule is above the generic block rule that Comodo has.

However, downspeeds are very low (0-8 kB/s) and I have the yellow trinagle with exclamation mark saying my network configuration might be wrong.

I do not have port forwarding on (could never get this to work following the instructions that utorrent links to), but this has never been a problem before (used to get speeds above 600 without it).

Q: Do I have the settings in Comodo wrong?

Q: Do I need port forwarding on for utorrent to properly work, or does this just optimise it?

Q: Might the problem be elsewhere?

Any advice much appreciated. In terms of suggestions, I am neither tech savvy or unsavvy, so can follow most step-by-step guides, and general pointers.

Thanks. If I cannot get this to work, might have to move to a different firewall.

Link to comment
Share on other sites

The yellow triangle means your port is not open. You have the proper rule in Comodo so that shouldn't be blocking it. But for this to go green you also need to forward the port in your router. See http://www.portforward.com how to do that with your specific router. This could be the cause of slower speeds.

If it doesn't help. Try disabling all three monitors and see if it increases your speeds.

Low speeds can also be caused by a other things such as:

Slow torrents (try faster torrents. maybe open office. Also don't judge your speed on a short time span.)

ISP blocking/shaping/throttling bittorrent traffic (try forcing encryption)

Router problems (try restarting it, search these forums or google for know problems with your router)

Link to comment
Share on other sites

  • 2 weeks later...

i have put in the rule and assigned it to the top priority (#1 is the highest right?). i also have utorrent as a trusted program which should automatically avoid all this... but i guess not. for some reason im still not getting green. if i hit the 'allow all' option, the red goes green instantly. leaving allow all on defeats the purpose of having a firewall though.

comodo </3 my utorrent.

someone help me please! is there something i missed?

EDIT: im using utorrent 1.6.1 and comodo

EDIT2: false alarm! dont know exactly what i did wrong but it somehow corrected itself after some tinkering. thanks anyway :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...