Jump to content

Error:Incorrect function - after system crash - what means that error?


Recommended Posts

I got a rather large torrent (60 gigs) which i'm 'saving' onto an external USBv2 standard 7200 RPM/8MB cache'd HDD. The torrent was 27.7% completed. The torrent is a multitude of several files, ranging from 1 kbyte to 1 gigabyte. (read: it's NOT one massive archive-file or something like that)

My system crashed overnight, and next morning, trying to continue the download, µtorrent is doing the torrent-check (what is it? a hash-/integrity-check?)

but after 11.7% of the check i get a "Error: Incorrect function". I started digging here, and didnt found much of a solution.

I ran XP's internal HDD file and surface checker, but to no avail. Same issue. Used Paragon HDD Manager Pro v8 to run a defrag of MFT and defrag of the entire partition. I canceled the Partition defrag, ast'd have took over TWO full days to run *ugh*!

still same error (of course, you may say ;-))

then i ran again the XP's internal disk-fixer, took 2 hours, but, after that, the check went fine, and the D/L went on.

Now my Q is, what IS that error "Error: Incorrect function" anyway ? anything specific or some sort of wildcard error, like microsofts "out of memory" back in the old days? :D

here a few specs:

sparse_files = OFF

coalesce_writes = ON - to minimize the writes on the HDD, being ext. USBv2, although 480mbit/s shouldnt be that much of a bottleneck - better safe than sorry @ a 60 gigs torrent ;)

pre-allocate all files = ON - to ensure i'm not fucking over w. the remaining diskspace.

Which version of µTorrent?

1.7 B1672

Which OS?


What type of filesystem (FAT32/NTFS/SMB)?


What type of storage device (USB disk, FW, SATA, IDE, etc)?

USBv2 - external seagate 160 gigs

Which disk device driver?

standard Microsoft windowsXP's/NTFS v5.1.2535.0 from JUL 1st 2001

Any write-intercept type utilities installed (AV etc)?

only Kaspersky Security suite v6 - dont think it's causing any issues, because it can hold up very fine at ~2-3 MBYTE/s D/L (via several torrents) speed and taking maybe 10% CPU - probably thanks to pre-allocation.

I ran

Link to comment
Share on other sites

Its amusing you said this, I run windows XP home and I also had a system crash after I shut down that day, after reinstalling windows, I put utorrent on my pc, I also started receving the "Error: Incorrect funtion" so i shit down my computer for the night, Now I cant get Utorrent up and running at all, on top of that when ever i open Utorrent it freezes my pc and i have to restart... any one have a suggestion on this?

Link to comment
Share on other sites

Ludde once commented on it (you probably found the related topic already). It might have to do with the USB disk driver. But since you solved it with a check I'm gonna assume it was a result of a bad sector or something similar.

elvnsage. Rename the %appdata%\utorrent folder to utorrent_old and see if you can boot µtorrent again. (All settings will be reset and all torrents unloaded)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...