Jump to content

Vista install bug with betas (->beta 1875)


Recommended Posts

With all of the betas, including the latest 1875:

Everytime I start utorrent it asks me if I want to set the startmenu/desktop/quick launch links (it should only ask the first time).

Everytime, when I start utorrent as admin to try to fix this, it deletes the utorrent exe, so I have to copy it again to the program files dir. And the problem still remains...

This is on vista x64.

The right behavior for utorrent would be, like all the other apps are doing, to ask to confirm admin mode when I click to install the shortcuts, but it does not.

Link to comment
Share on other sites

Thanks for the replies.

Yes the shortcuts are created. But I now see there is a 2nd bug with the update process (utorrent.exe is deleted with both bugs when run as admin)

The problem is that utorrent does not ask for admin privileges when doing something that requires them.

The are 2 bugs (same problem): 1 with the shortcuts install and 1 with the update process.

Detailed explanation:

I believe it was the original utorrent 1.6 install package that has first intalled utorrent.exe in c:\program files(x86)\utorrent and placed an utorrent shortcut (which is pointing the the exe in program files) in my start menu.

Since then I have always copied all the utorrent.exe betas to c:\program files(x86)\utorrent, replacing the older version of utorrent.exe.

What now happens, is that as I said, everytime I start utorrent (as a user) there is a popup window that asks me if I want to install the launchmenu/quicklaunch/desktop shortcuts. When I start utorrent as admin and click ok to install the shortcuts, then the next time I want to start utorrent I can't because the **utorrent.exe file is always deleted**.

So I can't start it as admin (I want to do this only 1 time so it won't bug me with the popup window for the shortcuts, this popup bugs me everytime I start it as a user).

AND THERE IS 1 MORE BUG (but same problem):

When I try to update utorrent 1825 to 1875 (automatically, with the update tool in the help menu) it downloads the update but can't install it as I am a user. When I do this as admin the utorrent.exe file gets again deleted, so it does not work (same problem as with the shortcuts).

-> like all the other vista compliant apps, utorrent should popup a window requiring admin privileges when I click "OK" to install the shortcut.

Link to comment
Share on other sites

uTorrent itself a per-user application so it is intended that it will install itself and its shortcuts for the current user. If you want to run it as an admin you need to run it as an admin manually - in vista you can set it up so that every time you run the program it will run as an admin.

Otherwise, since you are running it on a limited user account it will always install itself to "%userprofile%/Program Files". This is why it keeps on asking you - it is in the wrong directory :). Ditto with it deleting itself - it is probably installing itself in a different program files directory - probably "C:\Program Files". Find where the shortcuts are pointing to because that is where it is installed.

It appears that the real problem here you are experiencing is that you can't make the shortcuts without installing it; and I will have to think about that one for a while...

Link to comment
Share on other sites

Ok. If it would install itself in "%userprofile%/Program Files" it would be fine with me. But it does not.

This is what I have now tried:

1. Ran utorrent as admin. Result: it has deleted itself from C:\program files(x86)\utorrent\. And now the shortcut in the start menu is not pointing anywhere.

2. Then I ran the utorrent-1.7-beta-1875.exe I had in D:\download. I wanted to try what you said, so it would install itself in "%userprofile%/Program Files". But it did not. When I closed the application, the file D:\download\utorrent-1.7-beta-1875.exe was deleted (I have write permissions in this directory). So same problem. -> **I had to download the file again**. Also, the shortcuts where not created (I still have the old shortcut in startup menu that is not pointing anywhere)

So If I have write permissions it deletes itself. What should I do ?

For now I keep it in C:\program files (so it does not delete itself), but it still bugs me with the shortcut creating popup every time it starts.


1. When I run it, it does not instal itself anywhere (you say it should install itself in "%userprofile%/Program Files", it does not).

2. If I have write permissions on the utorrent.exe file it deletes itself when I start it.

3. Everytime I start it, it bugs me with the "shortcuts install" (startmenu/desktop/quicklaunch) popup.

Thanks for your help.

Link to comment
Share on other sites


You said: "it will always install itself to "%userprofile%/Program Files". . . . it is probably installing itself in a different program files directory - probably "C:\Program Files".

When I first realized it installed to %userprofile%/Program Files instead of C:\Program Files, I thought it was a bug - but it sounds like it has been designed to do this intentionally? Why? There is no Program Files folder under %userprofile%, so one is created JUST for uTorrent. Its my understanding that %userprofile% is supposed to be for documents, settings, things like that, not the actual program files. :)

Link to comment
Share on other sites

I did some more testing today.

The program files directory was now created in the "useprofile" and utorrent is now there.

It seems alright now, strange it did not work a few days ago.

Link to comment
Share on other sites

Hello guys.

Just registered here because this is a major annoyance to me. I was wondering before why uTorrent.exe would place itself under %userprofile%\Program Files\ rather than under c:\program files.

Reading this post, i was able to reproduce the create-shortcuts-every-start "bug" of MB, this by just forcing the utorrent.exe back to where i want it- C:\Program Files.

Please consider changing this since i really can't stand having utorrent sit in the userprofs! Or name a very,very good reason why an executable should sit somewhere else than all other programs. Please.


Oh well- this is on build 1952 and was so on previous builds as you, the developers certainly know.

My OS is Vista, as you might have guessed already.

Link to comment
Share on other sites


apparently i misunderstood some information some posts up from ryan norton. So i removed this post and wrote a new one :)

Ryan, do i understand you right with this:

to make uTorrent install itself into "C:\Program Files\utorrent" i have to run it as admin, otherwise it will install to the userprof dir?

or did you just say that utorrent will run with admin rights only if i tell it to manually but will always install to userprof no matter what?

if the latter, please redesign. it is a nuisance.

i guess this would be a request then... ;)



Link to comment
Share on other sites

Allright thank you ryan, did try around a bit already, figured this. (am still trying to get used to vistas rather complex security policies ;) )

Still if i install it with administrative privileges and later do not run it with same privileges it will always set up the shortcuts (issue brought up by MB).

would not be a warning instead be more apropriate? something that points out that i do not have the necessary access level to run it? rather than recreating the userprofs-utorrent dir and the shortcuts?


Ryan, did you change something with this behaviour in build 2145?

looks like its not present anymore.

does this have something to do with it (sorry but my understanding of the english language ain't that good):

- Fix: When installing to user profile directory uTorrent now tries to be smarter in choosing a localized program files directory name
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...