Jump to content

CPU Usage Goes Up To 100%


Recommended Posts

Recently, when I save torrents to my secondary HDD, my CPU usage goes up to 100% when they're downloading. When I save torrents to my primary HDD, the complete opposite happens and my CPU usage doesn't go up. I've looked at other threads concerning this problem and on some, it says to go to Start -> Run -> devmgmt.msc and check if any one of my IDE channels are set to "PIO mode". And well... let the images below speak for themselves:



I tried switching to "DMA if available" and restarting, but it didn't works. I even tried uninstalling it and restarting, but it didn't work either. I also tried changing my cache size, but my CPU usage was still high (when saving to my secondary HDD). I also looked at Process Explorer, since it appeared my CPU usage was at 100%, although no apparent process was using this much CPU. It turned out that "Hardware interruptions" was taking up all the CPU. I don't know what I can do at this point. If you can help me, that would be great.

Ok, I just changed the cache size and it seemed to have worked. But µTorrent now, in addition to the 100% CPU usage, uses up to 75MB of memory. Can anyone help?

Link to comment
Share on other sites

You need to remove the controllers from device manager (uninstall them) and restart your computer once or twice to get them out of PIO mode.

Edit: Er, didn't realize you said you tried uninstalling them...


If it remains PIO after all that, then chances are, you have a dying drive and/or a damaged drive cable.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...