Jump to content

uTorrent killing network connection in Vista Home Premium


Recommended Posts


I recently purchased a new computer, a Dell Inspiron 1501 with AMD Turion 64 x2 processor and I am running Vista Home Premium.

Whenever I open uTorrent or any other torrent program (also tried Azureus) and try to start downloading, nothing happens. It finds seeds but doesn't connect and doesn't download. At the same time, all of my other network connections die... I cannot use IE, Firefox, MSN etc to access the internet. I can't even access the browser pages for my wireless router or broadband router (I've tried both wireless and wired) HOWEVER when I go into the command prompt I can ping various websites such as google.com and even the IPs of my routers and receive a quick response.

I have McAfee SecurityCentre and have tried turning off the firewall and I also have given uTorrent and Azureus full access permissions within.

Does anyone have any suggestions as to the cause and solution of my problem?

PS. I made the silly mistake of ringing Dell tech support... the supposed software specialists didn't even know what a torrent was. He told me to turn off my popup blocker, phishing filter and firewall and said my problem was fixed... :rolleyes:

oh and when I close the program, well I just have to stop the torrent, the internet starts working again.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...