Jump to content

Internet Crashes every hour or so (continued)


Recommended Posts

Continued from This Topic

Just thought of sharing this since it seems unsolvable. The net card was tested and it was ok. The cable modem was changed and for a few days it worked alright. When it happened again, I switched the net card with my other PC (which is configured for a city goverment network where I worked so it won't connect at my home or I'd have tested with that box).

It worked alright for 2 weeks and then when I decided to download something with µTorrent, at the seeding it started again and it is like that even now. Connection freezes and only when I hit "repair" on Local Area Connection Status it gets back.

Could it be coincidence that those 2 weeks without any problem I had not used µTorrent at all?

Link to comment
Share on other sites

net.max_halfopen - 8

Ok, this is the one thing I didn't try from the Troubleshooting guides. I'll change its value to 4 as suggested and come back with results.

EDIT: It is still the same. After 10, 30 or 60 minutes uploading, my connection will freeze. Clicking "repair" in Local Area Connection/support will refresh the "DHCP lease" and it is all good again.

I have only green lights on UT and speed is quite normal, very fast indeed. I really don't think it is a UT problem or anything on my system. I imagine that it is either something on my cable provider end (but the signal still arrives very good), perhaps their DHCP server, or they might be identifying my UT traffic, despite encryption and causing it to freeze, somehow. Could that be possible?

I need to test my connection with my wife's laptop but she has so much network stuff on it that it doesn't reckognize my cable IP/DNS settings. She has a wireless card, network card for her office adsl connection and a dialer for her dial-up connection when those others two are not available. The dialer (uol.com.br) is quite intrusive. UOL is part of some stupid news company that has this thing that messes with registry and policies but I think I can overcome that by setting it manually. Brazilian version of AOL.. lol

EDIT 2: I could get the notebook connected alright but then, she doesn't have µTorrent and there was no problem with connection for the hour I had it on. Downloaded some streamming videos but problem is that I could not upload anything from that laptop, even to my website. She doesn't have anything heavy there and my conn probs happen when I am seeding huge files. Smaller one can get thru before the freezing strikes! Guess I'll have to live with it... *sighs* or I might try the Beta 1.7 and see if it still happens.

Link to comment
Share on other sites

My cable is contracted for 2Mb/330Kb - My settings are upload capped at 20kB/s when downloading and "unlimited" when not - but I keep it at 25kB/s when browsing the web. When not and unlimited applies, I can upload at 30-36kB/s as displayed in µTorrent lower status bar.

I just got frozen while UT was not working as I was going to run the tests. It has nothing to do with UT, I can feel it. But I still appreciate any help you guys can provide as my ISP claims that everything is perfect and cannot detect any problem or help me any further

Earlier today I got this from Fort Worth, TX

1553/132 Net Virtua 2000/300 anon São Paulo

Now I got:

1926.8 kbps at http://medidor.interair.com.br/ (also in Rio)

From 300 kbps to 1700 kbps at http://www.rjnet.com.br/ (dslreports brazilian link)

They gotta be crowded and Rio-São Paulo have some poor connection or heavy traffic at this hour (1pm here now). I get as good or better latency to any server in the US. Also, there's no upload test in both brazilian sites I tested. My latency to Rio de Janeiro servers is 100ms from command prompt ping)

Remade it at Forth Worth with 130ms latency

1373/150 Net Virtua 2000/300 anon São Paulo

Also got 2064.3 kbps - 253 KB/sec at http://www.ip2.com.br/ (again, no upload test)

They all, including dslreport US servers seem more reliable than the brazilian link of dslreport. sorry but lol.

EDIT: My bad. There are plenty test sites listed under BraZil. I thought it had only only as there is only one listed under BraSil (which is the correct form too). Problems of a country with different spelling name. =)

Link to comment
Share on other sites

Done. Set to 15 and I'll let you know if the freezing happens again.

But still, I had never had any problems with that, either when I had a 256 ADSL and used ABC or after I got the 2Mb cable and got µTorrent for best d/l speed. It just used my full upload band when I had no other use.

This problems started some 2 weeks before I first posted on original topic. That's some 6 months and some 70GB d/l - 86GB u/l - after I had UT. So up to that point, it worked perfectly.

I was thinking that it might have something to do with my deleting some VPN auto configured by Zone Alarm. I don't have or use a VPN. It appeared while using UT though. But there is no VPN mention anywhere on UT website, faq or help.

Since I tested it after uninstalling and reinstalling ZA, I believed that is not the cause. I may be wrong but I can't see how to set a VPN back. Za never "detected" it again.

I can't see why my connection freezes while I can still ping my card, my modem but not the gateway, until a simple click on "repair" does fix it. The cable tech guy burned his hair on this, tried a new cable modem and it still happens just like that. Idem for the new network card. Higher tech people from Cable provider support also have no idea of what may be causing it. Still they claim it is not on their end.

HijackThis, SB-search&destroy, AVG, AVG antyspyware and KAV platinum have detected nothing. I guess I've lost some hair over it as well.

Link to comment
Share on other sites

Have you tried setting both half open limit in µTorrent very low (like 1-4) AND reducing global and per-torrent connection max rather low, like only 20-50? I'm thinking the router's buffers overflow, this was especially likely with stuff like Belkin routers with their extremely long timeout intervals for connections.

Link to comment
Share on other sites

Yes, Ultima, I followed the "SLOW/INTERRUPTED INTERNET CONNECTION OR OFFLINE TRACKERS while µTorrent is running" fuly now. I had Max global at 230, auto set by speed guide. I reduced it to 160/40 per torrent. Patched TCP/IP and set half max open to 4 yesterday.

Now I've just reduced it again to 60 global - 20 per torrent.

But the freezing still happened with up speed capped at 15KBps. Very sad for having to say that.

And as I have said, I think that while µTorrent is running are the key words. Although the freezing happens mostly when UT is running (because long uploads tend to keep running for many hours), it does happen when µTorrent is not running at all.

That's why I have mentioned a few times that I don't think it has anything with UT alone. Something prevents my connection, at somepoint, from reaching a node farther than my cable modem and a simple "repair" click fixes it. It is so weird. I could swear it might be something at one of the cable provider's DNS server, and it has the same IP as the DHCP server. And it seems that DHCP is not auto-acquiring a new lease at some point but the freezing happens in a period where the "lease" is valid for a few more hours still.

I'd be preparing my spirit for a new re-format but I have done one in March, I'm almost out of space on my backup HD, (10 of 160Gb free) and I'd kill myself if after a format the problem still showed. (main HD still has some 45GB free so it is not a space problem I am sure)

I don't use a router, Switeck. My cable modem is a Scientific-Atlanta WebSTAR DPC2100 / Modem Serial Number 202776160 / Cable Modem MAC Address 00:14:f8:cb:e1:34 / Hardware Version 2.0 / Software Version v2.0.2r1244-050506 / Receive Power Level 7.8 dBmV / Transmit Power Level 42.5 dBmV / Cable Modem Status Operational.

I am out of ideas as well. I'll leave UT settings as per your guidance for a while and keep hitting the "repair" button, which is the only thing bad about this problem: I cannot leave home if I want to seed and sometimes download ininterruptedly (although it rarely happens when d/l'ing only but it does happen when UT is not running). But again, UT works quite fine at full capacity (ie. half-speed open 8, DHT enabled, max global 230-80, ip resolving on, unpatched TCP/IP.sys.. all the opposite of the current settings that still see the freezing happens).

I might switch it all back if no solution is found. At least I can upload at 33KBps for the same period I can at 15 before having to hit "repair" again. Might allow me to leave home sooner. :lol:

If any more info is required, I'll have a full Everest report ready. Thanks a lot for the time and attention.

EDITed for minor corrections.

Link to comment
Share on other sites

Yes I did, Disabled all 4 boxes in DHT area and disabled IP resolving in peers window. And after every change I'd restart the PC and the modem, just to make sure I followed the instructions.

As these interruptions happen whether UT is running or not, I also tried other stuff: (but the problem still happens within a wide range of time. Sometimes in 10 minutes after a "repair", sometimes 3 hours after, sometimes 48 hours after. It is weird as hell I must say)

-changing the cable modem. Cable co. tech guy did it.

-changing network card and installing the new on a different slot in MoBo.

-changing settings in AntySpyXP, also in AVG antispyware AntySpy section.

-uninstall and reinstall fresh ZAlarm.

-downloading the very new version of NetLimiter Monitor freeware and uninstalling the old version prior to install.

-running UT with NetLimiter shut off.

-updating and running a full scan with SpyBot Search & Destroy.

-checking every tool provided with SB S&D.

-updating and running a full scan with AVG Anti-Spyware.

-Updating and running a full scan with AVG 7.5

-running a full scan with RootkitRevealer by SysInternals.

-checking every service, shell hook and driver I disabled with AutoRuns by SysInternals.

-checking every Policy item on GPedit (not configured for all connection section).

-checking every Service I disabled or turned to manual start (as per The Elder Geek on Windows XP website's guide and my own experience which pretty much match the guide).

-running full scans with MV RegClean 5.0, RegCleaner and SuperCleaner.

Link to comment
Share on other sites

No, that indeed I haven't done. I have bad memories from when I installed XP SP0 in a new computer long ago. Immediately after finishing windows install I had 3 virus trying to send data out. (stupid me forgot to unplug the adsl cable). Of course there was no data to be sent but still, I hate windows frailty.

I can try that but I have never enabled windows built-in firewall after disabling it. I wouldn't risk with no FW though. Is Windows Firewall trustworthy?

I had never had troubles with Za and UT or any other program I had set permission on before but it may be worthy the try too.

Link to comment
Share on other sites

You should definitely try uninstalling ZA and testing. Windows Firewall is perfectly reliable for blocking unauthorized/unrecognized incoming connections, so go right ahead and use it. Just make sure µTorrent's exception has been added to the exceptions list.

Link to comment
Share on other sites

Fully uninstalled ZA and cleared registry after. Tried a download with UT and it took only 15 minutes to freeze. UT was already in the exception list and I am sure that even if UT were not running, it would have frozen just the same. Pitty. Even if ZA was to blame for the problem and I would feel a fool for not having tested it long before today, I'd still be happy for having it solved.

But it is not ZA as it is not UT. I finished seeding this afternoon and until now (12am) I had not used UT and my connection froze quite a few times in the period. I'll reiterate the complaint to the cable co. and have them checking at their end now. That's all I can think of: it must be at their end.

Thanks again.

Link to comment
Share on other sites

My system is P4 2.8GHz, 1GB RAM, 2x 160GB hd's running WinXP SP2 Corporative with Longhorn package (cosmetics really) with all updates from WindizUpdate.

And thanks for the tip on TCP optimizer. Seems good. Who knows what may solve this crazy problem. That might be it =)

Link to comment
Share on other sites

Go evil and try the reverse route:

See if you can jack µTorrent's settings way up so it crashes your connection in less than 1 minute flat.

Then, once the connection is "crashed", see if resetting your computer but NOT your modem helps.

If it doesn't, then try turning the modem off for 30 seconds and then back on...then wait a minute for it to be ready to use...and see if your connection is "like new".

This should allow you to tell if the problem is computer-specific, modem-specific, or a combination of both.

If nothing else, it's sometimes nice to know you can crash your own computer "on demand". :P

Link to comment
Share on other sites

Eh.. I need some help for that. Can't make it happen or wouldn't know how.

I've restored UT to original settings with half max open = 8,

Connection type xx/384k (as that is my real speed even if test cannot show it, I do upload at that speed since I contracted the cable for that speed), 230 Global connection / 80 per-torrent, DHT enabled, IP resolving enabled and I actually suffered fewer connection freezes than when I nerfed them all. In either cases, my speed is not affected. I still get 170-250KB/s for well seeded torrents and upload at 30-36KB/s.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...